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Safety Instructions 
Instrucciones de seguridad 
Sicherheitshinweise 
Consignes de sécurité 
 
  

  

Risk of injury and instrument damage 

The instrument must be used in an appropriate manner to prevent 
electric shock, fire, personal injury or instrument damage. 

● Do not open the instrument casing. 
● Read and observe the "Basic Safety Instructions" delivered as 

printed brochure with the instrument. 
● Read and observe the safety instructions in the following sections. 

Note that the data sheet may specify additional operating conditions. 
● Keep the "Basic Safety Instructions" and the product documentation 

in a safe place and pass them on to the subsequent users. 

   
 

 
  

  

Riesgo de lesiones y daños en el instrumento 

El instrumento se debe usar de manera adecuada para prevenir 
descargas eléctricas, incendios, lesiones o daños materiales. 

● No abrir la carcasa del instrumento. 
● Lea y cumpla las "Instrucciones de seguridad elementales" 

suministradas con el instrumento como folleto impreso. 
● Lea y cumpla las instrucciones de seguridad incluidas en las 

siguientes secciones. Se debe tener en cuenta que las 
especificaciones técnicas pueden contener condiciones adicionales 
para su uso. 

● Guarde bien las instrucciones de seguridad elementales, así como 
la documentación del producto, y entréguelas a usuarios 
posteriores. 
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Gefahr von Verletzungen und Schäden am Gerät 

Betreiben Sie das Gerät immer ordnungsgemäß, um elektrischen 
Schlag, Brand, Verletzungen von Personen oder Geräteschäden zu 
verhindern. 

● Öffnen Sie das Gerätegehäuse nicht. 
● Lesen und beachten Sie die "Grundlegenden Sicherheitshinweise", 

die als gedruckte Broschüre dem Gerät beiliegen. 
● Lesen und beachten Sie die  Sicherheitshinweise in den folgenden 

Abschnitten; möglicherweise enthält das Datenblatt weitere 
Hinweise zu speziellen Betriebsbedingungen. 

● Bewahren Sie die "Grundlegenden Sicherheitshinweise" und die 
Produktdokumentation gut auf und geben Sie diese an weitere 
Benutzer des Produkts weiter. 

   
 

 

 
  

  

Risque de blessures et d'endommagement de l'appareil 

L'appareil doit être utilisé conformément aux prescriptions afin d'éviter 
les électrocutions, incendies, dommages corporels et matériels. 

● N'ouvrez pas le boîtier de l'appareil. 
● Lisez et respectez les "consignes de sécurité fondamentales" 

fournies avec l’appareil sous forme de brochure imprimée. 
● Lisez et respectez les instructions de sécurité dans les sections 

suivantes. Il ne faut pas oublier que la fiche technique peut indiquer 
des conditions d’exploitation supplémentaires. 

● Gardez les consignes de sécurité fondamentales et la 
documentation produit dans un lieu sûr et transmettez ces 
documents aux autres utilisateurs.  
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1  Preface
The R&S SGS is a signal generator intended either for the generation of IQ-modulated
signals or as a pure local oscillator (LO) source.

Optimized for use in automated test equipment (ATE), the instrument offers fast settling
times in an exceptionally small form factor and low power consumption. The R&S SGS
can be equipped optionally with an active electronic step attenuator, a high stability ref-
erence oscillator and LO connectors for coupling multiple generators to a common LO
source.

1.1  Key Features

The key features of the R&S SGS include the following:

● Compact size and low power consumption
● Remote connection via PCI Express, minimizing the setup time

Alternatively, LAN or USB connections available
● Coherent LO input and output connectors, also usable as MIMO input/output and

phase coherent I/Q demodulation
● Broadband analog input for vector modulation (I, Q)
● Linux operating system
● Graphical user interface R&S SGMA-GUI to set up and control one or more

R&S SGS instruments simultaneously from one remote computer, available for
Windows and Linux systems

1.2  Documentation Overview

This section provides an overview of the R&S SGS user documentation. Unless speci-
fied otherwise, you find the documents on the R&S SGS product page at:

www.rohde-schwarz.com/manual/sgs100a

1.2.1  Getting Started Manual

Introduces the R&S SGS and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

1.2.2  User Manual and Help

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control commands

Documentation Overview

http://www.rohde-schwarz.com/manual/sgs100a
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with programming examples, and information on maintenance, instrument interfaces
and error messages. Includes the contents of the getting started manual.

The contents of the user manuals are available as help in the R&S SGS. The help
offers quick, context-sensitive access to the complete information.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.2.3  Service Manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS, https://gloris.rohde-schwarz.com).

1.2.4  Instrument Security Procedures

Deals with security issues when working with the R&S SGS in secure areas. It is avail-
able for download on the Internet.

1.2.5  Basic Safety Instructions

Contains safety instructions, operating conditions and further important information.
The printed document is delivered with the instrument.

1.2.6  Data Sheets and Brochures

The data sheet contains the technical specifications of the R&S SGS. It also lists the
options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/sgs100a

1.2.7  Release Notes and Open Source Acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open source acknowledgment document provides verbatim license texts of the
used open source software.

See www.rohde-schwarz.com/firmware/sgs100a

Documentation Overview

https://gloris.rohde-schwarz.com
http://www.rohde-schwarz.com/brochure-datasheet/sgs100a
http://www.rohde-schwarz.com/firmware/sgs100a
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1.2.8  Application Notes, Application Cards, White Papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/sgs100a.

1.3  Typographical Conventions

The following text markers are used throughout this documentation:

Convention Description

"Graphical user interface ele-
ments"

All names of graphical user interface elements on the screen, such as
dialog boxes, menus, options, buttons, and softkeys are enclosed by
quotation marks.

[Keys] Key and knob names are enclosed by square brackets.

Filenames, commands,
program code

Filenames, commands, coding samples and screen output are distin-
guished by their font.

Input Input to be entered by the user is displayed in italics.

Links Links that you can click are displayed in blue font.

"References" References to other parts of the documentation are enclosed by quota-
tion marks.

Typographical Conventions

http://www.rohde-schwarz.com/application/sgs100a
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2  Preparing for Use
● Putting into Operation............................................................................................. 16
● Linux Operating System..........................................................................................22
● Connecting an External PC and Devices................................................................22

2.1  Putting into Operation

This section describes the basic steps to be taken when setting up the R&S SGS for
the first time.

Risk of injury and instrument damage
The instrument must be used in an appropriate manner to prevent electric shock, fire,
personal injury, or damage.
● Do not open the instrument casing.
● Read and observe the "Basic Safety Instructions" delivered as a printed brochure

with the instrument.
In addition, read and observe the safety instructions in the following sections.
Notice that the data sheet may specify additional operating conditions.

Risk of instrument damage due to inappropriate operating conditions
Specific operating conditions are required to ensure accurate measurements and to
avoid damage to the instrument. Observe the information on appropriate operating
conditions provided in the basic safety instructions and the instrument's data sheet.

Instrument damage caused by electrostatic discharge
Electrostatic discharge (ESD) can damage the electronic components of the instrument
and the device under test (DUT). Electrostatic discharge is most likely to occur when
you connect or disconnect a DUT or test fixture to the instrument's test ports. To pre-
vent electrostatic discharge, use a wrist strap and cord and connect yourself to the
ground, or use a conductive floor mat and heel strap combination.

Putting into Operation
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Risk of instrument damage due to inappropriate operating conditions
An unsuitable operating site or test setup can damage the instrument and connected
devices. Before switching on the instrument, observe the information on appropriate
operating conditions provided in the data sheet. In particular, ensure the following:
● All fan openings are unobstructed and the airflow perforations are unimpeded. A

minimum distance of 10 cm to other objects is recommended.
● The instrument is dry and shows no sign of condensation.
● The instrument is positioned as described in the following sections.
● The ambient temperature does not exceed the range specified in the data sheet.
● Signal levels at the input connectors are all within the specified ranges.
● Signal outputs are connected correctly and are not overloaded.

2.1.1  EMI Suppression

Electromagnetic interference (EMI) may affect the measurement results.

To suppress generated Electromagnetic Interference (EMI):
● Use suitable shielded cables of high quality. For example, use double-shielded RF

and LAN cables.
Note: USB cables are of varying and often poor quality. Therefore, check the qual-
ity of each individual USB cable as described in the service manual.

● Always terminate open cable ends.
● Note the EMC classification in the data sheet

2.1.2  Unpacking and Checking the Instrument

Unpack the R&S SGS carefully and check the contents of the package.

● Check if all items listed on the delivery note, including this getting started manual,
are included in the delivery.

● Check the R&S SGS for any damage.
If the contents are damaged, immediately contact the carrier who delivered the
package.

Packing material
Retain the original packing material. If the instrument needs to be transported or ship-
ped later, you can use the material to protect the control elements and connectors.

Putting into Operation
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Risk of injury during transportation
The carrying handles at the front and side of the casing are designed to lift or carry the
instrument. Do not apply excessive force to the handles. If a handle is ripped off, the
falling instrument can cause injury.

2.1.3  Accessory List

The instrument comes with the following accessories:

● Power cable
● Getting started printed manual

2.1.4  Placing or Mounting the Instrument

The R&S SGS is designed for use under laboratory conditions, either on a bench top
or in a rack using a rack adapter kit (order number see data sheet).

Bench top operation

If the R&S SGS is operated on a bench top, the surface should be flat. The instrument
can be used in horizontal position, standing on its feet.

Putting into Operation
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Risk of injury and instrument damage if stacking instruments
A stack of instruments may tilt over and cause injury. Furthermore, the instruments at
the bottom of the stack may be damaged due to the load imposed by the instruments
on top.
Observe the following instructions when stacking instruments:
● Never stack more than three instruments with the same dimensions (width and

length). If you need to stack more than three instruments, install them in a rack.
● The overall load imposed on the lowest instrument must not exceed 500 N.
● All instruments should have the same dimensions (width and length).

If you need to stack smaller instruments on the top, the overall load imposed on the
lowest instrument must not exceed 250 N.

● If the instruments have foldable feet, fold them in completely.

Rack mounting

The R&S SGS can be installed in a rack using a rack adapter kit (Order No. see data
sheet). The installation instructions are part of the adapter kit.

Risk of instrument damage due to insufficient airflow in a rack
If you mount several instruments in a rack, you need an efficient ventilation concept to
ensure that the instruments do not overheat. Insufficient airflow for a longer period can
disturb the operation and even cause damage.

2.1.5  Switching the Instrument On and Off

The R&S SGS is automatically adapted to the AC voltage supplied. There is no need
to set the voltage manually or change fuses. The [AC supply and power switch] is at
the rear of the unit.
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To connect the AC supply

► Connect the R&S SGS to the AC power source using the AC power cable deliv-
ered with the instrument.

Note: The instrument is in compliance with safety class EN61010-1.
Connect the instrument only to a socket with earthing contact.

To start up the instrument

1. Connect the instrument to the AC supply.

2. To turn on the power, press the main power switch to position I (On).

To switch between standby and ready state

► Press the [POWER ON /STAND BY] key briefly to switch the instrument from the
standby to ready state or vice versa.

In ready state, the button is green. The instrument is ready for operation. All mod-
ules are power-supplied and the R&S SGS initiates its startup procedure.
In standby state, the button is orange. The standby power mode keeps the power
switch circuits and the remote control system active.

Start-up and booting

The instrument boots the operating system and starts the instrument firmware. During
the booting process, the green [POWER ON /STAND BY] key blinks. If the previous
session was terminated regularly, the instrument uses the last setup with the relevant
instrument settings.

Once the startup procedure has been terminated, the instrument is ready for operation.

In the R&S SGMA-GUI, select "Instrument > Preset" function to return the instrument
to its defined reset/preset state, if the current setup is no longer relevant.

To customize the start settings, use the "SGMA-GUI > File > Save As/Open" function.

To shut down the instrument

To shut down the R&S SGS, proceed as described below.
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Risk of losing data
If you switch off the running instrument using the rear panel switch or by disconnecting
the power cord, the instrument loses its current settings.
Always press the [POWER ON/STANDBY] key first to shut down the application prop-
erly.

1. Press the [POWER ON /STAND BY] key to save the current setup, shut down the
operating system and set the instrument to standby state.

The [POWER ON /STAND BY] LED must be orange.

Tip: If the instrument is operated manually via the R&S SGMA-GUI, select "SGMA-
GUI > Instrument Name > Setup > Standby".

2. To turn the power off, press the main power switch to position 0 (Off).

None of the front-panel LEDs should be on.

2.1.6  Function Check

The instrument automatically monitors the main functions when it is switched on and
monitors them continuously during operation.

A detected fault is indicated by an "Error" message displayed in the info line of the
R&S SGMA-GUI together with a brief error description. For an in-depth identification of
the error, press the "SGMA-GUI > Info" button. In response, a description of the errors
is displayed. For more information, refer to the "Error Messages" section in the user
manual.

In addition to the automatic monitoring, the R&S SGS offers the following capabilities
to ensure correct functioning:
● Internal Adjustments

In the R&S SGMA-GUI, select the "Instrument > Setup > Internal Adjustments" dia-
log to access the dialog for performing and configuring the adjustments settings. A
maximum level accuracy can be obtained, for instance.

● Selftest
A selftest is provided for service purposes ("SGMA-GUI > Instrument > Diagnostic/
Test > Self Test").

2.1.7  Default Settings

When the instrument is switched on, it is not the preset state that is active, but rather
the instrument state that was set before the instrument was switched off. It is recom-
mended that you use the "SGMA-GUI > Instrument > Preset" function to return the
instrument to its defined preset state every time a new configuration is required or the
current setup is no longer relevant.
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The R&S SGS offers a two-stage preset concept:
● Preset the instrument to a predefined state

The "SGMA-GUI > Instrument Name > Preset" function calls up a defined instru-
ment setup. All parameters and switching states are preset (also these of inactive
operating modes). The default instrument settings provide a reproducible initial
basis for all other settings. However, functions that concern the integration of the
instrument into a measurement setup are not changed.

● Preset the instrument to its factory settings
The instrument can also be forced to load its default factory settings. To access the
corresponding dialog box, select the "SGMA-GUI > Instrument Name > Setup >
Factory Preset" function.
For more information and an overview of the settings affected by the factory preset
function, see Chapter 8.11, "Factory Preset", on page 142.

User-defined instrument states can be stored and called up using the functions
"SGMA-GUI > File > Save As/Open".

2.2  Linux Operating System

The instrument uses an embedded Linux operating system, optimally adapted to the
instrument.

Accessing the operating system
No access to the operating system is required for normal operation.
All necessary system settings can be made in the "Setup" dialog.

2.3  Connecting an External PC and Devices

As a rule, the R&S SGS is operated exclusively via remote control on a connected PC.
Another way to control the instrument is the manual operation via the R&S SGMA-GUI
software on the connected PC.

Both the remote control and the manual operation of the instrument require an external
controller. For the prerequisites and the instructions on how to configure an external
controller for remote control, refer to the user manual. A brief introduction to the remote
control capabilities is provided in Chapter 10, "Network and Remote Control Opera-
tion", on page 162.

This section gives an introduction on how to configure the external PC for manual
operation (see Chapter 2.3.1, "Installing the R&S SGMA-GUI Software", on page 23).

In addition to connecting an external controller, it may be useful to connect other exter-
nal devices, e.g. a memory stick. The following interfaces are provided on the rear
panel of the instrument, see also Chapter 3.2, "Rear Panel Tour", on page 33:

Connecting an External PC and Devices
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● PCI Express (refer to Chapter 2.3.3, "Connecting a Controller via PCI Express",
on page 28

● USB interface (refer to Chapter 2.3.4, "Connecting a Controller or a USB Device
via USB", on page 28)

● LAN interface (refer to Chapter 2.3.2, "Connecting a Remote PC via LAN",
on page 24)

2.3.1  Installing the R&S SGMA-GUI Software

The R&S SGMA-GUI software is a graphical user interface program for one or more
instruments. It runs on a remote PC.

The R&S SGMA-GUI software is provided as separate installation package for the dif-
ferent operating systems. The latest version of the software together with the release
notes is available for download at:

http://www.rohde-schwarz.com/product/SGS100A.html > "Downloads" > "Software"

This page always offers the latest information on your R&S SGMA-GUI.

This description focuses on the handling of the Windows-32 version. The file naming
conventions and the installation instructions for the other operating systems are analo-
gous.

The R&S SGMA-GUI installation package for Windows-32 operating system consists
of the file SGMA-GUI_<V.VV.VVV.VVV>.exe. The version numbers in the file names
vary with each update. To install the R&S SGMA-GUI, the following hardware and soft-
ware requirements have to be met.

Table 2-1: Hardware and software requirements

Requirement Remark

One of the following operating sys-
tems:
● Windows Vista
● Windows 7
● Windows 8/ 8.1
● Windows 10
● Linux

R&S SGMA-GUI has to be installed on one of the supported operat-
ing systems. Also, the version of the operating system must be still
supported by Microsoft.

Note:

Any other Windows version or other operating systems are not sup-
ported.

During installation, the operation system is checked.

The installation is terminated if this requirement is not fulfilled.

R&S VISA VISA drivers can be obtained on the Rohde & Schwarz website:

http://www.rohde-schwarz.com/rsvisa

CPU At least Pentium or compatible, as from 1 GHz (recommended).

VGA color display resolution At least 800*600 pixels

Connecting an External PC and Devices
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Installing a new software version

Administrator rights are necessary for installation and starting.

1. Download the R&S SGMA-GUI software.

2. In Windows Explorer, double-click SGMA-GUI_V.VV.VVV.VVV.exe. Follow the
instructions.

After the installation of the R&S SGMA-GUI software, two icons will be shown in your
Windows menu: one is the standard version and one for which the remote command of
the software through SCPIs is disabled. The SCPI disabled version allows you to install
and use the R&S SGMA-GUI on other instruments, without interfering with the remote
control of the host instrument.

Start the version that is required for your application.

Uninstalling an old software version

An uninstallation of a previous version of the SW can be performed before the installa-
tion of the new one, but this is not mandatory.

► To uninstall this version, go to "Start > Settings > Control Panel > Add/Remove
Programs" and select the entry SGMA-GUI_V.VV.VVV.VVV.

The script file identifies and removes all currently installed R&S SGMA-GUI soft-
ware items.

2.3.2  Connecting a Remote PC via LAN

The R&S SGS is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The interface can be used, for example:

● To connect an external computer for manual control of the instrument by the R&S
SGMA-GUI software.

● To operate the device by a remote control program.
See Chapter 10, "Network and Remote Control Operation", on page 162.

Connecting an External PC and Devices
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This section describes how to configure the LAN interface. It includes the following top-
ics:

● Chapter 2.3.2.1, "Connecting the Instrument to the Network", on page 25
● Chapter 2.3.2.2, "Assigning the IP Address", on page 26
● Chapter 2.3.2.3, "Automatically Adding Instruments to the SGMA-GUI ",

on page 27

2.3.2.1  Connecting the Instrument to the Network

There are two methods to establish a LAN connection to the instrument:

● A non-dedicated network (Ethernet) connection from the instrument to an existing
network.

● A dedicated network connection (Point-to-point connection) between the instru-
ment and a single computer.

In both cases, an IP address has to be assigned to the instrument and the computer,
see Chapter 2.3.2.2, "Assigning the IP Address", on page 26.

Risk of network failure
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses

Errors can affect the entire network.

Setting up a non- dedicated network (LAN) connection

► Connect the instrument to the network or to a single PC.

If the instrument is connected to the LAN, the operating system automatically
detects the network connection and activates the required drivers.
By default, the instrument is configured to use dynamic TCP/IP configuration and
obtain all address information automatically.

Setting up a dedicated network connection

If your network does not support DHCP, you can set a dedicated network connection
between a stand-alone PC and a R&S SGS

Prerequisite: the computer and the R&S SGS are turned on and running.

1. Start the R&S SGMA-GUI.

2. Connect the computer and the R&S SGS with a LAN network cable.

3. Wait for about one minute for the automatic assignment of IP addresses to com-
plete.

Connecting an External PC and Devices
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4. R&S SGMA-GUI main panel, select "Setup > Instruments".

5. In the "Configure Instruments" dialog, click "Scan".

The new instrument should appear with a Zeroconf IP address 169.254.xx.yy

6. Assign a static IP address to the instrument, see "Assigning a static IP address to
the R&S SGS" on page 26.

7. Assign a static IP address to the PC, see "Assigning a static IP address to your
Windows-PC network card" on page 27.

8. Edit the instrument settings, see Chapter 6.4.2.5, "How to Edit Instruments",
on page 69

2.3.2.2  Assigning the IP Address

Depending on the network capacities, the TCP/IP address information for the instru-
ment can be obtained in different ways.
● If the network supports dynamic TCP/IP configuration using the Dynamic Host

Configuration Protocol (DHCP), all address information can be assigned automati-
cally.

● If the network does not support DHCP, the instrument tries to obtain the IP address
via Zeroconf (APIPA) protocol. If this attempt does not succeed or if the instrument
is set to use alternate TCP/IP configuration, the addresses must be set manually,
see "Setting up a dedicated network connection" on page 25.

The R&S SGS uses the Zeroconf IP addresses 169.254.xxx.yyy., where xxx takes val-
ues between 1...254 and yyy the values in the value range 1...255; the subnet mask is
always 255.255.0.0. The IP address of the host must be within the same address area
for Zeroconf.

By default, the instrument is configured to use dynamic TCP/IP configuration and
obtain all address information automatically. This means that it is safe to establish a
physical connection to the LAN without any previous instrument configuration.

Assigning a static IP address to the R&S SGS

Prerequisites: A connection is established between the R&S SGS and the controller
with installed SGMA-GUI.

For how to setup a LAN connection, see Chapter 2.3.2.1, "Connecting the Instrument
to the Network", on page 25.

For how to set up a USB connection, see "Setting up a USB connection from a PC to
the R&S SGS" on page 29.

1. Open "SGMA-GUI > Instrument > Setup > Network Settings" dialog.

2. Set the "Address Mode" to "Static".

3. Enter the "IP Address", for example 192.168.0.1..
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4. Enter the "Subnet mask", for example 255.255.255.0.

5. Enter the "Default Gateway", for example 192.168.0.1.

Assigning a static IP address to your Windows-PC network card

1. Obtain the IP address and subnet mask for the R&S SGS and the IP address for
the local default gateway from your network administrator. If necessary, also obtain
the name of your DNS domain and the IP addresses of the DNS and WINS servers
on your network. If you use more than one LAN connector, you need separate
address information for each connector.

2. Press the "Windows" key to access the operating system.

3. Open the "Control Panel" by selecting "Start > Settings > Control Panel".

4. Select "Network and Sharing Center".

5. In the left panel, click "Change adapter settings".

6. Select the network adapter you want to change. Click "Change settings of this con-
nection".

7. On the "Networking" tab, click "Internet Protocol Version 4 (TCP/IPv4)". Select
"Properties".

8. Select "Use the following IP address" and enter the address information as
obtained from the network administrator.

9. If necessary, you can also select "Use the following DNS server addresses" and
enter your own DNS addresses.

For more information, refer to your Windows system Help.

2.3.2.3  Automatically Adding Instruments to the SGMA-GUI

For information on how to install the R&S SGMA-GUI software, refer to Chapter 2.3.1,
"Installing the R&S SGMA-GUI Software", on page 23.

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Press the [POWER ON /STAND BY] key to switch on the instrument.
c) Wait until the [POWER ON /STAND BY] LED is green and not blinking.
d) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

3. Open the "Instruments" dialog and click "Scan".
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Note: This step is performed automatically on the first start and can also be omit-
ted for instruments with a direct LAN connection to the computer.

All instruments are added automatically to the main panel of the SIGMA-GUI.

2.3.3  Connecting a Controller via PCI Express

A PCI Express connector is provided on the rear panel of the instrument, see Chap-
ter 3.2, "Rear Panel Tour", on page 33.

Risk of device failure
The R&S SGS is equipped with a single lane PCIe interface that supports hot plugging.
Do not connect an external PC to the PCIe connector of the instrument during opera-
tion if this external PC does not support hot-plugging!

Using the PCIe interface for remote control of the instrument requires extended knowl-
edge. Refer to Chapter 10.3, "Advanced Remote Control Using PCIe", on page 172
for detailed information.

2.3.4  Connecting a Controller or a USB Device via USB

The USB interface on the rear panel of the R&S SGS allows you to connect either a
USB device or use the R&S SGS as a device and connect it to a controller.

Connecting a controller (host PC or compatible signal generator)

If you connect a controller (host PC or compatible signal generator) to the R&S SGS,
the R&S SGS acts as a USB device.

To connect the controller to the USB interface of the R&S SGS, always connect the
USB type Micro-B connector to the R&S SGS. Refer to the documentation of the con-
troller to find out which USB connector type you can connect to the controller.

The Figure 2-1 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 2-1: USB type Micro-B connectors

An external PC with installed R&S SGMA-GUI is required for manual operation of the
R&S SGS.

Connecting an External PC and Devices
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Setting up a USB connection from a PC to the R&S SGS

If your network does not support DHCP, you can set a USB connection between a PC
and a R&S SGS.

Prerequisite: the computer and the R&S SGS are turned on and running.

1. Start the R&S SGMA-GUI.

2. Connect the computer and the R&S SGS with a USB cable.

The new instrument should appear automatically.
If the instrument does not appear automatically, you can open the "Setup > Instru-
ments > Configure Instruments" dialog and click "Scan".

3. If your network does not support DHCP, you can now set a static IP address to
your computer.

a) Assign a static IP address to the instrument, see "Assigning a static IP address
to the R&S SGS" on page 26.

b) Assign a static IP address to the PC, see "Assigning a static IP address to your
Windows-PC network card" on page 27.

c) Edit the instrument settings, see Chapter 6.4.2.5, "How to Edit Instruments",
on page 69

Connecting a USB device

If you connect a USB device (memory stick, CD-ROM, an instrument) to the R&S SGS,
the R&S SGS acts as a host.

To connect a USB device to the interface of the R&S SGS, always connect the
USB type Micro-A connector to the R&S SGS. Refer to the documentation of the USB
device to find out which USB connector type you can connect to the USB device.

The Figure 2-2 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 2-2: USB type Micro-A connectors

If you connect an R&S SGS to an R&S SGU via a USB cable, perform the steps as
described in Chapter 5.2, "Setups for Connecting an R&S SGS and an R&S SGU",
on page 42.
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Using a USB Adapter
You can use a USB adapter to customize the connectors of a USB cable to the require-
ments of the instrument.
For example, you can use a Type-A / Micro-A adapter to customize a standard USB
cable with type A and type Micro-B connectors for the connection of an R&S SGS (act-
ing as a host) to an R&S SGU (acting as a USB device).
In some cases, you can also use a Type-A / Micro-B adapter to establish a connection
to the instrument. To check, whether the adapter you have is suitable or not you can
connect a USB stick with an LED through the adapter to the instrument. If the LED of
the USB stick lights up after a connection to the instrument then you can use this
adapter for further applications with the instrument.

Connecting an External PC and Devices
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3  Instrument Tour
The following topics help you get familiar with the instrument and perform the first
steps:
● Front Panel Tour
● Rear Panel Tour

This section explains the control elements and the connectors of the R&S SGS with
the aid of the front and rear views. Specifications of interfaces can be found in the data
sheet.

3.1  Front Panel Tour

This section provides an overview of control elements on the front panel of the
R&S SGS. The connectors of the R&S SGS are placed on the rear panel and are
described in Chapter 3.2, "Rear Panel Tour", on page 33. As the R&S SGS is inten-
ded to be remote-controlled, the front panel of the R&S SGS contains no display but
mostly LEDs to inform you about the status of the instrument. The user interface can
be displayed on a remote PC station used to manually remote control the instrument.

Figure 3-1: Front panel view

[POWER ON /STAND BY]

The [POWER ON /STAND BY] key switches the instrument from the standby to ready
state or vice versa.

In ready state, the button is green. The instrument is ready for operation.

In standby state, the button is orange. In this state, it is safe to switch off the AC power
and disconnect the instrument from the power supply.

A blinking green color indicates that a booting operation is in process.

[RF ON]

Front Panel Tour
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The [RF ON] key switches the RF signal on or off. If activated, the button is green.

[REF EXT]

The [REF EXT] LED indicates the status of the external reference.
● Green indicates that the instrument can synchronize to the external clock.
● Red indicates that the instrument cannot synchronize to the external clock.
● No light indicates that the internal reference is used.

[ERROR / WARNING]

The [ERROR / WARNING] LED indicates the status of the R&S SGS.
● Red indicates that an error has occurred, e.g. temperature exceeded or power fail-

ure.
● Blinking orange indicates a running process (e.g calibration, self test).
● No light indicates that no errors or warnings have occurred.
For details on errors or warnings, refer to the graphical user interface on a remote PC
("SGMA-GUI > Info").

For more information, refer to the "Error Messages" section in the user manual.

[LAN]

The [LAN] key indicates if a LAN connection is established.

Green LED indicates that a network cable is connected to the instrument and no error
in the DHCP connection is detected. But it does not indicate that the remote control
connection is established for all cases. For example, if the instrument is set to use a
"Static" IP address the instrument may still not be visible in the network.

Pressing the key resets the LAN interface settings, i.e the "IP Adress Mode" is reset to
DHCP.

[ID]

Pressing the [ID] key while the instrument is active, opens the "SGMA-GUI > Setup >
Instruments > Configure Instruments > Edit Instrument" dialog of the corresponding
instrument on the remote controller.

Front Panel Tour
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Pressing the ID key of an inactive instrument and starting "SGMA-GUI > Setup >
Instruments > Scan", leads to an automatic activation of the instrument in the SGMA-
GUI.

3.2  Rear Panel Tour

This section provides an overview of the connectors on the rear panel of the instru-
ment. For technical data of the connectors, refer to the data sheet.

Figure 3-2: Rear panel view

Risk of damaging components
Always use an appropriate 8 mm torque wrench to tighten SMA connectors. Limit the
tightening torque to 60 Ncm. Never use an open-end wrench.

[PCI Express Connector]

The PCIe (Peripheral Component Interconnect Express) single lane interface allows
remote control with optimized speed.

For details, see Chapter 2.3.3, "Connecting a Controller via PCI Express", on page 28.

[USB Connector]

The USB (universal serial bus) interface, type micro, allows you to connect various
external devices, e.g.:
● If the interface is configured as a device interface, the R&S SGS can be connected

to other devices like a remote computer. On the computer, you can perform a firm-
ware update, manual operation via the R&S SGMA-GUI software or for remote
control of the instrument.

Rear Panel Tour
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● If the interface is configured as a host interface, a memory stick for file transmis-
sion can be connected.

For details, see Chapter 2.3.4, "Connecting a Controller or a USB Device via USB",
on page 28.

[LAN Connector]

The [LAN] (Ethernet) interface allows you to connect the R&S SGS to other devices
like a remote computer. On the computer, you can perform a firmware update, manual
operation via the R&S SGMA-GUI software or for remote control of the instrument. The
connection to the remote computer can be direct or via a network.

For details, see Chapter 2.3.2, "Connecting a Remote PC via LAN", on page 24.

[RF OUT]

Provides an RF 50 Ohm signal output.

NOTICE! Maximum input levels. Do not overload the RF output. The maximum permis-
sible back-feed is specified in the data sheet.

[I , Q]

SMA female type connectors that are inputs of the I/Q modulator, provided for feeding
of external signal.

NOTICE! Maximum input levels. Do not overload the I and Q inputs. The maximum
permissible voltage is 1V. For details, refer to the data sheet.
Note: The I/Q modulator requires one of the hardware options R&S SGS-B106V/-
B112V.

[REF / LO IN, REF / LO OUT]

Rear Panel Tour
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SMA female type connectors, for reference or local oscillator signals, and alternatively
also in MIMO setups.

Reference input and output:
● [REF IN]: Input for external reference signal.
● [REF OUT]: Output of internal reference signal.
Local oscillator input and output:
● [LO IN]: Input for external LO signals
● [LO OUT]: Output of internal LO signals.
Note: The local oscillator input/output requires the additional software option
R&S SGS-K90.

[TRIG]

Multi-purpose connector. The [TRIG] connector is used mainly as an input connector
for an external pulse modulator source.

[AC supply and power switch]

The AC supply and power switch allow you to connect the R&S SGS to the power sup-
ply and switch on the instrument.

For details, see "To connect the AC supply" on page 20.

Rear Panel Tour
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4  First Steps with the Instrument
This section provides examples on how to configure the R&S SGS to generate a con-
tinuous wave (CW) signal via the R&S SGMA-GUI and the R&S SGS100A Web-GUI.

4.1  Configuring a CW Signal with the R&S SGMA-GUI

The R&S SGS in this example is a base unit equipped with the frequency option
R&S SGS-B106.

As a prerequisite for this example, the R&S SGS has to be connected to a remote PC.
The R&S SGMA-GUI software has to be installed on this remote PC and the instru-
ment is added to the list of "Available Instruments".

Figure 4-1: Example of the setup

For information on how to fulfill these requirements, refer to
● Chapter 2.3.2.1, "Connecting the Instrument to the Network", on page 25
● Chapter 2.3.1, "Installing the R&S SGMA-GUI Software", on page 23
● Chapter 2.3.2.3, "Automatically Adding Instruments to the SGMA-GUI ",

on page 27

1. Check the front panel of the R&S SGS.

The [POWER ON/STANDBY] and [LAN] key have to be green.

2. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application opens. The panel provides a quick access to the
main settings of the configured and activated instruments. The display shows one
row per instrument with the instrument-specific settings. The rows comprise the
instrument, the connection state, the used frequency and power level, the state of
the RF output and the modulator and the used reference frequency source.

Configuring a CW Signal with the R&S SGMA-GUI
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3. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

4. In the R&S SGMA-GUI main panel, select the row corresponding to the instrument
to be configured and select "Instrument Name > Preset" to restore the predefined
instrument's settings.

5. In the R&S SGMA-GUI main panel, select the row corresponding to the instrument
to be configured and adjust the "Frequency" as required.

6. Select "SGMA-GUI > RF On" to enable the output of the CW signal.

The 5 GHz signal is output at the [RF OUT] connector at the rear panel of the
R&S SGS.

Configuring a CW Signal with the R&S SGMA-GUI
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Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". The green [LAN] LED on the front panel of the instrument blinks.
● Press the [ID] key on the instrument's front panel. The "Edit Instrument" dialog of

the respective instrument opens.

4.2  Configuring a CW Signal with the R&S SGS100A Web-
GUI

The R&S SGS100A Web-GUI is an alternative way to operate the R&S SGS. There is
no installation needed. It can be used with all devices and operating systems, including
tablets and smart phones, which have one of the following web browsers installed:

● Mozilla Firefox
● Google Chrome
● Microsoft Internet Explorer 9 or later

To connect to the R&S SGS from an external device, both of them must have access to
the same network, i.e. use a shared network.

The feature set of the R&S SGS100A Web-GUI is limited to the most common settings,
needed especially for modifying the output signal. For additional actions like firmware
updates or adjustments, please use the R&S SGMA-GUI.

You can operate the R&S SGS100A Web-GUI and the R&S SGMA-GUI simultane-
ously. Furthermore you can enable the "Update" function (upper right corner) to allow
an automatic update of the settings shown in the R&S SGS100A Web-GUI, if the set-
tings were changed via other software.

As a prerequisite for this example, the R&S SGS has to be connected to the same net-
work as the device used for controlling the instrument. Also one of the supported web
browsers has to be available.

1. Check the front panel of the R&S SGS.

The [POWER ON /STAND BY] and the [LAN] key have to be green.

2. Open a supported web browser.

3. Enter the instrument name or the IP address of the R&S SGS you want to connect
to.
Tip: The default hostname of the instrument is a non case-sensitive string built as
follows:
hostname = rssgs100a<serial number>, where
<serial number> is the individual serial number of the instrument.

Configuring a CW Signal with the R&S SGS100A Web-GUI
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The serial number is displayed at the rear side of the instrument. It is the third part
of the device ID printed on the bar code sticker, see Figure 4-2.

Figure 4-2: Serial number of the R&S SGS100A

The main panel of the R&S SGS100A Web-GUI opens.

In the R&S SGS100A Web-GUI main panel, the green indicator "System Status >
OK " confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.
If you want to get additional information about the instrument, click on the "Device
Name". For additional information on other settings, hold the mouse cursor over
the specific setting.
Error messages are also displayed in the R&S SGS100A Web-GUI. If you want to
hide an error message, click on it.

4. In the menu bar on the left side press "Preset" to restore the predefined instru-
ment's settings.

5. Select "Frequency" and adjust the setting as required.

6. Select "RF On" to enable the output of the CW signal.

A signal with the set frequency is output at the [RF OUT] connector at the rear
panel of the R&S SGS.

Configuring a CW Signal with the R&S SGS100A Web-GUI
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5  System Overview
The R&S SGS RF Source is a signal generator intended either for the generation of
IQ-modulated signals or as a pure local oscillator (LO) source in the frequency range of
1 MHz to 12.75 GHz.

Optimized for use in automated test equipment (ATE), the instrument offers very fast
settling times in an exceptionally small formfactor and low power consumption. The
R&S SGS can be equipped optionally with an active electronic step attenuator, a high
stability reference oscillator and LO connectors for coupling multiple generators to a
common LO source.

5.1  Setups for Instrument Control

The R&S SGS is an instrument designed for the automated test equipment (ATE)
needs. To maintain the small size, the instrument is not equipped with a display and
hence additional equipment is required to control the instrument.

This section provides an overview of the possible configuration setups for controlling
the R&S SGS.

5.1.1  Manual Operation from the R&S SGMA-GUI

The following example represents a basic configuration of the R&S SGS, operated
manually by the configuration software R&S SGMA-GUI. The configuration software is
installed on a remote PC and controls several instruments. The instruments are con-
nected to the remote PC over different remote control interfaces. Any combination of
the used interfaces is possible.

Figure 5-1: Configuration example: manual control from R&S SGMA-GUI

For information about the manual control, refer to:
● Chapter 6, "Understanding the R&S SGMA-GUI Software", on page 53
● Chapter 7, "Signal Generator Settings", on page 80
● Chapter 8, "General Instrument Settings and Instrument Setup", on page 128

Setups for Instrument Control
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5.1.2  Remote Control from a Controller

The remote control provides access to the instrument's settings from a remote com-
puter (external controller) by means of remote commands. To automate often repeating
settings and settings sequences, these are grouped in the remote control programs,
i.e. application programs.

An instrument may be connected to the controller via any of the supported interfaces
LAN, USB or PCIe.

Figure 5-2: Configuration example: remote control from a controller

For information about remote control, refer to:
● Chapter 10, "Network and Remote Control Operation", on page 162
● Chapter A, "Remote Control Basics", on page 291

5.1.3  Control of an R&S SGS from an R&S Signal Generator

The R&S SGS can be used as an additional signal source to increase the number of
available RF outputs of a R&S Signal Generator. In this setup, a controller does not
need to access the R&S SGS directly. Instead, the signal generator acts as a controller
to the R&S SGS and depending on the required output signal parameters performs all
required settings automatically.

The Figure 5-3 shows a configuration example of the R&S SGS, directly controlled by
a R&S SMW.

Figure 5-3: Configuration example: Control from a R&S SMW

Setups for Instrument Control
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5.2  Setups for Connecting an R&S SGS and an R&S SGU

If an R&S SGU is connected to an R&S SGS, the R&S SGU acts as an extension to
the R&S SGS extending its frequency range. In this setup, a controller does not need
to access the R&S SGU directly. Instead, the R&S SGS acts as a controller to the R&S
SGU. The generator performs all required settings automatically depending on the
required output signal parameters.

This chapter gives an overview of how to connect the instruments.

See:
● Chapter 5.2.1, "Direct Connection", on page 42
● Chapter 5.2.2, "Connection in a Company Network", on page 43
● Chapter 5.2.3, "Connection with a PCIe Switch", on page 46
● Chapter 5.2.4, "R&S SGU as an Extension to the R&S SGS", on page 47

5.2.1  Direct Connection

The R&S SGS and the R&S SGU can be connected through a direct connection as
shown in Figure 5-4.

Direct connection of an R&S SGS and an R&S SGU

Figure 5-4: Direct connection of an R&S SGS and an R&S SGU

1. Connect the R&S SGS and the R&S SGU directly using one of the following
options:

a) USB cable. Use a Type Micro-A connector for R&S SGS and a Type Micro-B
connector for R&S SGU. See also Chapter 2.3.4, "Connecting a Controller or a
USB Device via USB", on page 28.

b) LAN cable. No additional cable considerations are required.
c) PCIe cable. Refer to Chapter 10.3.4, "Connecting the Controller and the Instru-

ment", on page 176 for cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

The R&S SGS automatically identifies the connected R&S SGU as its extension
and starts the extension mode.

Setups for Connecting an R&S SGS and an R&S SGU
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For a direct PCIe connection, an automatic identification of the R&S SGU as an exten-
sion is only available for an R&S SGS with a "Controller > Revision" 5 or higher. For a
description on how to manually set the PCIe identification, see Chapter 9.14, "How to
Manually Set a PCIe Direct Connection between an R&S SGS and an R&S SGU",
on page 161.
You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

If instrument is not automatically added as an extension
If the R&S SGU is not automatically added as an extension you can do that manually
in the "SGMA-GUI > R&S SGS Name > Extension" dialog.
If the R&S SGU is not listed in the list of "Available Instruments", you can press "Scan
> Start" to find the instrument.

5.2.2  Connection in a Company Network

Connection of an R&S SGS and an R&S SGU in a Company Network

As a prerequisite for this example the R&S SGMA-GUI software has to be installed on
a remote PC.

Setups for Connecting an R&S SGS and an R&S SGU
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Figure 5-5: Connection of an R&S SGS and an R&S SGU in a company network

1. Connect the test equipment as shown in Figure 5-5:

a) Connect the R&S SGS, the R&S SGU and the controller to the company net-
work.

b) Connect the [RF OUT] of the R&S SGS to the [LO IN] of the R&S SGU.

2. Switch on the R&S SGS and the R&S SGU.

The [POWER ON/STANDBY] keys have to be green and not blinking.

3. Press the [ID] keys on the front panels of the R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.

Note: If you connect the instruments to the company network for the first time this
process may take several minutes.

Setups for Connecting an R&S SGS and an R&S SGU
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5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

6. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Tip: Instrument doesn't appear in the extension dialog. If the R&S SGU is not auto-
matically shown in this dialog press "Scan > Start" to find the instrument.

7. Select the R&S SGU from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU.
The R&S SGMA-GUI indicates the extended frequency range of the R&S SGS and
the activated extension mode.

8. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

Setups for Connecting an R&S SGS and an R&S SGU
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The diagram displays the connection state of the tested signal connections. If the
test connections are correct (shown by an uninterrupted blue line), you can start
using the R&S SGS and the R&S SGU in extension mode.

Tip: If your connection is marked as faulty- a red line is crossing the blue connec-
tion line - check whether the cables are connected properly. Check also if the con-
nection cables are functioning properly.

Figure 5-6: A faulty connection between an R&S SGU and an R&S SGS

5.2.3  Connection with a PCIe Switch

The R&S SGS and the R&S SGU can be connected through a PCIe switch as shown
in Figure 5-7. This setup is recommended for achieving the highest setting/ measuring
speeds.

Setups for Connecting an R&S SGS and an R&S SGU
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PCIe switch connection of an R&S SGS and an R&S SGU

Figure 5-7: Connection of an R&S SGS and an R&S SGU through a PCIe switch

1. Connect the PCIe switch to a switched off computer with a single lane PCIe cable.

2. Connect the R&S SGS and the R&S SGU to the PCIe switch.

3. Switch on the R&S SGS and the R&S SGU.

The [POWER ON/STANDBY] keys of both instruments have to be green and not
blinking.

4. Switch on the computer.

5. On the computer start one of the following:

a) The R&S SGMA-GUI
b) An application program for remote control of the instruments

6. Manually (or remotely ) activate the R&S SGU as an extension to the R&S SGS.

The logical connection between an R&S SGS and an R&S SGU is established by the
driver layer of a program (e.g. the R&S SGMA-GUI) or the library PCIeController.dll
(Linux: libpciecontroller.so) of a remote control program on the PC. Such a program
has to be running on the PC so that an R&S SGS is able to communicate with an R&S
SGU.

5.2.4  R&S SGU as an Extension to the R&S SGS

In case the R&S SGU is connected to a compatible R&S signal generator, a controller
only needs to talk to the signal generator which in turn takes care of the proper settings
for the R&S SGU.

In the following example, the instrument is manually operated via the R&S SGMA-GUI
software. The R&S SGU in this example is a base unit equipped with the frequency
option R&S SGU-B120.

Configuring the R&S SGU to upconvert a CW signal generated by the R&S SGS

As a prerequisite for this example the R&S SGMA-GUI software has to be installed on
a remote PC.

Setups for Connecting an R&S SGS and an R&S SGU
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Figure 5-8: Example of a test setup for upconverting a CW signal generated by the R&S SGS

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

1. Connect the test equipment as shown on Figure 5-8:

a) Connect the R&S SGS, R&S SGU and the controller to a LAN switch.
b) Connect the [RF OUT] of the R&S SGS to the [LO IN] of the R&S SGU.
c) Connect the [TRIG] connectors of the R&S SGS and the R&S SGU.
d) Connect the [RF OUT] of the R&S SGU to the [RF IN] of the signal analyzer.

2. Switch on the R&S SGS and the R&S SGU.

The [POWER ON/STANDBY] keys have to be green and not blinking.

3. Press the [ID] keys on the front panels of the R&S SGS and the R&S SGU (only
required if the components are connected via a company network).

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured and
activated instruments. The display shows one row per instrument with the instru-
ment specific settings. The rows comprise the instrument, the connection state, the
used frequency and power level and the state of the RF output and the modulator.

Setups for Connecting an R&S SGS and an R&S SGU
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5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

6. In the R&S SGMA-GUI main panel, select the rows corresponding to the corre-
sponding instruments to be configured and select "Instrument Name > Preset" to
restore their predefined settings.

7. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Tip: Instrument does not appear in the extension dialog. If the R&S SGU is not
automatically shown in this dialog, press "Scan > Start" to find the instrument.

8. Select the R&S SGU from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU.
The R&S SGMA-GUI indicates the extended frequency range of the R&S SGS and
the activated extension mode.

Setups for Connecting an R&S SGS and an R&S SGU
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9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

10. Select "SGMA-GUI > R&S SGS > Freq = 40 GHz", "Lev = -30 dBm".

11. Select "SGMA-GUI >SGS> RF > State > On" to enable the output of the CW sig-
nal.

Setups for Connecting an R&S SGS and an R&S SGU
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The extension adopts these values and states automatically and generates a CW
signal with RF = 40 GHz and Level = -20 dBm.

The signal is output at the [RF OUT] connector on the rear panel of the R&S SGU.

Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". The green [LAN] LED on the front panel of the instrument blinks.
● Press the [ID] key on the instrument's front panel. The "Edit Instrument" dialog of

the respective instrument opens.

5.3  Introduction to the Instrument Functions

This section is intended to give a brief introduction to the instrument's function. The
description of the related user interface parameters is provided in the corresponding
section in Chapter 7, "Signal Generator Settings", on page 80.

For detailed information on how to work with the instrument and to perform basic and
advanced operating and configuration tasks, refer to Chapter 9, "Performing Configura-
tion Tasks", on page 147.

The Figure 5-9 provides a simplified block diagram of the instrument.

For better understanding of the instrument functions and the signal flow, the block dia-
gram shows the main blocks of the instrument together with the corresponding GUI
parameters.

Introduction to the Instrument Functions
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Figure 5-9: Simplified Block Diagram

TCXO = Built-in reference oscillator
OCXO = Oven-controlled oscillator, requires hardware option

R&S SGS-B1
Synth. = Synthesizer
I/Q Mod = I/Q Modulator
REF/LO IN, REF/LO OUT, I, Q, RF OUT = Connector at the rear panel
"Ref. Osc. Source", "REF/LO Out", "LO Coupling
Source", "Mod On/Off", RF On/Off", "Operation
Mode"

= R&S SGMA-GUI equivalent parameter

The instrument can generate a CW or an I/Q modulated signal ("Mod On/Off"). The fre-
quency and level settings are adjustable ("Level", "RF on/Off", "Frequency"). The
instrument can use its internal reference frequency or a fed-in external one ([REF/LO
IN], "Ref. Osc. Source"). The reference frequency can also be output for synchroniza-
tion purposes ([REF/LO OUT], "REF/LO Out"). The local oscillator (LO) signal can be
distributed in such a way, that two or more instruments are connected to generate
phase coherent signals ("LO Coupling Source", [REF/LO OUT], "REF/LO Out").
Whereas both possibilities, the input of the reference frequency and the input of a LO
signal, exclude each other because they use the same connectors. The same applies
for the output of the reference frequency and the LO signal. The instrument can also
be configured to work in the special baseband bypass mode ("Operation Mode").

Refer to Chapter 9, "Performing Configuration Tasks", on page 147 for an overview of
the general operating tasks. The Chapter 9.1, "How to Generate an I/Q Modulated Sig-
nal", on page 147 explains the basic operating concept by means of an example.

Introduction to the Instrument Functions
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6  Understanding the R&S SGMA-GUI Soft-
ware
This section gives a detailed description of the R&S SGMA-GUI user interface and
information on how to work with it. The main panel with the overview of the configured
instruments is the operating and control interface for the whole program. From here, all
program functions are accessible. This panel is displayed after the start of R&S SGMA-
GUI. The program always loads the previously used settings so you can continue your
work in the next session.

6.1  Operating Menu and Toolbar

On the top of the main panel, there are the menu bar, the toolbar and the info bar with
the corresponding "Info" button. Some of the functions are accessible via the toolbar
with its icons below the menu selection line.

The dialogs are built using elements, e.g., selection lists, checkboxes, and entry fields.
A blue frame indicates that the selected item is active. In a highlighted element, entries
can be made.

Table 6-1: Content of the operating menu

File Setup Help

 New Instruments About

 Open Software Contents

Save Reset SGMA-GUI Index

 Save as Remote  

Operating Menu and Toolbar
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File Setup Help

Exit Protection  

Shut down instruments and exit   

6.1.1  File Menu

The R&S SGMA-GUI employs the standard Save/Recall file management function and
allows you to store and reload settings in/to a file with a user-defined name and loca-
tion (see also Chapter 6.4.1, "Storing and Loading Settings", on page 67).

In the following, the "File" menu of the R&S SGMA-GUI is described in detail. It incor-
porates standard functions.

New
Resets R&S SGMA-GUI and all connected instruments to their preset settings.

Open
Opens the standard file open browser for loading a saved R&S SGMA-GUI file
(*.savrcl). The file contains the user-specific settings of a session, such as instru-
ments configured in the software. The complete settings of a session can be saved
and loaded.

Only files of this type are selectable.

Note: Instrument-specific settings, e.g. frequency and level settings, are stored locally
on the particular instrument itself. These instruments settings are saved automatically
in a predefined directory and loaded by default when starting the instrument again.
The files with instrument settings are not accessible.

Save
Standard quick save of the settings of the current session if a filename previously has
been applied. If not, the "Save As" dialog is opened.

Save as
Opens the standard file save browser for saving the settings of the current session.
R&S SGMA-GUI files have the file extension .savrcl so the name typed in is equip-
ped with this extension. The complete settings of a session are saved.

Exit
Quits the R&S SGMA-GUI. The current settings of the instrument's session are saved
and loaded by default when starting the software again.

Note: The instruments configured in the R&S SGMA-GUI are not shut down.

Shut down instruments and exit
Quits the R&S SGMA-GUI and switches the connected instruments to the standby
state (see alsoChapter 9.9, "How to Switch between the Operating States",
on page 156 ).

Operating Menu and Toolbar
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6.1.2  Setup Menu

The setup menu provides access to dialogs for setting the general settings of the soft-
ware, like dialogs for managing the connected instruments or dialogs providing infor-
mation about the installed options.

6.1.2.1  Configure Instruments

This dialog is the central point for managing the instrument that is configured and oper-
ated via the R&S SGMA-GUI. New instruments can be created and appended to the
list of available instruments. Connection settings can be edited, instruments can be
removed from the list or they can be deactivated, but kept in the list for further use.

Refer to Chapter 6.4.2, "Handling Instruments in the R&S SGMA-GUI", on page 68
for information on how to configure and manage instruments in R&S SGMA-GUI.

Available Instruments
This section comprises a list of configured instruments. Each instrument is represented
by a "Symbolic Name" which is also displayed in the main panel and an "Instrument
Type". It is also displayed whether the instrument is activated in the R&S SGMA-GUI
and hence displayed in the main panel or not.

Remote command: 
:INSTruments:COUNt? on page 76
:INSTruments:NAME on page 77
:INSTruments:TYPE on page 79
:INSTruments:ACTive[:STATe] on page 76

Scan
Triggers a scan function and searches for instruments connected to the remote com-
puter via all the available interfaces. During the scan process, a progress bar is dis-
played.

Operating Menu and Toolbar
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Tip: The first initialization of a newly connected instrument in a network and the instru-
ment's request to the DHCP server for an IP address may take some time. During this
time, the instrument does not respond to the query sent by the scan function. If the
instrument does not appear in the list of "Available Instruments", trigger the scan func-
tion again after some minutes.

Remote command: 
:INSTruments:SCAN on page 78

New Instrument
Calls the Add/Edit Instruments dialog.

Delete Instrument
Removes the selected instrument from the list of Available Instruments.

Edit Instrument
Calls the Add/Edit Instruments dialog.

Clear Instrument
Removes all instruments from the list of Available Instruments.

Export
Opens the standard file save browser for saving the list of the available instruments in
a mapping file. The mapping files have the file extension .map so the filename typed in
is automatically equipped with this extension.

A mapping file provides a cross-reference between the instruments' symbolic names
and their respective remote control parameters. The information in the mapping file is
grouped in rows, where one row corresponds to one configured instrument. The rows
have the following structure:
<InstrumentType> <SymbolicName> <IP_Address/Hostname>
<RemoteChannel> <SerialNumber>

Figure 6-1: Mapping file example

Tip: In a remote control application program, address the instruments by their symbolic
names and retrieve the remain required settings from the mapping file. This workflow is
especially useful for frequent exchange of instruments.

Remote command: 
:INSTruments:MAPPing:FILE on page 77

Operating Menu and Toolbar



Understanding the R&S SGMA-GUI SoftwareR&S®SGS100A

57User Manual 1173.9105.02 ─ 12

Scan LAN instruments with host name prefix
Sets the prefix the searched host names begin with. Use this function to limit the
amount of the searched instruments and to speed up the scan process.

For example, set this field to "RsSGS, RsSGU, RsSGT", if you want to search for all
available instruments.

Tip: If you start a scan for an instrument with a set IP address and it does not appear
in the list of available instruments it may be due to the prefixes written in this field. You
can perform another scan while leaving this field empty.

Remote command: 
:INSTruments:SCAN:HNPRefix on page 78

6.1.2.2  Add/Edit Instruments

The dialog provides access to the main instrument's settings, such as "Symbolic
Name", "Instrument Type" and connection settings.

Refer to Chapter 6.4.2, "Handling Instruments in the R&S SGMA-GUI", on page 68
for information on how to configure and manage instruments in R&S SGMA-GUI.

Instrument Nr.
Automatically assigned number that indicates the instrument's index in the list of "Avail-
able Instruments".

Symbolic Name
Selects the alias name of the instrument.
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Remote command: 
:INSTruments:NAME on page 77

Instrument Type
Selects the instrument's family.

Remote command: 
:INSTruments:TYPE on page 79

Active
Activates/deactivates the display of the instrument's settings in the main panel.

Note: Only instruments in an active state can be controlled from the R&S SGMA-GUI!

Remote command: 
:INSTruments:ACTive[:STATe] on page 76

Exclusive Access
Checks whether the instrument is locked by another user and if not locks the instru-
ment. When an instrument is locked, it is reserved and can be operated manually or
remote exclusively from the remote PC on which the R&S SGMA-GUI is running or
from which the SCPI command is sent.

For interfaces using VISA, i.e. for LAN and USB, enabling the "Exclusive Access" trig-
gers the standard viLock request. For remote control over PCIe or Socket, the lock
request is performed on a higher application level.

Note: It is recommended to lock the instrument before further configuration.
Locked instruments are not found by the scan function.
The instrument has to be unlocked to allow operation from another remote PC.

Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.
Disable "Exclusive Access" if the instrument is monitored by an external PC.

Remote command: 
:INSTruments:EACCess[:STATe] on page 76
:LOCK? on page 203
:UNLock on page 204

Device Identity
Triggers the device identification function. The [LAN] LED on the front panel of the
selected instrument blinks.

See also Chapter 6.4.4, "Bidirectional Instrument Identification ", on page 71.

Hardware Channel
Selects the hardware interface used by the remote channel.

Remote command: 
:INSTruments:REMote:CHANnel on page 77

Instrument Name / IP Address
Enters the IP address or the host name of the connected instrument.

See also Chapter 6.4.3, "Finding Out the Default Hostname of the Instrument",
on page 71.
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Remote command: 
:INSTruments:REMote:NAME on page 77

GPIB Address
Enters the GPIB address of the connected instrument.

See also Chapter 10.1.5, "GPIB Interface (IEC/IEEE Bus Interface)", on page 170.

Remote command: 
:INSTruments:GPIB:ADDRess on page 78

Board Number
Identifies the GPIB bus card of the controller to that the adapter is connected.

See also Chapter 10.1.5, "GPIB Interface (IEC/IEEE Bus Interface)", on page 170.

Remote command: 
:INSTruments:GPIB:BOARd on page 78

Serial Number
Enters the serial number as instrument's identification while using the USB or PCIe
interfaces for remote control.

Remote command: 
:INSTruments:SERial on page 78

OK
Confirms the settings and closes the dialog.

Apply
Confirms the settings.

Cancel
Discards settings and closes the dialog.

6.1.2.3  Versions/Options Dialog

Querying information about the installed options and software version

► Select "Setup > Software".

An info dialog opens, showing program information.
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Software
Displays information on:

"Package" Installed software packages.

"Version" Release of the software package.

Show Open Source Acknowledgments
Accesses the list of the used open source software packages and the corresponding
verbatim license texts.

Versions
Shows the installed software platform and its version.

6.1.2.4  Protection

The "Protection" dialog provides access to the unlocking of protected service functions
(authorized personnel of Rohde & Schwarz service departments only).

Unlocking of protected service functions

1. Select "SGMA-GUI > Setups > Protection".

After the instrument has been switched on, the protection levels 1 to 4 are auto-
matically activated.

2. To deactivate the protection, enter the correct password.
Enter "Protection Level 1 > Password > 123456".

Protection Level 1 is activated.
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Protection Level / Password
"Protection Level 1" can be activated to expand the functionality of the internal adjust-
ment. The password is 123456.

The other protection levels 2 to 4 provide access to protected service functions. Only
the authorized personnel of Rohde & Schwarz service departments can access these
functions.

6.1.2.5  Reset SGMA-GUI

Resets R&S SGMA-GUI to its factory preset settings.

The connected instruments are not affected by this preset.
To preset one specific instrument to its factory preset settings, select "SGMA-GUI >
Instrument Name > Setup > Factory Preset". Refer to Chapter 8.11, "Factory Preset",
on page 142 for an overview of the settings affected by this function.

6.1.2.6  Remote

Access: "SGMA-GUI > Setup > Remote".

SCPI Port
Sets the port number of the LAN interface for remote control with TCP/IP socket proto-
col.

This allows you to set different port numbers if you want to control different software,
e.g. R&S SGMA-GUI and R&S WinIQSIM2, from the same application.

Remote command: 
:SYSTem:COMMunicate:SOCKet:PORT on page 273
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6.1.3  Help

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help page
can be called any time during software operation.

The context-sensitive page which is opened with the [F1] button is part of a compre-
hensive help system.

It is possible to move from this context-sensitive page to any page of the help system.
An overview of the contents of the online help can be reached via the menu "SGMA-
GUI > Help > Contents".

A search for keywords within the help function is available via menu item "SGMA-GUI
> Help > Index".

6.2  Info Dialog and Messages in the Info Bar

A few operating states and the current messages are displayed in the info line. For
information on messages in greater detail and their management, an "Info" dialog can
be opened.

6.2.1  Info Dialog

The "Info" dialog provides a list of currently active permanent messages and a detailed
description of each message. The messages are color-coded according to their level.

Accessing the info dialog

► In the "R&S SGMA-GUI main panel", select the "Info" button.

The "Info" dialog opens.

The upper part of the "Info" dialog lists the currently active permanent messages. See
the following table for explanation of the displayed information.
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Parameter Description

"LEV" Message level. Messages referring to a logical component of R&S SGMA-GUI, e.g.,
Unicode, are marked in red color, info messages are marked in black color.
The following levels might occur:
● Err: Error message
● Info: Information message
● Sys: System message
● Crit: Critical message

For detailed information on the message types, see Chapter 6.2.2, "Understanding the
Messages in the Info Bar", on page 63.

"SCPI" Indicates the SCPI error code.

Text A list of all currently permanent messages in the order of their occurrence, i.e., the most
recent message is displayed first.

The buttons in the lower part of the "Info" dialog provide quick access to some func-
tions for managing these messages. For a detailed description on how to clear error
messages or display a history of all messages, refer to Chapter 6.4.5, "Managing Mes-
sages in the Info Dialog", on page 73.

Function Description

"Delete" Clears the highlighted message. This button is available only if the history of the
messages is displayed.

"Delete All" Clears all messages.

This button is available only if the history of the messages is displayed.

"Del. volatile" Clears all brief messages. This button is available only if the history of the mes-
sages is displayed.

"Show History/Static" Calls the list of all messages that have occurred since instrument switch-on. The
most recent messages are displayed at the top of the list. When the button is
pressed again, the list of current messages is displayed.

Refer to Chapter 6.4.5, "Managing Messages in the Info Dialog", on page 73 for
information on how to manage messages.

6.2.2  Understanding the Messages in the Info Bar

Messages indicate information, warnings, and errors. They are displayed in the info
line in different colors depending on their importance and display duration. The follow-
ing messages are displayed:
● Error

There are two options:
– Critical errors are errors that prevent the instrument from working, e.g. an HW

failure. Critical errors are displayed in red color.
– System errors are errors that concern the operating system, e.g., wrong file

path. System errors are displayed in black color.
● Information
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The information, e.g., file not found, is displayed in black color.
● Warning

A warning indicates a less significant error and is displayed in black color.
● Brief message

Brief messages report automatic settings in the program, e.g. switching on illegal
entries that are not accepted by the program, e.g., range violations. They are dis-
played in the info line on a yellow background. They are displayed on top of status
information or permanent messages.
Brief messages usually do not demand user actions and disappear automatically
after a short period of time. They are stored in the history, however.

● Permanent messages
Permanent messages are displayed if an error occurs that impairs further program
operation. The error signaled by a permanent message must be eliminated before
correct software operation can be ensured.
The message is displayed until the error is eliminated. It covers the status display
in the info line. After error elimination, the message automatically disappears and is
also recorded in the history.

6.3  Main Panel

The main panel of the R&S SGMA-GUI provides quick access to the main settings of
the configured instruments. The display shows one row per instrument and comprises
the instrument name and state, the used frequency and power level, the states of the
RF output and modulator and the used reference source.

Click one of the buttons with an instrument name on it to access the menu tree with
further settings for the corresponding instrument. For a detailed description of the pro-
vided settings, see:
● Chapter 8, "General Instrument Settings and Instrument Setup", on page 128 for

general settings
● Chapter 7, "Signal Generator Settings", on page 80 for R&S SGS settings.
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Instrument/Connection State
The three colors of the state indicator in front of the instrument's name distinguish
between the following states:
● Gray: the instrument is configured and activated in the R&S SGMA-GUI but there is

no connection to the instrument.
● Green: the instrument is active, the connection is working and the instrument can

be manually and remotely operated.
● Red: the instrument is in one of the following states:

– Standby state
To operate the instrument manually, it has to be switched to ready state (see
"To return the instrument from standby to ready state" on page 157).

– Instrument locked
The red state indication together with the message "Instrument Locked" in the
"Info" line indicates that the instrument is locked for Exclusive Access from
another SGMA-GUI or controller.

– The instrument is performing a time consuming operation, e.g. a selftest.

Maximum Frequency
The numbers in the rectangular box  on the left of the instrument's name indicate the
maximum frequency of the instrument.

When the Eco Mode is turned on then this rectangular is colored in green and the fre-
quency shown in the rectangular corresponds to the maximum frequency available in
this mode.

Pulse Modulation
A  sign on the left of the instrument's name indicates that the pulse modulation is
switched on.
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Instrument Name/ IP Address
Displays the alias name of the instrument and the IP address, as set by the parameters
in "SGMA-GUI > Setup > Instruments > Add/Edit Instruments" dialog.

Click the button to access a menu tree for configuring the available instrument's set-
tings, e.g. "Level" settings.

Freq/Freq (Offs)
Sets the RF frequency, incl. enabled frequency offset.

The following apples:

"Freq" = Frequency + Offset

Where, the value set with the parameter "SGMA-GUI main panel > instrument name >
Frequency/Phase > Frequency" is the RF frequency at the RF output, without the fre-
quency offset.

The icon "Freq (Offs)" indicates that a frequency offset is applied.

Remote command: 
[:SOURce]:FREQuency[:CW|FIXed] on page 236

RF On/Off
Activates and deactivates the RF output signal.

The current state of the RF output (activated and deactivated) is indicated in the main
panel with the different block color (blue or gray) and the status "On/Off".

Remote command: 
:OUTPut[:STATe] on page 223

Mod State
Switches the I/Q modulation on and off.

Remote command: 
[:SOURce]:IQ:STATe on page 246

PEP
Displays the Peak Envelope Power (PEP) of the RF signal of the selected instrument.
The value is calculated as follows:

"PEP" = Level + Crest Factor

Remote command: 
[:SOURce]:POWer:PEP? on page 252

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.

If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".
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Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 251
[:SOURce]:POWer:POWer on page 250

Ref. Oscillator Source/Ext Ref On/Off
Determines whether the internal built-in oscillator (TXCO or OXCO) is used as a refer-
ence source or if an external reference is used. The internal reference oscillator OCXO
requires the additional option R&S SGS-B1.

To feed in an external instrument reference, use the input connector [REF/LO IN]. To
output the reference frequency at the output [REF/LO OUT], select "SGMA-GUI >
Instrument Name > Ref. Oscillator > REF/LO Output > REF".

See also Chapter 9.4, "How to Configure the Reference Oscillator Source",
on page 152.

"Int" The internal reference signal of 10 MHz is used.

"Ext" An external reference signal is used. The frequency of the external
reference signal must be selected with the parameter "SGMA-GUI >
Instrument Name > Ref. Oscillator > Ex. Ref. Input Frequency".

Remote command: 
[:SOURce]:ROSCillator:SOURce on page 260

LO Scr Ext
This icon indicates that the internal local oscillator is switched off.

See "Source" on page 83.

6.4  Working with R&S SGMA-GUI

This section explains how to work with the R&S SGMA-GUI software and perform con-
figuration tasks for manual operation of the instruments.

6.4.1  Storing and Loading Settings

To proceed work with a particular configuration of the instruments in the R&S SGMA-
GUI, it is useful to save the used settings and load them again later.

How to store and load settings

1. Select "SGMA-GUI main panel > File > Save As".

2. Navigate to the desired directory and enter the filename.
The extension *.savrcl is applied automatically.

The current settings of the software are saved to the selected file.
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3. To load settings from a file, select "SGMA-GUI main panel > File > Open"

4. Navigate to the directory the file is stored in and select the setting file.

The saved settings are loaded to the R&S SGMA-GUI and the main panel of the
software displays the saved instrument's configuration.

6.4.2  Handling Instruments in the R&S SGMA-GUI

This section provides information on how to configure and manage instruments in the
R&S SGMA-GUI.

For reference information about all provided settings in the user interface, refer to the
corresponding sections:
● Chapter 6.1.2.1, "Configure Instruments", on page 55 and Chapter 6.1.2.2, "Add/

Edit Instruments", on page 57
● Chapter 6.1.2.3, "Versions/Options Dialog", on page 59

Chapter 6.1.2.5, "Reset SGMA-GUI", on page 61

6.4.2.1  How to Automatically Add New Instruments to the SGMA-GUI

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Switch on the instrument.
c) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

All instruments are added automatically to the main panel of the SGMA-GUI.

6.4.2.2  How to Manually Add New Instruments to the SGMA-GUI

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Select the "New" button.

The Add Instrument dialog opens to register a new instrument.

3. In the "Symbolic Name" field, enter an alias name of your choice, e.g.
SGS-100021.

4. In the "Instrument Type" field, select the device family to connect to.

5. Select "Remote Control > Hardware Channel" and select the hardware interface.

6. For LAN or Socket interfaces, select "Remote Control > Instrument Name / IP
Address" and enter the IP Address or the hostname of the connected instrument,
e.g. rssgs100a100021.
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Tip: See also Chapter 6.4.3, "Finding Out the Default Hostname of the Instrument",
on page 71 .

7. For USB or PCIe interfaces, select "Remote Control > Serial Number" and enter
the serial number of the connected instrument , e.g. 100021.

8. Set "Active > On" to activate the instrument. Only active instruments are displayed
in the R&S SGMA-GUI main panel.

9. Click "OK" to confirm the settings and to close the dialog or press the "Apply" but-
ton to confirm the settings.

10. Click the "Cancel" button to discard settings and to close the dialog.

6.4.2.3  How to Scan for New Instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Click the "Scan" button to trigger the instrument to scan all remote channel interfa-
ces for connected instruments.

Tip: To limit the amount of the searched instruments and to speed up the scan
process, select "Configure Instruments > Scan LAN instruments with hostname
prefix" and enter the prefix the searched hostnames begin with.
The scan function searches only for instruments whose hostnames begin with the
selected prefix.

All instruments which are connected to one of the available interfaces, are
switched on and are not locked are displayed in the"Available Instruments" list.
The R&S SGMA-GUI obtains all information for connecting to the instrument, so
further configuration is not necessary.

6.4.2.4  How to Activate Instruments for Control from the R&S SGMA-GUI

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The "Available Instruments" in the Configure Instruments dialog lists all instruments
configured in the software.

2. Select the newly configured/connected or deactivated instrument and set "Active >
On" to activate it.

Tip: Only active instruments are displayed in the R&S SGMA-GUI main panel!

6.4.2.5  How to Edit Instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens and lists the "Available Instruments".
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2. Select the instrument to be edited and click the "Edit" button.

The Edit Instrument dialog opens.

3. Change the settings and confirm with OK.

The edited settings are applied.

6.4.2.6  How to Delete an Instrument

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Select the instrument to be deleted and click the "Delete" button.

The selected instrument is deleted from the list of "Available Instruments".

6.4.2.7  How to Delete All Instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Click the "Clear" button.

All instruments are deleted from the list of "Available Instruments".

6.4.2.8  How to Reserve the Instrument for Control

1. Open the "SGMA-GUI > Setup > Instruments > Configure Instruments" dialog,
select the instrument in the list of "Available Instruments" and select "Edit".

2. In the "Edit Instrument" dialog, enable "Exclusive Access".

3. Alternatively, send the SCPI command :INSTruments:EACCess[:STATe] from
the external PC the R&S SGMA-GUI is installed on.

The instrument is reserved for control from this external PC and cannot be
accessed from any other controller. A scan function started from another controller
finds the instrument but the instrument is indicated as locked.

The two functions "Exclusive Access" and monitoring are mutually exclusive!
The "Exclusive Access" must be disabled to remote control or monitor the instrument
form another external PC (see Chapter 10.6, "Using the R&S SGMA-GUI to Monitor
the Remote Control Operation", on page 187).
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6.4.3  Finding Out the Default Hostname of the Instrument

The default hostname of the instrument is a non-case-sensitive string built as follows:

hostname = <instrument name><serial number>, where

<serial number> is the individual serial number of the instrument

<instrument name> is the complete name of the instrument, written without spaces.

How to query the hostname of the instrument

1. Find the individual serial number on rear of the instrument , e.g. 100021.

2. Build the default hostname.

For the R&S SGS with serial number 100021, the default hostname is
rssgs100a100021.

For instructions on how to change the default hostname, refer to Chapter 9.10, "How to
Use Computer Names", on page 158.

6.4.4  Bidirectional Instrument Identification

In practice, instruments are integrated into a large network or placed in racks together
with several other instruments of the same kind. It might be difficult then to find out
which of the instruments configured in the R&S SGMA-GUI corresponds to which
physical instrument or to localize all instruments operated by the current controller.

The R&S SGMA-GUI and the instrument provide the "Device Identification" function for
this purpose.

How to find an instrument in the R&S SGMA-GUI

► If several instruments have been configured and activated in the R&S SGMA-GUI,
press the [ID] button on the instrument's front panel to trigger device identification.

The "Edit Instrument" dialog of this instrument opens.
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Field "Edit Instrument > Symbolic Name" displays the name of the instrument as
shown in the R&S SGMA-GUI main panel.

Dialog "Edit Instrument" does not appear
If this dialog does not open, perform the following:
● Check whether the instrument is correctly connected to the external PC on which

you work with the R&S SGMA-GUI.
● Check if the instrument is configured in the R&S SGMA-GUI and perform, if neces-

sary, the steps described in Chapter 6.4.2, "Handling Instruments in the R&S
SGMA-GUI", on page 68.

● Select "SGMA-GUI > Setup > Instruments", check the state of the instrument in the
"Configure Instruments > Available Instruments" table and activate it, if disabled.
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How to identify an instrument in an instrument set

► To identify the instrument in an instrument set, use one of the device identification
functions:

a) Select "SGMA-GUI > Setup > Instruments > Available Instruments > Instrument
> Edit > Edit Instrument" and trigger "Device Identify"

b) Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Chan-
nels" and trigger "Device Identify"

The green [LAN] LED on the front panel of the instrument blinks.

6.4.5  Managing Messages in the Info Dialog

How to get additional information on the message

► In the "Info" dialog, click a message to select it.

In the lower section of the dialog, additional information on the highlighted mes-
sage is displayed.

How to display all messages

► In the "Info" dialog, click the "History" button.

A history of all messages that have occurred since the R&S SGMA-GUI software
was started is listed in the upper dialog pane. The most recent message is dis-
played first.

How to delete an error message

► In the "Info" dialog, select the highlighted message and click the "Delete" button.

Tip: This button is available only when the history of the messages is displayed.

The highlighted message is cleared.

How to delete all error messages

► In the "Info" dialog, click the "Delete All" button.

Tip: This button is available only when the history of the messages is displayed.

All messages are cleared.

How to delete all brief messages

► In the "Info" dialog, click the "Del. volatile" button.

Tip: This button is available only when the history of the messages is displayed.

All brief messages are cleared.
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How to call the history

1. In the "Info" dialog, click the "History" button.

A list of all messages that have occurred since the instrument switch-on is dis-
played. The most recent messages are displayed at the top of the list.

2. Click the "History" button once more.
A list of current messages is displayed.

6.5  Remote Control of the R&S SGMA-GUI

This section focuses on the remote control of the R&S SGMA-GUI software.

6.5.1  Configuring Instruments in the R&S SGMA-GUI

This section provides an example of the automation of the R&S SGMA-GUI.

In the following example we assume that a remote PC with installed R&S SGMA-GUI
on it is connected to a LAN and that the remote PC and the instruments are switched
on.

For more information, refer to Chapter 2.3, "Connecting an External PC and Devices",
on page 22.

// ******************************************************************
// Trigger the scan function to search for instruments connected 
// to the remote computer via all of the available interfaces. 
// ******************************************************************

:INSTruments:SCAN:HNPRefix "rssg"
// scan returns only instruments with hostname beginning with "rssg"
:INSTruments:SCAN 1
*OPC?

// ******************************************************************
// Query the number of available instruments and the settings of each 
// configured instrument: instrument type, symbolic name, 
// remote channel used, serial number, hostname/IP address
// Adjust settings if required
// ******************************************************************

:INSTruments:COUNt?
// Response: 3

:INSTruments:TYPE?
// Response: SGU,SGS,SGT

:INSTruments:NAME?
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// Response: SGU-100002,SGS-100006, SGT-100008

:INSTruments:SERial?
// Response: 100002,100006,100008

:INSTruments:REMote:CHANnel?
// Response: LAN,USB, PCIe

:INSTruments:REMote:NAME?
// Response: rssgu100a100002, rssgs100a100006, rssgt100a100008

// ******************************************************************
// Check the instrument state and activate instruments if required
// ******************************************************************

:INSTruments:ACTive:STATe?
// Response: 0,1,1
:INSTruments:ACTive:STATe ON,OFF,OFF
// Activates the first  instruments in the list, 
// i.e. the instruments with symbolic names SGS-100006

// ******************************************************************
// Export the configuration into a mapping file
// ******************************************************************

:INSTruments:MAPPing:FILE 'd:\mapping_files\mapping.map'

// ******************************************************************
// Enable exclusive access for the selected instrument
// ******************************************************************

:INSTruments:EACCess:STATe?
// Response: 0,0,0
:INSTruments:EACCess:STATe ON,0FF, 0FF
// Locks the first instrument

6.5.2  R&S SGMA-GUI Settings

This section comprises the SCPI commands provided to remote control the R&S
SGMA-GUI.

:INSTruments:ACTive[:STATe]........................................................................................... 76
:INSTruments:COUNt?..................................................................................................... 76
:INSTruments:EACCess[:STATe]........................................................................................76
:INSTruments:MAPPing:FILE............................................................................................ 77
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:INSTruments:REMote:CHANnel....................................................................................... 77
:INSTruments:REMote:NAME............................................................................................77
:INSTruments:GPIB:ADDRess...........................................................................................78
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:INSTruments:GPIB:BOARd..............................................................................................78
:INSTruments:SCAN........................................................................................................ 78
:INSTruments:SCAN:HNPRefix......................................................................................... 78
:INSTruments:SERial........................................................................................................78
:INSTruments:TYPE......................................................................................................... 79

:INSTruments:ACTive[:STATe] <State>

Enables/disables the instrument for the R&S SGMA-GUI. The main panel of this soft-
ware displays only activated instruments.

Parameters:
<State> List of BOOL-values

<StateInstr#1>,<StateInstr#2>,...
0, 1, ON, OFF

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Available Instruments" on page 55

:INSTruments:COUNt?

Queries the number of the currently available instruments.

Return values: 
<Count> float

Range: 0  to  12

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Usage: Query only

Manual operation: See "Available Instruments" on page 55

:INSTruments:EACCess[:STATe] <State>

"Locks" the instruments, meaning the instrument is reserved and can be operated
exclusively from the remote PC that sent this SCPI command.

Tip: It is recommended to lock the instrument prior to further configuration.

Parameters:
<State> List of BOOL-values

<LockInstr#1>,<LockInstr#2>,...
0,1,OFF,ON

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Exclusive Access" on page 58
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:INSTruments:MAPPing:FILE <File>

Saves the list of the available instruments in a mapping file. Mapping files are stored
with the predefined file extension .map; the file extension may be omitted.

The file is saved in the default directory. Use the command MMEM:CDIRectory to
change the default directory or specify the complete path.

Parameters:
<File> string

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Export" on page 56

:INSTruments:NAME <Name>

Selects the alias name of the instruments, i.e. sets the "Symbolic Name".

Parameters:
<Name> <SymbolicNameInstr#1>,<SymbolicNameInstr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Available Instruments" on page 55

:INSTruments:REMote:CHANnel <Channel>

Sets the hardware interface used by the remote channel.

Parameters:
<Channel> List of CHAR-Data

<Channellnstr#1>,<Channellnstr#2>,...
The available interfaces are: LAN, USB, SOCKET, PCIe, GPIB,
HiSLIP

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Hardware Channel" on page 58

:INSTruments:REMote:NAME <Name>

Enters the IP Address or the host name of the connected instrument.

Parameters:
<Name> <Hostname/IP-AddressInsr#1>,<Hostname/IP-Addres-

sInsr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Instrument Name / IP Address" on page 58
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:INSTruments:GPIB:ADDRess <Serial>

Sets the GPIB Address of the connected instrument.

Parameters:
<Serial> List of Numbers

Manual operation: See "GPIB Address" on page 59

:INSTruments:GPIB:BOARd <Board>

Identifies the GPIB bus card the controller uses.

Parameters:
<Board> List of Numbers

Manual operation: See "Board Number" on page 59

:INSTruments:SCAN <State>

Triggers a scan function and searches for instruments connected to the remote com-
puter via all of the available interfaces.

Parameters:
<State> number

1 = triggers the scan function, 0 = aborts the running scan proc-
ess
The query command returns 1 as long as scan is running; 0 indi-
cates completed scan process.

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Scan" on page 55

:INSTruments:SCAN:HNPRefix <Prefix>

Sets the prefix the searched host names begin with.

Parameters:
<Prefix> string

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Scan LAN instruments with host name prefix" on page 57

:INSTruments:SERial <Serial>

Enters the serial number as instrument's identification while using the USB interface for
remote control.
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Parameters:
<Serial> <SerialNumberInstr#1>, <SerialNumberInstr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Serial Number" on page 59

:INSTruments:TYPE <Type>

Selects the instrument's family.

Parameters:
<Type> List of CHAR-Data

<TypeInstr#1>,<TypeInstr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 74.

Manual operation: See "Available Instruments" on page 55

6.5.3  List of R&S SGMA-GUI Commands
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7  Signal Generator Settings
This section summarizes the settings necessary to configure the instrument for signal
generation. The description in this section follows the menu tree structure of the graph-
ical user interface. Each of the discussed topics follows a common structure, providing
basic background information, and reference to the user interface.

For step-by-step instructions for fulfilling typical tasks, refer to Chapter 9, "Performing
Configuration Tasks", on page 147.

7.1  Operation Mode

You can operate the R&S SGS in two modes, normal mode and baseband bypass
mode. In baseband bypass mode, an external IF signal fed in at the [I] or [Q] connec-
tors is directly routed to the [RF OUT] connector. The level of the signal can be adjus-
ted.

Refer to Figure 5-9 for visualization of the signal flow.

► To access the "Operation Mode" dialog, select "SGMA-GUI > Instrument Name >
Operation Mode".

Operation Mode
Sets the operation mode.

"Normal" The complete signal processing chain is used.

"Baseband Bypass"
The IF signal fed in at the [I] or [Q] connectors is directly routed to the
[RF OUT] connector.

Note: The "Baseband Bypass" is a special operation mode. See also
Chapter 9.3, "How to Enable a Baseband Bypass Mode",
on page 151.

Remote command: 
[:SOURce]:OPMode on page 235

7.2  Frequency/Phase Settings

Depending on the installed options, the instrument provides an adjustable output fre-
quency in the frequency range of 1 MHz to 6 GHz or to 12.75 GHz.

Frequency/Phase Settings
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Access:

► Select "SGMA-GUI > Instrument Name > Frequency/Phase".

The frequency and phase related settings are provided in this dialog.

Configuring the RF frequency

1. To change the RF frequency of the selected instrument, perform one of the follow-
ing:

a) Select "SGMA-GUI > Instrument Name > Frequency/Phase > Frequency" and
set the frequency at the RF output.

b) Select "SGMA-GUI main panel > Freq" and set the frequency.
The value includes possible frequency offset.

2. To enable frequency offset for example to consider the frequency shift of a down-
stream instrument, set the parameter "Frequency/Phase > Offset".

Changes of the RF frequency have an immediate effect on the output signal.

Frequency
Sets the RF frequency at the RF output connector of the selected instrument.

The displayed value does not consider an enabled frequency offset (Offset).

Remote command: 
See [:SOURce]:FREQuency[:CW|FIXed] on page 236

Offset
Sets a frequency offset.

The frequency offset value represents the frequency shift of a downstream instrument,
as for example an attenuator or an amplifier.

Enabled frequency offset does not change the frequency at the RF output (Frequency).
It influences the value of the parameter "SGMA-GUI main panel > Freq".

The following applies:

"Freq" = Frequency + "Offset"

Frequency/Phase Settings
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In the "SGMA-GUI main panel", enabled frequency offset is also indicated with the key-
word "Freq (Offs)".

Remote command: 
[:SOURce]:FREQuency:OFFSet on page 236

Delta Phase
Sets the phase of the RF signal. The current phase of the signal is used as the refer-
ence. This function allows, for example, the phase of the output signal to be synchron-
ized with the phase of a signal from a second signal generator.

Remote command: 
[:SOURce]:PHASe on page 248

Reset Delta Phase Display
Resets delta phase value. The set phase is adopted as the new current phase, i.e. the
delta phase value is reset to 0.

Remote command: 
[:SOURce]:PHASe:REFerence on page 248

7.3  Local Oscillator (LO) Coupling

The LO coupling function allows you to distribute the local oscillator signal in a way that
multiple R&S SGSs or other R&S signal generators can be driven by the same LO sig-
nal. This is mandatory for phase coherent application, e.g. the generation of beam-
formed signals, and for phase coherent demodulation.

The LO coupling function is available only for instruments equipped with the option
R&S SGS-K90 (Phase Coherence). This option enables phase coherent RF outputs of
two or more RF signals. The local oscillator signal is provided at the REF/LO OUT con-
nector. An external signal can be input at the REF/LO IN connector.
Refer to Figure 5-9 for visualization of the signal flow.

See also:
● Chapter 9.5, "How to Configure the Local Oscillator (LO) Coupling Source",

on page 153
● Chapter 9.6, "How to Define the Signal at the REF/LO OUT Connector",

on page 154
● Chapter 9.7, "How to Connect and Configure Instruments for Optimum Phase

Coherence", on page 154

7.3.1  Phase Coherence

Phase coherence of RF signals designates a defined, constant delta phase between
two or more RF carrier signals with the same frequency or a multiple of the frequency.

Local Oscillator (LO) Coupling
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If two signal generators are coupled via their 10 MHz reference, they are generating
exactly the same frequency but only in the long-term perspective. Having a closer look
into the instantaneous differential phase (“delta phase”) of these two RF signals, this is
unstable due to:
● Phase noise of the two synthesizers
● “weak” coupling at 10 MHz and a long synthesis chain up to the RF domain
● Temperature differences, which cause slightly different phase drift for the different

synthesizers

Most critical for a stable delta phase is the thermal RF phase fluctuation between multi-
ple RF synthesizers. These fluctuations can be minimized by using a common synthe-
sizer (common local oscillator (LO) signal) for all RF carriers.

See also Chapter 9.7, "How to Connect and Configure Instruments for Optimum Phase
Coherence", on page 154.

7.3.2  Local Oscillator (LO) Coupling Settings

The LO coupling-related settings are provided in the "Frequency/Phase" dialog.

► To access this dialog, select "SGMA-GUI > Instrument Name > Frequency/Phase >
Local Oscillator (LO) Coupling".

Source
Selects the source of the local oscillator signal.

"Int" The instrument uses the built-in local oscillator.

Local Oscillator (LO) Coupling
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"Ext" The signal fed-in at the [REF/LO IN] input connector is used as signal
source.

An icon in the block diagram indicates that an external LO source is
used.

Note: The local oscillator input/output requires the additional software
option R&S SGS-K90.

Remote command: 
[:SOURce]:LOSCillator:SOURce on page 236

REF/LO Output
Determines the signal provided at the output connector [REF/LO OUT].

See also Chapter 9.6, "How to Define the Signal at the REF/LO OUT Connector",
on page 154.

"OFF" No signal is provided.

"LO" The signal of the local oscillator (LO) is available at the [REF/LO
OUT] connector.

"REF" The signal of the reference oscillator is available at the [REF/LO
OUT] connector.

Remote command: 
:CONNector:REFLo:OUTPut on page 208

7.4  Reference Oscillator

The R&S SGS is equipped with an internal TXCO reference oscillator. If equipped with
the additional HW option R&S SGS-B1, an OXCO can be used as an internal refer-
ence frequency source for the synthesizer. Moreover, an external reference signal
source can be connected to the REF/LO IN connector of the instrument.

Refer to Figure 5-9 for visualization of the signal flow.

► To access this dialog, select "SGMA-GUI > Instrument Name > Reference Oscilla-
tor".

Reference Oscillator
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Ref. Oscillator Source/Ext Ref On/Off
Determines whether the internal built-in oscillator (TXCO or OXCO) is used as a refer-
ence source or if an external reference is used. The internal reference oscillator OCXO
requires the additional option R&S SGS-B1.

To feed in an external instrument reference, use the input connector [REF/LO IN]. To
output the reference frequency at the output [REF/LO OUT], select "SGMA-GUI >
Instrument Name > Ref. Oscillator > REF/LO Output > REF".

See also Chapter 9.4, "How to Configure the Reference Oscillator Source",
on page 152.

"Int" The internal reference signal of 10 MHz is used.

"Ext" An external reference signal is used. The frequency of the external
reference signal must be selected with the parameter "SGMA-GUI >
Instrument Name > Ref. Oscillator > Ex. Ref. Input Frequency".

Remote command: 
[:SOURce]:ROSCillator:SOURce on page 260

Ext. Ref. Input Frequency
Available only for "Source > Ext".

Selects the frequency of the external reference signal.

Remote command: 
[:SOURce]:ROSCillator:EXTernal:FREQuency on page 259

Synchronization Bandwidth
Available only for "Source > Ext".

Selects the synchronization bandwidth for an external reference signal. The wideband
setting is provided for using good reference sources of high spectral purity.

"Wide" Synchronization bandwidth is app. 250 Hz.

"Narrow" Synchronization bandwidth is app. 40 Hz.

Reference Oscillator
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Remote command: 
[:SOURce]:ROSCillator:EXTernal:SBANdwidth on page 261

Output Frequency
Selects the output for the reference oscillator signal. The available values depend on
the input frequency and the reference oscillator source.
Table 7-1: Output frequency

"Reference Oscillator Source" Input frequency Output frequency

"Internal" 10 MHz 10 MHz

1 GHz

"External" 10 MHz

13 MHz

100 MHz

1 GHz

10 MHz, 1 GHz

13 MHz, 1 GHz

100 MHz, 1 GHz

1 GHz

Support of 13 MHz reference frequency requires that the instrument is equipped with
hardware module RF board with part number 1419.5308.02.

To find out the RF board installed in the instrument:
● Select "SGMA-GUI > instrument name > Setup > Hardware Config" > "RF Assem-

bly"
● Observe the part number of the assembly "RfBoard".

Remote command: 
[:SOURce]:ROSCillator:OUTPut:FREQuency on page 260

REF/LO Output
Determines the signal provided at the output connector [REF/LO OUT].

See also Chapter 9.6, "How to Define the Signal at the REF/LO OUT Connector",
on page 154.

"OFF" No signal is provided.

"LO" The signal of the local oscillator (LO) is available at the [REF/LO
OUT] connector.

"REF" The signal of the reference oscillator is available at the [REF/LO
OUT] connector.

Remote command: 
:CONNector:REFLo:OUTPut on page 208

Active Adjustment Data
Displays whether the factory or user defined (custom) calibration value is currently
used for the external calibration of the reference oscillator.

Adjusting the calibration value for the OCXO adjustments is a protected service proce-
dure, that requires a Protection Level 2 password. The exact test procedure is descri-
bed in the service manual.

See also Chapter 8.15, "External Adjustments", on page 146.

Reference Oscillator
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Adjustment Active
Available only for "Source > Int".

Selects adjustment mode.

"OFF" Uses the calibrated internal reference frequency. This value is deter-
mined at one of the R&S service centers during calibration.

"ON" A user-defined adjustment value is used. The value is entered under
DAC Value.
This allows the frequency to be impaired freely, for example, to simu-
late a frequency error.
The instrument is no longer in the calibrated state. However, the cali-
bration value is not changed and the instrument resumes the calibra-
ted state after switching the "Adjustment State" to Off.

Remote command: 
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] on page 260

DAC Value
Enters a user-defined adjustment value for the internal reference frequency. This value
is not used unless "Adjustment Active > On" is selected.

"DAC Value = 0" indicates the calibrated state. The setting range depends on the refer-
ence oscillator type and its factory calibration value.

Remote command: 
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue on page 260

7.5  Level and Power-On Settings

This section explains the level settings of the R&S SGS. The instrument can be equip-
ped optionally with an active electronic step attenuator (R&S SGS-B26).

Configuring RF level

► To change the RF level of the selected instrument, perform one of the following:

a) Select "SGMA-GUI main panel > Level" and enter the desired value.
b) Select "SGMA-GUI > Instrument Name > Level > RF Level > Level" and enter

the desired value.

Changes of the RF level have an immediate effect on the output signal.

Level and Power-On Settings



Signal Generator SettingsR&S®SGS100A

88User Manual 1173.9105.02 ─ 12

7.5.1  RF Level

► To access the RF level settings, select "SGMA-GUI > Instrument Name > Level >
RF Level".

This dialog comprises settings like the RF level and level limit.

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.

If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 251
[:SOURce]:POWer:POWer on page 250

Offset
Sets a level offset.

This value represents the level shift of a downstream instrument, as for example an
attenuator or an amplifier, and is indicated in the status bar of the display. It does not
change the level at the RF output.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet on page 252
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Mode
Allows you to optimize the RF output signal for applications, where improved harmonic
distortion or improved wideband noise is required.

"Normal" In normal mode, the generator provides an RF output signal with high
signal to noise ratio and low distortion, according to the data sheet.

"Low Noise" This setting forces the generator to optimize the signal to noise ratio.

"Low Distortion"
In this mode, the generator reduces distortions of the RF signal to a
minimum.

Remote command: 
[:SOURce]:POWer:LMODe on page 250

Setting Characteristic
Selects the characteristic for the level setting. For some general applications, the
instrument operation can be optimized by selecting one of the predefined level setting
characteristics.

"Auto" The instrument provides the highest dynamic range and the fastest
setting times according to the data sheet.
The RF signal is shortly blanked during the moment the step attenua-
tor is switched on.

"Uninterrupted Level setting"
Suppresses level blanking at frequency and level changes.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

"Strictly Monotone"
Provides level setting without discontinuities. All electronic switches in
the RF path are clamped. The operation mode is useful for applica-
tions using level searching algorithms.
This mode further reduces the dynamic range of the instrument. The
step attenuator is also fixed.

"Constant-VSWR"
Suppresses output impedance variations at the [RF Out] connector
due to changed level setting.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

Remote command: 
[:SOURce]:POWer:SCHaracteristic on page 251

Level Range
Displays the level range within which the level setting is expected to work properly. The
range limits depend on several parameters like "Mode", "Setting Characteristic", the I/Q
signal's crest factor etc.

Remote command: 
[:SOURce]:POWer:RANGe:LOWer? on page 253
[:SOURce]:POWer:RANGe:UPPer? on page 253
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Limit
Sets the level limit.

The value specifies the upper limit of the level at the [RF Out] connector. A message
appears if an attempt is made to set a level above this limit and the level at the RF out-
put is confined to the upper limit. However, the level indication is not influenced.

The value is not affected by an instrument preset function. This parameter is influenced
only by the Factory Preset and its factory value is equal to the upper limit.

Remote command: 
[:SOURce]:POWer:LIMit[:AMPLitude] on page 252

Readjust
Recalculates the instrument internal settings optimized for the current level. Not
required for automatic modes.

Remote command: 
[:SOURce]:POWer:ALC:SONCe on page 249

7.5.2  Attenuator

► To access the attenuator settings, select "SGMA-GUI > Instrument Name > Level
>Attenuator".

This dialog comprises the settings for the power-on behavior of the instrument.

Mode
Sets the attenuator mode at the RF output.

"Auto" Standard mode.
The electronically switching attenuator switches with a ~ 6 dB step
width at optimized switching points. The entire level range is availa-
ble.
The level setting is performed by continuous electronic level control
combined with switching the step attenuator.

Level and Power-On Settings
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"Fixed" The level settings are made without switching the attenuator.
When this operating mode is switched on, the attenuator is fixed in
the current position to provide level settings without interruption. The
resulting variation range is defined and displayed with the parameters
Level Range.

Note: The function is effective when automatic level control is activa-
ted ("ALC State = On").
If the normal variation range is overranged or underranged, level
errors increase considerably. The warning "Level under/overrange"
appears in the info line.
The spectral purity of the output signal decreases with high attenua-
tion.

"Auto Passive" The attenuator is switched automatically.
The level settings are made only for the passive reference circuits.
The high-level ranges are not available.

Remote command: 
:OUTPut:AMODe on page 222

SATT Switch-Over Offset
Sets the switch-over offset value of the attenuator.

Remote command: 
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] on page 250

Level Range
Displays the level range in which the level is set without interruption for the "Attenuator
Mode Fixed" setting.

Remote command: 
:OUTPut:AFIXed:RANGe:LOWer? on page 222
:OUTPut:AFIXed:RANGe:UPPer? on page 222

RF-Off-Mode
Determines the attenuator's state after the instrument is switched off.

In default setting, the electronic step attenuator switches to highest attenuation when
RF is off. By setting the RF-Off mode, the electronic step attenuator can be fixed to
keep the output impedance constant during RF off.

Remote command: 
[:SOURce]:POWer:ATTenuation:RFOFf:MODE on page 250

Level and Power-On Settings
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7.5.3  Power-On/EMF

► To access the power- on/EMF settings, select "SGMA-GUI > Instrument Name >
Level > Power-On/EMF".

This dialog comprises the settings for the power-on behavior of the instrument.

Power-On State
Selects the state which the RF output takes after the instrument is switched on.

"RF Off" The output is deactivated when the instrument is switched on.

"Previous Setting"
When the instrument is switched on, the output takes the same state
as it had when the instrument was switched off.

Remote command: 
:OUTPut[:STATe]:PON on page 223

7.5.4  ALC

► To access the automatic level control (ALC) settings, select "SGMA-GUI > Instru-
ment Name > Level > ALC".

Automatic level control can be used with almost all applications, especially I/Q
modulation. It only has to be deactivated for certain settings in the baseband and
when I/Q impairments ("Impairments State On") are activated. This is indicated
under the respective function.
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By default, the instrument operates in "Table & On" mode to provide the highest
level accuracy and fastest setting time. Level control can be switched to "Off
(Table)" or "On" for particular applications. The "Off (Table)" state (level control Off)
is recommended if in CW mode the signal/intermodulation ratio is to be improved
for multi-transmitter measurements.

State
Sets the internal level control.

"Table & On" Default mode.
First sets the level to the target value using the internal level table.
Then activates the level control circuit to achieve maximum level
accuracy.

"On" Internal level control is permanently activated.
If "On" and "Attenuator Mode Fixed" is selected, the level is recalibra-
ted for every level and frequency setting.

"Off (Table)" Internal level control is performed according to the ALC table.

Remote command: 
[:SOURce]:POWer:ALC[:STATe] on page 249

Detector Sensitivity
Allows you to fix the internal level detector. It is recommended to use the Auto mode
(default).

"Auto" Automatic detector selection. Recommended mode of operation.

"Low" Low sensitivity detector selected.
This setting is intended for signals with high internal electronic levels.

"Med" Medium sensitivity detector selected.
This setting corresponds to normal mode. It is intended for signals
with medium internal electronic levels.

"High" High sensitivity detector selected.
Selects the detector path with high sensitivity, intended for signals
with low internal electronic levels.

"Fix" Fixes the last set sensitivity setting.

Remote command: 
[:SOURce]:POWer:ALC:DSENsitivity on page 249

7.5.5  User Correction Settings

► To access the user correction level settings, select "SGMA-GUI > Instrument Name
> Level > UCOR".
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The "User Correction" function is used to create and activate lists in which level correc-
tion values predefined by the user are freely assigned to RF frequencies. Correction is
performed by the user-defined table values being added to the output level for the
respective RF frequency.

With frequencies which are not contained in the list, the level correction is determined
by interpolation of the closest correction values.

The lists are created in the "List Editor". Each list is stored in its own file with the prede-
fined file extension *. uco. The name of the "User Correction" file can be freely
selected. The files are loaded from the "Lists..." file manager. Externally created tables
with pairs of frequency and level values can be converted into "User Correction" files
using the import function. The external files must have the file extension *.txt or
*.csv. These file formats are provided e.g. by the Microsoft Excel program. The sepa-
rators for table columns and for decimal floating-point numerals can be set. In addition,
internally created "User Correction" data can be exported into ASCII files using the
export function.

If user correction is activated, the "UCOR" display ("User Correction") is shown in the
header together with the "Level" display. The RF output level is the sum of both values.

"Level" + "UCOR" = Output level

If activated, user correction is effective in all operating modes.

State
Activates/deactivates user correction.

Remote command: 
[:SOURce<hw>]:CORRection[:STATe] on page 245

User Correction
Indicates the current value for level correction.

Remote command: 
[:SOURce<hw>]:CORRection:VALue? on page 245

Level and Power-On Settings



Signal Generator SettingsR&S®SGS100A

95User Manual 1173.9105.02 ─ 12

User Cor. Data
Calls the "File Select" menu for selecting and creating a list or the "File Manager".

Remote command: 
[:SOURce]:CORRection:CSET:DELete on page 240
[:SOURce<hw>]:CORRection:CSET[:SELect] on page 244

Edit User Cor. Data
Calls the editor for editing the selected user correction list.

A list consists of any number of frequency/level value pairs. The currently selected list
is displayed.

Each list is saved as a separate file with extension *.uco. The file name and the direc-
tory to which the file is saved are user-selectable.

Note: Save list only after filling both columns (frequency and level), otherwise the
entries are lost.

"Frequency /Hz"
Enters the frequency to which the level correction value applies.

Note: The "Fill..." function allows you to automatically enter any num-
ber of frequencies with freely selectable range and increment.

"Power/dB" Enters the level correction value to which the specified frequency
applies.
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"Goto" Selects row for editing.

If "Goto Row" is selected, a window opens for entering the requested
row.

"Edit" Calls a selection of possible actions described below.

"Insert Range" Insert new rows before the marked row. The number of rows to be
inserted can be defined in an entry window.

"Insert Row" Insert a new row before the marked row.

"Fill...." Opens a sub menu for defining a set of list values to be automatically
entered in the ucor list, see Filling the Correction List Automatically).

"Fill with sensor..."
Opens a dialog to configure the settings for automatic filling of user
correction data with an R&S NRP power sensor, see Chapter 7.5.7,
"Fill with Sensor", on page 99.

"Delete Row" Deletes the marked row.

"Delete Range..."
Allows you to delete any number of rows starting with the marked
row. The number of rows to be deleted can be defined in an entry
window.
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"Save as" Open the file menu to save the list under a new name.

Note: Save list only after filling both columns (frequency and level),
otherwise the entries are lost.
Each list is saved to the R&S SGS hard disk as a separate file with
the file prefix *.uco. The file name and the directory to which the file
is saved are user-selectable.

"Save" The list is saved under its current name.

Remote command: 
[:SOURce<hw>]:CORRection:CSET[:SELect] on page 244
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency on page 238
[:SOURce<hw>]:CORRection:CSET:DATA:POWer on page 239

Import/Export >>>
Expands the menu with the area for import and export of user correction files.

Externally edited Excel tables with any number of frequency/level value pairs can be
imported as text or *.csv files and used for user correction.

Conversely, you can also export internally created user correction lists as text or
*.csv files.

Mode
Selects if user correction lists should be imported or exported. The settings offered
depend on the selected mode.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:MODE on page 243

Extension
Selects the file extension of the ASCII file to be imported or exported. Selection "TXT"
(text file) or "CSV" (Excel file) is available.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension on page 241

Decimal Point
Selects the decimal separator used in the ASCII data between '.' (decimal point) and ','
(comma) with floating-point numerals.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal
on page 242

Column Separator
Selects the separator between the frequency and level column of the ASCII table the
user correction list is exported to or imported from.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn
on page 242
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Select ASCII Source/Destination
Calls the "File Manager" for selecting the ASCII file to be imported into a user correc-
tion list (source) or the ASCII file the user correction list is exported (destination) in.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect on page 241

Select Destination/Source
Calls the "File Manager" for selecting the user correction list to be exported (source)
into an ASCII file or the destination for the ASCII file to be imported (destination) in.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:SELect on page 244

Import/Export
Starts the export or import of the selected file.

When import is selected, the ASCII file is imported as user correction list.

When export is selected, the user correction list is exported into the selected ASCII file.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:EXECute on page 243

7.5.6  Filling the Correction List Automatically

The "Fill Table" menu enables you to set the level correction values automatically.

The start line and the number of rows to be filled are defined under "From" and
"Range."

The column to be filled is selected under "Select column to fill". Depending on the
selection here, the default for start, end, and increment value are set. As the settings
are interdependent, a change of one parameter may result in the automatic change of
one or more of the other parameters. The filling of the column with the selected value
settings is started with button "Fill".
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The correction list entries are only computed when the "Fill" button is pressed.

From
Sets the start value of the index range.

Remote command: 
n.a.

Range
Sets the range for filling the table.

Remote command: 
n.a.

Select column to fill
Selects either the frequency or the level column to be filled with the value defined
below.

Remote command: 
n.a.

Start value
Sets the start value for the frequency or the level entries.

Remote command: 
n.a.

End value
Displays the end value for the frequency or the level entries.

Remote command: 
n.a.

Increment value
Sets the increment for the frequency or the level entries.

Remote command: 
n.a.

Fill
Fills the selected column in the set range with values, starting with the start value and
using the set increment.

Remote command: 
n.a.

7.5.7  Fill with Sensor

► To access this dialog, select "SGMA-GUI > Instrument Name > Level > UCOR >
Edit User Cor. Data> Fill With Sensor".
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This dialog describes all parameters for filling a table automatically with sensor
readings.

Since the settings are interdependent, the affected parameters change accordingly if
you set a value.
To fill the table, press the "Execute" button.
To select the sensor and determine its parameters, refer to Chapter 7.5.8.3, "NRP
Power Viewer", on page 105.

Fill User Correction Data with Sensor
● "Sensor"

Displays connected sensors for selection.
● "List To Fill"

Indicates the used list.
● "Include Zeroing"

Performs a zeroing procedure before acquiring the user correction data to improve
precision. Since during zeroing no signal may be applied to the sensor, RF is tem-
porarily switched off at the generator.
When unchecked, the zeroing procedure is skipped. However, the RF signal level
might be blanked shortly. This setting is recommended if blanking of RF is undesir-
able or the absence of power at the sensor cannot be guaranteed.

● "Execute"
The "Execute" button is only enabled if a sensor is detected and the user correction list
contains at least one frequency value.
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Remote command: 
[:SOURce<hw>]:CORRection:ZERoing:STATe on page 245
[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe
on page 240

Used Instrument Settings For Measurement
Displays the settings relevant for the measurement.

"Modulation" Indicates the modulation state

"Amplitude" Shows the currently set level.

"Use SParameter"
Indicates whether SParameter correction is used.

"Attenuator Mode"
Displays the selected mode of the attenuator.

"Fixed range (PEP) In"
Shows the level range.

Remote command: 
n.a.

7.5.8  Using Power Sensors

The R&S SGS works with most of the R&S NRP power sensors and thus supports var-
ious application tasks. Using power sensors, you can for example determine attenua-
tion characteristics of downstream equipment or cables. You can use the measured
values to compensate the losses with internal control functions or with an external con-
trol circuit in real time.

R&S NRP sensors are highly accurate standalone measuring devices, suitable for a
wide range of applications. The devices communicate directly with the signal genera-
tor, calculate the average or peak power internally, include S-parameter correction and
return the measurement results to the generator.

The R&S SGS works with any sensor of the R&S NRP series and can perform up to
four power measurements simultaneously.

Check the firmware version of the R&S NRP sensors regularly. Update the firmware, if
necessary.
For updates, see the Rohde & Schwarz website http://www.rohde-schwarz.com in sec-
tion "Power Meters & Voltmeters".

● Connecting R&S NRP Power Sensors to the R&S SGS.......................................102
● NRP Sensor Mapping........................................................................................... 103
● NRP Power Viewer............................................................................................... 105
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7.5.8.1  Connecting R&S NRP Power Sensors to the R&S SGS

R&S NRP sensors are connected to the R&S SGS in the following ways:
● Connection to the USB connector

Requires a USB Adapter Micro-A to A and the following cables, depending on the
used sensor type:
– R&S NRP-ZK6 and an R&S NRP-Z3 with external power supply for R&S

NRPxx power sensors
– R&S NRP-Z3 with external power supply for sensors of the R&S NRP-Zxx fam-

ily
● Connection via R&S NRP-Z5 sensor hub, see Using the R&S NRP-Z5 sensor hub.
● Connection via USB hub with external power supply unit, see Using USB hub.
● Connection via LAN for R&S NRPxxxSN power sensors

Using the Ethernet interface requires PoE (Power over Ethernet) to provide the
electrical power.
To establish the connection, you can use:
– A PoE Ethernet switch, e.g. R&S NRP-ZAP1 and an RJ-45 Ethernet cable.
– A PoE injector and an RJ-45 Ethernet cable.

Using the R&S NRP-Z5 sensor hub

The R&S NRP-Z5 USB sensor hub (high-speed USB 2.0) can host up to 4 R&S NRP
sensors. It provides simultaneous internal and external triggering of all connected sen-
sors.

Figure 7-1 illustrates the connection as principle. For details, see the description
R&S®NRP®Series Power Sensors getting started.

Figure 7-1: Connecting power sensors to the R&S SGS via R&S NRP-Z5 sensor hub

I, II = Connection order
G = Signal source (R&S SGS)
1 = USB type Micro-A connector
2 = USB Adapter Micro-A to A
3 = Standard USB cable with USB type A and USB type B connectors
4 = USB type B connector
4a = External power supply unit, incl. power cable (supplied with the R&S NRP-Z5)
5 = Cable R&S NRP-ZK6 per sensor of the R&S NRPxx power sensor family; no further adapter cables for

sensors of the R&S NRP-Zxx family
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Using USB hub

Figure 7-2 illustrates the connection as principle. For details, see the description
R&S®NRP®Series Power Sensors getting started.

Figure 7-2: Connecting power sensors to the R&S SGS via USB hub

I, II = Connection order
G = Signal source (R&S SGS)
1 = USB type Micro-A connector
2 = USB Adapter Micro-A to A
3 = Standard USB cable with USB type A and USB type B connectors
4 = USB type B connector
4a = External power supply unit and extra power cable
5 = Cable R&S NRP-ZKU per sensor of the R&S NRPxx power sensor family; R&S NRP-Z3 or R&S NRP-

Z4 USB adapter cables for sensors of the R&S NRP-Zxx family

Connection order

Always connect the equipment in the following order:

1. Connect the R&S NRP-Z5 sensor hub or the USB hub to the power supply and to
the R&S SGS

2. Switch on the R&S SGS

3. Connect/disconnect the R&S NRP sensors

Detection and mapping

The R&S SGS automatically detects a connected R&S NRP power sensor and indi-
cates it in the "NRP Power Viewer" and "NRP Sensor Mapping" dialogs.

You can change the default mapping in the NRP Sensor Mapping dialog.

On connection, the R&S SGS immediately starts the measurement of a detected
R&S NRP power sensor. If you perform an instrument preset, the R&S SGS stops the
measurements. The connection and the mapping of the power sensors remain, the
measurements must be restarted.

7.5.8.2  NRP Sensor Mapping

The "NRP Sensor Mapping" lists all R&S NRP sensors detected by the instrument.
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Any R&S NRP sensor that supports the USB legacy protocol and is connected to one
of the USB interfaces, is detected automatically and added to the list. Vice versa, the
R&S SGS removes a sensor from the list, when it is disconnected.

R&S NRP sensors that are connected via LAN or use the USBTMC protocol are not
automatically detected. They are detected by the scan search function.

Access:

► Select "Instrument" > "NRP Sensor Mapping".

The dialog lists all detected R&S NRP sensors for selection and mapping. You can
also browse the network for sensors.
The detected sensors are characterized by the used protocol and the correspond-
ing connector icon. In the "Mapping" column, you can assign the sensor to one of
the available sensor channels. The list can contain several entries but the
R&S SGS can only use up to four sensors simultaneously.

Settings

Sensor Mapping List .................................................................................................. 104
Scan ........................................................................................................................... 105

Sensor Mapping List
Displays a list of all sensor entries with information on the sensor name, the used pro-
tocol, the connector and the assigned mapping.

If a sensor is connected via LAN or uses the USBTMC protocol, its protocol is indica-
ted as "Visa".

Remote command: 
:SLISt[:LIST]? on page 226
:SLISt:ELEMent<ch>:MAPPing on page 226
:SLISt:SENSor:MAP on page 227
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Scan
Scans the network and the USB connections for sensors connected via the VISA com-
munication protocol, i.e. sensors that are addressed via LAN or USBTMC.

Sensors communicating via the USB legacy protocol are detected automatically.

Remote command: 
:SLISt:SCAN[:STATe] on page 226

7.5.8.3  NRP Power Viewer

The R&S SGS features the power viewer function for measuring or monitoring signals
with R&S NRP power sensors.

The R&S SGS can perform up to four power measurements simultaneously. The mea-
sured signals can be the RF output power or other selected signal sources.

About

The R&S SGS can perform up to four power measurements simultaneously.

Depending on the signal characteristic (CW, AM, pulsed, etc.) or the parameter to be
measured (average, peak, etc...) a suitable R&S power sensor must be used.

About the measuring principle, averaging filter, filter length, and achieving stable
results

A sensor measures the average or peak RF power of the source continuously. The
measurement results are displayed in the "NRP Power Viewer" dialog.

The power viewer function uses averaging filters for getting a stable readout.

Measurement results could be interfered for instance by to much noise in your setup,
by a bad supression of harmonics or non harmonics or when you reach the sensitivity
level of your power sensor.

Measurements are continuously repeated in a predefined time window. The measure-
ment result is obtained by averaging the measured values for the last 2N time win-
dows. This approach is referred as a two-step averaging process.

The factor of 2 in the formula arises because the output signals from the microwave
detector are chopped at the same rate as the time windows to suppress low-frequency
noise. An independent measured value can only be obtained from two consecutive val-
ues.

The variable N in the formula indicates the filter length. The filter length then directly
influences the measurement time. The filter length can be selected automatically or it
can be manually set to a fixed value.

Depending on the R&S NRP power sensor type, the manual setting of the filter length
varies in resolution:
● Resolution = 1 for the R&S NRPxx power sensor family
● Resolution = 2n for R&S NRP-Zxx power sensors, with n = 1 to 16
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Follow the following general recommendation to find out the optimum filter length:
● Always start a measurement in auto mode ("Filter > Auto").

Check if the measurement results are sufficient.
● If the power is not constant, select the filter length manually ("Filter > User").

Trigger the "Auto Once" function to search for the optimum filter length for the cur-
rent measurement conditions.
The estimated value is indicated as filter length.

● If the target measurement accuracy value is known, select "Filter > Fixed Noise".
The averaging factor is selected automatically and so that the sensor's intrinsic
noise (two standard deviations) does not exceed the specified noise content.

● Different sensor types achieve the same filtering result with different filter and time
window lengths.
The time window length depends on the sensor type:
– For most sensors, it is fixed to 20 ms.
– For the R&S NRP-Z81 sensor, it is 10 μs.

The R&S NRP-Z81 uses filter length that is 1000 times larger than the filter
length for other sensors.

About zeroing

Activates the auto zero function.

Zeroing calibrates the external power sensor by adjusting its reading at zero signal
power. For this purpose, the RF power source must be switched off or disconnected
from the sensor. If a Rohde & Schwarz power sensor receives an input power during
the zeroing process, it aborts zeroing and generates an error message. Zeroing takes
a few seconds, depending on the sensor model. Refer to the documentation of your
power sensor for more information.

Tips for zeroing

When to perform zeroing:
● During warm up after switching on or connecting the instrument
● After a substantial change of the ambient temperature
● After fastening the power sensor module to an RF connector at high temperature
● After several hours of operation
● When low-power signals are to be measured, e.g. less than 10 dB above the lower

measurement limit.
● Switch off the RF power source for zeroing, but do not disconnect it from the power

sensor. This proceeding keeps the thermal equilibrium, and the zeroing process
also compensates the noise that superimposes the measured signal (e.g. from a
broadband amplifier).

Related settings and functions

● Measurements-related settings, like results, filter, filter length:
NRP Power Viewer Settings

● Sensor-specific information and sensor software update:
Chapter 8.5, "NRP Info", on page 134
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● Software version of the connected power sensor:
:SENSe<ch>[:POWer]:TYPE? on page 235

● Acquisition of level correction data:
Chapter 7.5.5, "User Correction Settings", on page 93.

Additional information

See Rohde & Schwarz website http://www.rohde-schwarz.com in section "Power
Meters & Voltmeters" for:
● R&S NRP power sensor manual.
● Information on the R&S NRP-Z5 sensor hub and the available accessories.
● Sensor software updates.

NRP Power Viewer Settings

Access:

► Select "Instrument" > "NRP Power Viewer".
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The "Overview" tab shows the list of detected sensors, and provides a separate tab
per sensor.

A sensor tab contains all parameters for configuring the sensor settings, like aver-
age or peak display, reference source, filter and level offset.
The remote commands required to define these settings are described in Chap-
ter 11.12, "SENSe, READ, INITiate and SLISt Subsystems", on page 223, includ-
ing the triggering of the measurement and the retrieval of measurement results.

Settings:

Sensor type and serial number .................................................................................. 109
Level (Peak) / Level (Average) ...................................................................................109
Sensor Mapping.......................................................................................................... 109
Sensor Settings...........................................................................................................109

└ State .............................................................................................................109
└ Zero ..............................................................................................................109
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└ Source...........................................................................................................110
└ Frequency .................................................................................................... 110
└ Level Offset State,Level Offset......................................................................110
└ Filter.............................................................................................................. 110
└ Filter Length.................................................................................................. 111
└ Auto Once..................................................................................................... 111
└ Noise Content................................................................................................111
└ Timeout..........................................................................................................111
└ Default Aperture Time................................................................................... 111
└ Aperture Time................................................................................................112
└ S-Parameter .................................................................................................112
└ Enable Logging............................................................................................. 112

Sensor type and serial number
Indicates the type and the serial number of the selected R&S NRP power sensor, and
the channel the sensor is assigned to.

The displayed Level (Peak) / Level (Average) values correspond to the particular sen-
sor.

Remote command: 
:SENSe<ch>[:POWer]:TYPE? on page 235
:SENSe<ch>[:POWer]:SNUMber? on page 233

Level (Peak) / Level (Average)
Indicates the measured peak or average level value.

You can also change the unit for the results display: Watt, dBm or dBμV.

Note: Peak level measurements are provided if the power sensor supports this feature.

Remote command: 
:READ<ch>[:POWer]? on page 227
:SENSe<ch>:UNIT[:POWer] on page 228

Sensor Mapping
Accesses the NRP Sensor Mapping dialog.

Sensor Settings
One tab per sensor provides the corresponding setting parameters.

State ← Sensor Settings
Activates level measurement.

Remote command: 
:INITiate<hw>[:POWer]:CONTinuous on page 227
To query the availability of a sensor at a given connector, use the command :
SENSe<ch>[:POWer]:STATus[:DEVice]? on page 234.

Zero ← Sensor Settings
Activates the auto zeroing.

For details, see "About zeroing" on page 106.
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Remote command: 
:SENSe<ch>[:POWer]:ZERO on page 235

Source ← Sensor Settings
Selects the source for measurement.

"RF" Assigns the signal to the RF path of the R&S SGS.
The R&S SGS transfers the RF frequency and level settings to the
R&S power sensor automatically. Thus you achieve power readings
of high accuracy, irrespective from the connected sensor type.

"User" Sets a user defined frequency.

Example: 
If you have a frequency converting device between the generator and
the DUT. If the frequency converter doubles the frequency, you can
set twice the frequency in the R&S SGS. The R&S power sensor con-
siders this RF frequency setting.

Set the parameter Frequency to the measurement's frequency.

Remote command: 
:SENSe<ch>[:POWer]:SOURce on page 234

Frequency ← Sensor Settings
Defines the frequency value if "Source > User" is used.

Remote command: 
:SENSe<ch>[:POWer]:FREQuency on page 232

Level Offset State,Level Offset ← Sensor Settings
Activates and defines a level offset which is considered in the power meassurement
result. The level offset value is always expressed in dB, irrespective of the display of
the measurement result.

This function allows you to consider, for example, an attenuator in the signal path.

Remote command: 
:SENSe<ch>[:POWer]:OFFSet on page 233
:SENSe<ch>[:POWer]:OFFSet:STATe on page 233

Filter ← Sensor Settings
Selects the way the length of the used filter is defined.

See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 105.

"Auto" Selects the filter length automatically and adjusts it to the measured
value. The value is indicated with the parameter Filter Length.
When high output power is applied, the filter length and therefore the
measurement time can be short.
When low output power is applied, the filter length and therefore the
measurement time is increased which reduces the considered noise
content in your measurement.
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"User" The filter length is defined manually, with the parameter Filter Length.
As the filter length works as a multiplier for the time window, constant
filter length results in a constant measurement time.
Values 1 and 2N are allowed.

"Fixed Noise" The averaging factor is taken automatically in accordance to the
value Noise Content. Thus, the sensor's intrinsic noise (2 standard
deviations) does not exceed the specified noise content.
To avoid long measurement times when the power is too low, set a
Timeout.
Timeout is the maximum acceptable measurement time which limits
the averaging factor and therefore leads to a more unstable readout.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:TYPE on page 232

Filter Length ← Sensor Settings
Sets or indicates the filter length, depending on the selected filter mode.
● "Filter > Auto" indicates the automatically adjusted filter length.
● "Filter > User" enables you to set the filter length manually.
● "Filter > Fixed Noise" hides the setting parameter.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO? on page 230
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] on page 230

Auto Once ← Sensor Settings
Searches the optimum filter length for the current measurement conditions. The result
is indicated with the parameter Filter Length.

See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 105.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:SONCe on page 231

Noise Content ← Sensor Settings
For Filter > Fixed Noise, sets the noise content.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio on page 231

Timeout ← Sensor Settings
For "Filter > Fixed Noise", sets a time limit for the averaging process.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe on page 231

Default Aperture Time ← Sensor Settings
The sensor default setting is sufficient. Disable this parameter to specify a user-defined
aperture time per sensor, if, for example, the readings vary.

To obtain stable readings, set the Aperture Time exactly to one modulation period.

Remote command: 
:SENSe<ch>[:POWer]:APERture:DEFault:STATe on page 228

Level and Power-On Settings
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Aperture Time ← Sensor Settings
If "Use Default Aperture Time > Off", defines the acquisition time per sensor.

For example, to obtain a sufficient low average value, set the aperture time exactly to
one modulation period.

Remote command: 
:SENSe<ch>[:POWer]:APERture:TIMe on page 229

S-Parameter ← Sensor Settings
S-Parameter correction is used to mathematically shift the reference plane to the DUT
by considering the S-parameters for any components connected upstream of the sen-
sor.

The S-Parameter table can be changed with the S-Parameters tool, provided as part of
the free R&S NRP Toolkit software. For more information, refer to the manual of the
connected R&S NRP power sensor.

Remote command: 
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe on page 229
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST? on page 229
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect on page 229

Enable Logging ← Sensor Settings
Activates recording of R&S NRP power sensor readings in a log file.

There is 1 log file per sensor. The log files are created automatically and filled in con-
tinuously. They are text files with predefined filename SensLog<n>.txt, where <n>
indicates the connected sensor. Log files are stored on the internal memory, in the
directory /var/sgs/SensorLogging.

Each log file contains the measured value (2 readings when you work with peak sen-
sors), the sensor type, and the measurement time (timestamp). Logged data is not
overwritten. When a new measurement is started, the collected logging data is appen-
ded in the log file.

Check the used disc space regularly and remove log files to maintain storage capacity.

Note: The logging function is intended for measurements with long time intervals. It is
suitable source for data reconstructions if the connection to the sensor was interrupted.

Remote command: 
:SENSe<ch>[:POWer]:LOGGing:STATe on page 233

7.6  Pulse Modulation

This section explains the pulse modulation settings of the R&S SGS. The equipment
layout for generating the pulse modulation signal includes the option Pulse Modulator
(R&S SGS-K22).

To configure and perform a pulse modulation, you need to select the modulation signal
source and provide the corresponding settings.

Pulse Modulation
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Modulation signal sources

The R&S SGS provides the following signal sources for the signal modulation:
● Internal: A high-performance pulse generator, that allows you to generate either

single or double pulse signals
● Externally supplied signal: the instrument expects the pulse modulation signals

at the [TRIG] connector.

Pulse modulation signal waveforms

The high-performance pulse generator enables you to generate single or double pulse
signals.

Figure 7-3: Pulse generator - single pulse mode

1 = Pulse period
2 = Pulse width
3 = Pulse delay

Figure 7-4: Pulse generator - double pulse mode

1 = Pulse period
2 = Pulse width
3 = Double pulse width
4 = Double pulse delay

Pulse Modulation
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7.6.1  Pulse Modulation Settings

► To access the pulse modulation settings, select "SGMA-GUI > Instrument Name >
Pulse Modulation".

The "Pulse Modulation" dialog contains all parameters required to configure pulse
modulation and pulse signal generation.

State
Activates pulse modulation.

The R&S SGMA-GUI indicates an activated pulse modulation as follows:

Remote command: 
[:SOURce<hw>]:PULM:STATe on page 257

Source
Selects between the internal "Pulse Generator", or an "External" pulse signal for the
modulation. In the later case, the instrument expects the pulse modulation signals at
the [TRIG] connector.

Remote command: 
[:SOURce<hw>]:PULM:SOURce on page 257

Polarity
Sets the polarity of the active slope of the modulation signal for "Source > External".

Remote command: 
[:SOURce<hw>]:PULM:POLarity on page 257

External Impedance
Selects the input impedance for an external pulse modulation signal.

Remote command: 
[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance on page 258

Pulse Modulation
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7.6.2  Pulse Generator Settings

► To access the pulse connector/trigger settings, select "SGMA-GUI > Instrument
Name > Pulse Modulation > Pulse Genrator".

Comprises the settings necessary to configure the internal pulse modulation signal.

Pulse Mode
Sets the operating mode of the pulse generator.

"Single" Generates a single pulse in one pulse period, see Figure 7-3.

"Double" Generates two pulses in one pulse period, see Figure 7-4.

Remote command: 
[:SOURce<hw>]:PULM:MODE on page 256

Pulse Period
Sets the repetition rate of the generated pulse signal, see "Pulse modulation signal
waveforms" on page 113.

Remote command: 
[:SOURce<hw>]:PULM:PERiod on page 256

Pulse Width
Sets the pulse duration of the generated pulse signal, see "Pulse modulation signal
waveforms" on page 113.

Remote command: 
[:SOURce<hw>]:PULM:WIDTh on page 259

Double Pulse Width
Sets the width of the second pulse, see Figure 7-4.

Remote command: 
[:SOURce<hw>]:PULM:DOUBle:WIDTh on page 256

Pulse Modulation
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Pulse Delay
Sets the pulse delay. The pulse delay determines the time that elapses after a trigger
event before pulse modulation starts, see Figure 7-3.

The pulse delay is not effective for double pulse generation.

Remote command: 
[:SOURce<hw>]:PULM:DELay on page 255

Double Pulse Delay
Sets the delay between the start of the first pulse and the start of the second pulse,
see Figure 7-4.

Remote command: 
[:SOURce<hw>]:PULM:DOUBle:DELay on page 256

7.6.3  Pulse Connector/Trigger Settings

► To access the pulse connector/trigger settings, select "SGMA-GUI > Instrument
Name > Pulse Modulation > Connector/Trigger".

Comprises the settings necessary to configure the signal at the multi-purpose
[TRIG] connector in the external trigger mode.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose [TRIG] connector.

"Signal Valid" Output of high signal to mark valid frequency and level settings.

"Not Signal Valid"
Output of high signal to mark the transition state when frequency and
level change.

"Pulse Video Out"
Output of the internally generated pulse video (modulating) signal.
The video signal level corresponds to the RF envelope.

Pulse Modulation
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"Pulse Mod Ext Trigger"
Input for an external trigger signal, used to trigger the pulse genera-
tor.

"Pulse Mod Ext Source"
Input for an externally provided pulse modulation signal.
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 208

Trigger Mode
Selects between continuous pulse modulation or pulse modulation triggered by an
external signal.

"Auto" Generates the modulation signal continuously.

"Ext Single" Generates the signal each time an external trigger event occurs.

"Ext Gated" Generates the signal triggered by an external gate signal.

Remote command: 
[:SOURce<hw>]:PULM:TRIGger:MODE on page 258

Ext. Trigger Input Slope
Available only for "Trigger Mode > Ext Triggered "

Sets the polarity of the active slope of an applied external trigger signal.

Remote command: 
[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe on page 258

Gate Input Polarity
Available only for "Trigger Mode > Ext Gated "

Sets the polarity of the active slope of an applied gate signal.

Remote command: 
[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity on page 258

7.7  Trigger Connector Settings

The dialog provides settings to determine the signal at the input/output of the multi-pur-
pose [TRIG] connector.

► To access the pulse connector/trigger settings, select "SGMA-GUI > Instrument
Name > Connector".

Trigger Connector Settings
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Comprises the settings necessary to configure the signal at the input/output of the
multi-purpose [TRIG] connector.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose [TRIG] connector.

"Signal Valid" Output of high signal to mark valid frequency and level settings.

"Not Signal Valid"
Output of high signal to mark the transition state when frequency and
level change.

"Pulse Video Out"
Output of the internally generated pulse video (modulating) signal.
The video signal level corresponds to the RF envelope.

"Pulse Mod Ext Trigger"
Input for an external trigger signal, used to trigger the pulse genera-
tor.

"Pulse Mod Ext Source"
Input for an externally provided pulse modulation signal.
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 208

7.8  I/Q Modulation and Signal Impairment

The R&S SGS offers I/Q modulation with external analog I/Q signals. I/Q modulation
with an external analog I/Q signal is possible for the instrument equipped with fre-
quency options R&S SGS-B106V/-B112V. The external signal is input via the I and Q
connectors and transferred to the I/Q modulator.

Before the signal is fed into the I/Q modulator, the signal can be impaired. Impairment
at this point along the signal flow is provided for error correction of the supplied signal
or for enabling dedicated impairments. Impairments caused by the I/Q modulator are
automatically corrected by the "Internal Adjustments" function.

System error correction of the I/Q modulator permits precise and repeatable measure-
ments. The correction routine should be called in the case of temperature fluctuations
of several degrees. To call the routine, select "SGMA-GUI > Instrument Name > Setup
> Internal Adjustment" and execute the desired adjustment procedure.

7.8.1  I/Q Impairments

Signal impairments are well-defined arithmetic modifications of the data. Every data
sample is modified in the same way. The purpose of adding impairments to the data

I/Q Modulation and Signal Impairment
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stream is to simulate frequent sources of distortions in a real signal-processing chain to
generate a test signal with dirty transmitter conditions.

7.8.1.1  Gain and Gain Imbalance

An I/Q gain is a multiplication of all I/Q amplitudes by a common factor. The effect is
equivalent to two identical I and Q gain factors. The effect of an increased gain factor
in the I/Q constellation diagram is shown below.

Figure 7-5: Effect of an increased amplitude in the I/Q constellation diagram

An I gain multiplies the I amplitudes by a factor, leaving the Q amplitudes unchanged.
A Q gain has the opposite effect. Different I and Q gain factors result in an I/Q imbal-
ance. This is usually due to different gains of the amplifiers in the I and Q channels of
the I/Q modulator. The effect of a positive and negative gain imbalance is shown
below.

Figure 7-6: Negative gain imbalance (left) and positive (right) gain imbalance in the I/Q constellation
diagram

I/Q Modulation and Signal Impairment
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7.8.1.2  I and Q Offset

An I offset adds a constant value to all I amplitudes, leaving the Q amplitudes
unchanged. A Q offset has the opposite effect. A combination of I and Q values results
in an I/Q offset, which is usually due to carrier feedthrough in the I/Q modulator. Possi-
ble reasons are interfering signals at the RF carrier frequency, e.g. an unsuppressed
RF carrier subchannel. The effect of a positive I and Q offset in the I/Q constellation
diagram is shown below.

Figure 7-7: I offset (left) and Q offset (right) in the I/Q constellation diagram

7.8.1.3  Quadrature Offset

Changes the phase angle between the I and Q vectors from the ideal 90 degrees,
while the amplitudes are maintained. A positive quadrature offset results in a phase
angle greater than 90 degrees. The effect of a positive quadrature offset in the I/Q con-
stellation diagram is shown below.

Figure 7-8: Positive quadrature offset in the I/Q constellation diagram

I/Q Modulation and Signal Impairment
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7.8.2  General I/Q Settings

► To access the settings of the I/Q modulator, select "SGMA-GUI > Instrument Name
> I/Q Settings > General".

Comprises the settings for setting the state and the analog wideband I/Q input.

Mod State
Switches the I/Q modulation on and off.

Remote command: 
[:SOURce]:IQ:STATe on page 246

I/Q Wideband
Setting mode for wideband modulation signals (higher I/Q modulation bandwidth).

The modulation frequency response of the R&S SGS in the useful bandwidth is
improved at the expense of poorer harmonic suppression. This is achieved by shifting
the switching frequencies of the low pass filters in the output section.

Remote command: 
[:SOURce]:IQ:WBSTate on page 248

Crest Factor
Sets the crest factor of the I/Q modulation signal.

The crest factor gives the difference in level between the peak envelope power (PEP)
and average power value (RMS) in dB. This value is necessary for the generation of
the correct output power at the RF output, i.e. the instrument uses the crest factor
value to compensate the average power.

In vector modulation mode, the output level setting is correlated to the nominal full
scale voltage at the I/Q input. If the baseband signal exhibits no constant envelope, the
instrument internal level setting can be corrected by use of the crest factor value.

Remote command: 
[:SOURce]:IQ:CREStfactor on page 247

I/Q Modulation and Signal Impairment
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7.8.3  Analog Impairment Settings

► To access the settings of the I/Q modulator, select "SGMA-GUI > Instrument Name
> I/Q Settings > Analog Impairments".

Comprises the settings like I/Q offset and quadrature offset.

State
Activates/deactivates I/Q impairments.

If activated, the settings for offset, gain imbalance and quadrature offset become effec-
tive.

It is indicated in the function block, if the I/Q impairment is activated.

Remote command: 
[:SOURce]:IQ:IMPairment[:STATe] on page 247

Offset
Sets the carrier offset (in percent) of the amplitudes (scaled to the peak envelope
power (PEP) for the I and/or Q signal component. An ideal I/Q modulator suppresses
the carrier offset completely (offset = 0 percent).

For more information, see Chapter 7.8.1.2, "I and Q Offset", on page 120.

Remote command: 
[:SOURce]:IQ:IMPairment:LEAKage:I on page 246
[:SOURce]:IQ:IMPairment:LEAKage:Q on page 246

Gain Imbalance
Sets the imbalance of the I and Q vector (see Chapter 7.8.1.1, "Gain and Gain Imbal-
ance", on page 119).

The entry is made in dB (default) or %, where 1 dB offset is roughly 12 % according to
the following:

Imbalance [dB] = 20log ( | GainQ | / | GainI |)

Positive values mean that the Q vector is amplified more than the I vector by the corre-
sponding percentage. Negative values have the opposite effect.

I/Q Modulation and Signal Impairment
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Remote command: 
[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude] on page 246

Quadrature Offset
Sets the quadrature offset (see Chapter 7.8.1.3, "Quadrature Offset", on page 120).

Remote command: 
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] on page 247

7.9  Preset

Calls up a defined instrument setup. All parameters and switching states are preset
(also those of inactive operating modes). The default instrument settings provide a
reproducible initial basis for all other settings. However, functions that concern the inte-
gration of the instrument into a measurement setup are not changed, e.g. reference
oscillator settings.

Overview of the most important preset states

The following list gives an overview of the presets for the most important generator set-
tings. The other presets can be found in the information accompanying the remote
commands.
● "RF frequency" = 1 GHz
● "Reference frequency" = "Internal"; adjustment off
● "RF output" switched off
● "Modulator State" = Off

Settings that are not affected by the "SGMA-GUI > Instrument Name > Preset" func-
tion:
● Reference frequency settings ("Ref Oscillator" dialog)
● Power on settings ("Level" dialog)
● Network settings ("Setup" dialog)
● Password and settings protected by passwords ("Setup" dialog)
● "Eco Mode" state ("Setup > Eco Mode" dialog)

To preset the R&S SGMA-GUI itself and all configured instruments to their predefined
state, use the "SGMA-GUI > File > New" function.

SCPI command:

:SYSTem:PRESet on page 205

Preset
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7.10  Extension

Depending on the installed option, your R&S SGS generates an RF signal with fre-
quency range up to 12.75 GHz. Some test cases, however, require even higher fre-
quencies. A general setup would thus include an upconverter connected to the signal
generator and you would have to control both the signal generator and the
upconverter.

The R&S SGS equipped with one of the options R&S SGS-B112/B112V provides the
build-in extension mode for controlling the R&S SGU upconverter. If you connect an
R&S SGU to the R&S SGS, this upconverter acts as an extension to your instrument
extending its frequency range to 20 GHz for instance. Refer to Chapter 5.2, "Setups for
Connecting an R&S SGS and an R&S SGU", on page 42 for a description of the possi-
ble setups.

The extension mode provides the following advantages:
● Simplified calibration of the R&S SGU and single point of control

In this setup, a controller does not need to access the extension, i.e. the R&S
SGU, directly. Instead, the R&S SGS acts as a controller to it and depending on the
required output signal parameters performs all required settings automatically.
The signal generator settings of the extension are disabled for direct configuration
in the R&S SGMA-GUI. However, you can still remotely control the extension using
the corresponding SCPI commands.

● Extended value ranges and functionality
The main application field of the extension mode is the extended frequency range
but you can also benefit from the I/Q modulation and pulse modulation functions of
the extension. For frequencies greater than 12.75 GHz, the combination of R&S
SGS and R&S SGU can generate vector modulated signals even if the R&S SGS
is not equipped with the required options R&S SGS-B106V/B112V.

Prerequisites and required physical connections for operation in extension mode:
● The R&S SGS is equipped with one of the options R&S SGS-B112/B112V.
● A remote PC is connected to the master instrument, the remote PC and the instru-

ment are switched on and a connection between them is established.
The instrument and the extension are connected via a direct remote connection or
over network/switch. All interfaces (LAN, PCIe, or USB) can be used for controlling
the SGU.

● The R&S SGMA-GUI or an application program is running on the remote PC.
● Signal connections between the R&S SGS and the R&S SGU are established, i.e.

the connections between:
– The [RF Out] of the R&S SGS and the [LO In] of the R&S SGU
– For vector modulated signals, the [I Out/Q OUT] of the R&S SGU and the [I

In/Q IN] of the R&S SGS
– The [TRIG] connectors of both instruments

This section describes the manual operation via the R&S SGMA-GUI software. The
remote commands required to define these settings are described in Chapter 11.8,
"EXTension Subsystem", on page 209.

Extension
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To access the extension mode settings and enable the extension mode

1. Select "SGMA-GUI > Instrument Name > Extension".

Tip: Steps 2 and 3 can be omitted if the R&S SGS and a single R&S SGU are con-
nected using PCIe or USB or by a direct LAN connection. In this case, R&S SGS
automatically activates the R&S SGU.

2. Trigger "Scan" to find all available instruments that can serve as an extension to
the particular instrument.

3. Select an instrument from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection to the extension.

4. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

The R&S SGMA-GUI indicates the extended frequency range of the master instru-
ment and the activated extension mode.

You cannot access the signal generation settings of an instrument working in
extension mode. The extension is controlled via the master instrument.
To display the R&S SGU settings, click on the  button next to the instrument's
name.
Select for example "SGMA-GUI > Master Instrument Name > Freq = 20 GHz", "Lev
= -30 dBm" and enable "RF > State > On". The extension adopts these values and
states automatically. To confirm, disable the "Extension > Available Instruments >
Extension Name > Select > Off" and compare the values of the parameters
"SGMA-GUI > Extension Instrument Name > Freq/Lev".

Extension
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Connected
The connection state indicator visualizes the state of selected extension:
● Grey - the connection to the extension is not activated ("Extension > Available

Instruments > Instrument# > Select > Off")
● Green - the extension is connected to the master instrument and can be manually

and remotely operated
● Red - the extension is in standby or locked state, or is performing a time consum-

ing operation

Available Instruments
Lists all available instruments that may serve as an extension to the R&S SGS.

Each instrument is represented by:

"Symbolic Name"
Alias name of the instrument as it is defined in the main panel of
R&S SGMA-GUI.

"Channel" Hardware channel, "Socket", "LAN", "USB" or "PCIe", used by the
extension as remote control channel

"Select" State of the remote connection to the extension.
The R&S SGMA-GUI indicates an activated extension mode as fol-
lows:

Remote command: 
:EXTension:BUSY[:STATe]? on page 211
:EXTension:INSTruments:NAME? on page 210
:EXTension:INSTruments:REMote:CHANnel? on page 210
:EXTension:INSTruments:REMote:LAN:NAME? on page 211
:EXTension:INSTruments:REMote:SERial? on page 211
:EXTension:INSTruments:SCAN[:STATe] on page 210
:EXTension:REMote:STATe? on page 210

Scan
Triggers a scan function and searches for instruments connected to the instrument via
all the available interfaces.

Remote command: 
:EXTension:INSTruments:SCAN[:STATe] on page 210

Test Signal Connections
The "Test" function triggers a test of all signal connections between the instrument and
the extension. The schematic diagram displays the required physical signal connection
for the current test setup and the connection state.

A faulty connection is marked with a red line crossing the drawn blue connection line
as shown in Figure 7-9. If your connection is marked as faulty check whether the
cables are connected properly and if the connection cables are functioning properly.

Extension
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Figure 7-9: A faulty connection between an R&S SGU and an R&S SGS

Note: If your connection is marked as faulty check whether the cables are connected
properly. Check also if the connection cables are functioning properly.

Remote command: 
:TEST:EXTension:CONNection? on page 212
:TEST:EXTension:CONNection:RF? on page 212

Extension
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8  General Instrument Settings and Instrument
Setup
This section describes the settings which do not directly affect signal generation.

Access:

► Select "SGMA-GUI > Instrument Name > Setup" and select the required dialog.

8.1  Internal Adjustments

The R&S SGS is accurate due to the integrated procedures for adjustments.

All internal adjustments for which no external measuring equipment is needed can be
started in the "Internal Adjustments" dialog. The adjustments with external measuring
equipment are described in the service manual.

Adjustment is recommended if the temperature range in which the instrument is oper-
ated changes, before all applications which require maximum level and frequency
accuracy, or after enabling/disabling of the "Eco Mode" (see Chapter 8.12, "Eco Mode",
on page 143).

During adjustment, a bar indicates the status of progress. If an error occurs, adjust-
ment is terminated and an error message is output in the info line.

Risk of invalid adjustment
Wait until the instrument has reached its operating temperature before you start the
adjustment procedure. The warm-up time is 30 minutes.

Internal Adjustments
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Adjust All
Starts all internal adjustments for which no external measuring equipment is needed.
The adjustments with external measuring equipment are described in the service man-
ual.

Remote command: 
:CALibration:ALL[:MEASure]? on page 205

Adjust I/Q Modulator at Current Frequency
Starts the adjustment for the I/Q modulator for the currently set frequency. The I/Q
modulator is adjusted regarding carrier leakage, I/Q imbalance and quadrature.

The adjustment is only possible when "RF > On" and "I/Q Mod > State > On".

Adjustment for only the set frequency is considerably faster than adjustment across the
entire frequency range. An adjustment of the entire range is possible with the I/Q Mod-
ulator button of this dialog.

Remote command: 
:CALibration:IQModulator:LOCal? on page 206

Synthesis
Performs all adjustments which affect the frequency.

Remote command: 
:CALibration:FREQuency[:MEASure]? on page 206

Level
Performs all adjustments which affect the level. The acquired correction values
improve the settling time and the signal quality.

Remote command: 
:CALibration:LEVel[:MEASure]? on page 206

Internal Adjustments
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I/Q Modulator
Starts the adjustment for the I/Q modulator for the entire frequency range. The I/Q
modulator is adjusted regarding carrier leakage, I/Q imbalance and quadrature.

Remote command: 
:CALibration:IQModulator:FULL? on page 206

Delta Temperature
Displays the difference between the current temperature and the temperature by the
last performed adjustment.

Note: Adjustment is recommended if the temperature range in which the instrument is
operated changes, before all applications which require maximum level and frequency
accuracy, or after enabling/disabling of the "Eco Mode" (see Chapter 8.12, "Eco Mode",
on page 143).

Remote command: 
:CALibration:LEVel:TEMPerature? on page 207
:CALibration:FREQuency:TEMPerature? on page 207
:CALibration:IQModulator:TEMPerature? on page 207

8.2  Hardware Configuration

Querying information about the installed assemblies

► Select "SGMA-GUI > Instrument Name > Setup > Hardware Config".

In the "Hardware Config" dialog, the installed assemblies together with their var-
iants and revision states can be displayed for servicing purposes.

Hardware Configuration
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The dialog is a table that lists the installed assemblies. It is divided into the sec-
tions:
● "Common Assembly"
● "RF Assembly"

Assembly
The tables list the installed assemblies.

"Assembly" Name of the assembly

"Part Number" Part Number of the assembly

"Serial Number"
Serial number of the assembly

"Revision" Revision state of assembly

Remote command: 
:SYSTem:HARDware:ASSembly<dir>:NAME? on page 275
:SYSTem:HARDware:ASSembly<dir>:PNUMber? on page 275
:SYSTem:HARDware:ASSembly<dir>:SNUMber? on page 276
:SYSTem:HARDware:ASSembly<dir>:REVision? on page 275

Hardware Configuration
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8.3  Software / Options

Querying information about the installed options and software version

► Select "SGMA-GUI > Instrument Name > Setup > Software/Options".

The "Software/Options" dialog shows the firmware version of the instrument soft-
ware and all installed hardware and software options.

The dialog is divided into the following sections:
● "Firmware"
● "Hardware"
● "Software"
● "Loaded Modules"

Software / Options
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Software options purchased at a later stage can be activated with a keycode. The acti-
vation code is supplied with the software option. An instruction on how to install options
is described in the service manual. Most hardware options need to be installed at an
authorized Rohde & Schwarz service center.

Software
Shows the software/firmware version and the version of the software platform.

Note: Your instrument is delivered with the latest firmware version available. Firmware
updates and the Release Notes describing the improvements and modifications are
provided on the Internet at the download site of the instrument's home page. This
home page always offers the latest information on your instrument, e.g. also on
changes of the firmware update procedure.

Hardware / Software/WinIQSIM
The tables in the sections "Hardware" and "Software" list the installed hardware and
software options.

"Option" Short name of the option

"Designation" Name of the option

"Licenses" Number of licenses

"Expiration Date"
For regular options, "Permanent" is indicated in this column. Some
options are available as trial versions. This column shows their expi-
ration date. After this date, the option is no longer available on the
instrument.

Remote command: 
:SYSTem:SOFTware:OPTion<dir>:NAME? on page 277
:SYSTem:SOFTware:OPTion<dir>:DESignation? on page 276
:SYSTem:SOFTware:OPTion<dir>:LICenses? on page 277
:SYSTem:SOFTware:OPTion<dir>:EXPiration? on page 276

Loaded Modules
Section "Loaded Modules" is provided for service purposes. It lists all loaded software
modules with their versions and offers a short description of each module.

Show Open Source Acknowledgments
Accesses the list of the used open source software packages and the corresponding
verbatim license texts.

8.4  Install SW-Options

Newly purchased software options are enabled in the "Install SW-Option" dialog. They
are ready to operate after they are enabled by a key code supplied with the option.

Install SW-Options
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Only if the instrument is equipped with an older firmware version, a firmware update
before enabling the software option may be required. The information on the valid firm-
ware versions for the purchased software option is provided together with the option.

See:
● Chapter 9.12, "How to Install a New Firmware Version on the Instrument",

on page 159 for information on how to perform firmware update
● Chapter 9.13, "How to Activate Options", on page 161 for instruction on how to

install new options

The firmware update is also described in the service manual.

8.5  NRP Info

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > NRP Info"

Current Sensors
Shows the sensors that are connected to the generator with information on serial num-
ber, the revision state, and some characteristic features.

8.6  Protection

The "Protection" dialog provides access to the unlocking of protected service functions
(authorized personnel of R&S Service Departments only).

Unlocking of protected service functions

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Protection".

The "Protection" dialog provides access to the unlocking of protected service func-
tions (authorized personnel of R&S Service Departments only).

Protection
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2. To deactivate the protection, the correct password has to be entered. After the
instrument has been switched on, the protection levels 1 to 4 are automatically
activated.
Enter "Protection Level 1 > Password > 123456".

Protection Level 1 is activated.

Protection Level / Password
"Protection Level 1" can be activated to expand the functionality of the internal adjust-
ment. The password is 123456.

The other protection levels 2 to 4 provide access to protected service functions. Only
the authorized personnel of R&S Service Departments can access these functions.

8.7  Security Setting

The R&S SGS employs a security concept based on user and security password. The
security password is required for changing several critical settings, like performing firm-
ware updates. Access to the passwords and mass storage security settings is provided
in the "Security" dialog.

► To access the "Security" dialog, select "SGMA-GUI > Instrument Name > Setup >
Security"

The menu is divided into the password sections and the security settings section. In
the password section, the passwords for securing a controlled access to the instrument
are defined and changed.

A change of passwords for the operating system and security password requires the
entry of the old and new password and the conformation of the new password. All set-
tings are only accepted after the "Change Password" button is pressed.

Security Setting
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The settings of this dialog are not accessible over remote control (e.g. SCPI com-
mands).

Change User Password
The user name and password are required for remote access to the instrument via
VNC, FTP or SAMBA.

Note: It is highly recommended to change the default user password before connect-
ing the instrument to the network.

User Name ← Change User Password
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SAMBA access.

Old Password ← Change User Password
Enter the currently used user password. The default password is "instrument".

Security Setting
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New Password ← Change User Password
Enter the new user password.

Confirm Password ← Change User Password
Enter the new password for conformation.

The new password is only valid after the "Change Password" button is pressed.

Change Password ← Change User Password
Changes the password accordingly.

Change Security Password
Note: It is highly recommended to change the default security password before con-
necting the instrument to the network.
The security password is, for example, required when changing the status of the USB
and LAN interface.

Old Password ← Change Security Password
Enter the currently used security password. The default password is '123456'.

New Password ← Change Security Password
Enter the new security password. The security password may contain decimal charac-
ters only.

Confirm Password ← Change Security Password
Enter the new password for conformation.

The new password is only valid after the "Change Password" button is pressed.

Change Password ← Change Security Password
Changes the password accordingly.

Security Settings
Comprises the settings for enabling and disabling the USB and LAN interfaces. The
setting requires the entry of the security password and is only accepted after the
"Accept" button is pressed.

USB Device ← Security Settings
Enable/disable the USB interface.

Note: The instrument does not recognize any device connected to the USB interface
when the interface is disabled.

LAN Connection ← Security Settings
Enable/disable the LAN interface.

Note: It is not possible to access the instrument via LAN while the LAN connection is
disabled.
An enabled LAN connection is a prerequisite for the remote control of the instrument
via VNC, FTP or SAMBA.

Security Setting



General Instrument Settings and Instrument SetupR&S®SGS100A

138User Manual 1173.9105.02 ─ 12

Security Password ← Security Settings
Enters the password that is required to enable or to disable the settings protected by a
security password. The default is '123456'.

Note: It is highly recommended to change the default security password before con-
necting the instrument to the network. To change the security password, select
"SGMA-GUI > Instrument Name > Setup > Security > Change Security Password".
The settings are only accepted after the "Accept" button is pressed.

Accept ← Security Settings
Accept a new entry or selection and change the settings accordingly.

8.8  Maintenance

The R&S SGS provides a special dialog for performing some maintenance procedures,
like installing firmware packages.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Mainte-
nance".

Operation
Selects the desired maintenance operation.

Select Package
Available only for "Operation > Install Firmware Package".

Selects the firmware package to be installed, see also Chapter 9.12, "How to Install a
New Firmware Version on the Instrument", on page 159.

Update All
Available only for "Operation > Install Firmware Package".

Enable this function to perform a simultaneous firmware update on all instruments, that
are in active state and are connected to this controller.

Note: A firmware update and the required subsequent restart and the automatically ini-
tiated internal adjustment process of the controller may be a time consuming operation.

Maintenance
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This feature accelerates the update process and the required restart of the external PC
can be executed once after the update operation of all instruments is completed.

Security Password
Enters the password that is required to enable or to disable the settings protected by a
security password. The default is '123456'.

Note: It is highly recommended to change the default security password before con-
necting the instrument to the network. To change the security password, select
"SGMA-GUI > Instrument Name > Setup > Security > Change Security Password".
The settings are only accepted after the "Accept" button is pressed.

Accept
Accept the selected operation and perform the required procedure.

PCIe Interface Mode
Sets the PCIe interface mode for the R&S SGS.

"Endpoint" Standard mode.

"Root Com-
plex"

The mode needed for a direct PCIe connection of an R&S SGS and
an R&S SGU.

8.9  Network Settings

The instrument is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The "Network Settings" dialog provides access to the
network settings.

Risk of network errors!
Connection errors can affect the entire network.
If your network does not support DHCP, or if you choose to disable dynamic TCP/IP
configuration, you must assign valid address information before connecting the instru-
ment to the LAN.
Contact your network administrator to obtain a valid IP address.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Network
Settings".

Network Settings
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The dialog provides access to the network settings, like settings about the general net-
work environment and specific identification of the computer in the network. The dialog
also displays an indication whether the instrument is connected to the network or not.

Restart Network
Shuts down the network connection of the instrument and then re-establishes the con-
nection.

This function can be used to resolve network problems.

Note: Only the connection of the instrument to the network restarts, the network itself
is not affected.

Hostname
Displays the individual computer name of the instrument.

A predefined name is indicated and can be used for network connections, see Chap-
ter 6.4.3, "Finding Out the Default Hostname of the Instrument", on page 71.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname on page 270

MAC Address
Indicates the MAC address of the network adapter.

Address Mode
Selects if the IP address is assigned automatically or manually.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Network Settings
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Note: Lost LAN connection to an instrument.
If the connection to an instrument configured to use static IP addresses is lost, press
the [LAN LED] on the instrument front panel.
This resets the "Address Mode" to its default value ("Auto (DHCP)").

"Auto (DHCP)" The IP address is assigned automatically.
The network used must support automatic assignment of IP address
via DHCP or APIPA (Zeroconf) to use this function.

"Static" The IP address is assigned manually.

Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress:MODE on page 269

IP Address
Displays the IP address. To enter the IP address manually, select "Address Mode >
Static".

If there is manual input of the IP address, it is recommended that a connection of the
instrument to the network is coordinated with the network administrator. Connection
errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress on page 269

Subnet Mask
Displays the subnet mask. To enter the subnet mask manually, select "Address Mode >
Static".

This number is used together with the IP address to identify the network segment the
instrument is in.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK on page 271

Default Gateway
Displays the IP address of the default gateway. To enter the default gateway manually,
select "Address Mode > Static".

This address identifies the router on the same network as the instrument that is used to
forward traffic to destinations beyond the local network.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway on page 270

Apply
Applies the network settings to the instrument.

Network Settings
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8.10  Remote Channels

The "Remote" dialog provides access to the settings for remote control.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Remote".

Visa Resource Strings
Indicates the VISA resource strings used for remote control of the instrument. A sepa-
rate string is provided for remote control via the different interfaces.

Note: For background information and description of the syntax of the VISA resource
strings, refer to the description of the corresponding interface in Chapter 10.1, "Remote
Control Interfaces and Protocols", on page 162.

Remote command: 
:SYSTem:COMMunicate:HISLip:RESource? on page 272
:SYSTem:COMMunicate:NETWork:RESource? on page 271
:SYSTem:COMMunicate:SOCKet:RESource? on page 273
:SYSTem:COMMunicate:USB:RESource? on page 273
:SYSTem:COMMunicate:PCIexpress:RESource? on page 272

Device Identity
Triggers the device identification function. The [LAN] LED on the front panel of the
selected instrument blinks.

See also Chapter 6.4.4, "Bidirectional Instrument Identification ", on page 71.

8.11  Factory Preset

The "Factory Preset" dialog provides a function to reset the instrument's settings to
their factory states

Factory Preset
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1. To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Factory
Preset".

2. Select "Execute Factory Preset".

The instrument's settings are reset to their factory states. Security settings and
user data are not effected.

Execute Factory Preset
Reset the instrument's settings to their factory state.

Note: Because "Factory Preset" resets the "Remote Channel Settings" and "Network
Settings" to the default values, executing factory preset via remote control may termi-
nate the connection to the instrument, if these settings had been configured to values
different to the default ones!
The factory preset function resets nearly all instrument settings. In addition to the regu-
lar preset, a "Factory Preset" resets also the following values:
● Power on settings ("Level" dialog)
● Network settings including hostname ("Setup > Network Setting" dialog)
● Remote Channel settings ("Setup > Remote Channel" dialog)
● Eco Mode state ("Setup > Eco Mode" dialog)
To maintain security, password settings and all settings protected by these passwords
like disabled USB and LAN connections are not changed.

Not affected by the "Factory Preset" are also user data, lists or instrument settings
files, created, for example, with the "File Save As" function.

Remote command: 
:SYSTem:FPReset on page 205

8.12  Eco Mode

This energy saving mode is available only for instruments equipped with
optionR&S SGS-B112/B112V.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Eco
Mode".

Eco Mode
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With enabled "Eco Mode 1" the doubler stage in a 12.75 GHz instrument is perma-
nently switched off to reduce power consumption and the maximum frequency is
limited to 6 GHZ. An enabled "Eco Mode" is indicated by a green coloring of the
frequency range in the R&S SGMA-GUI.

Risk of invalid adjustment after changing the Eco Mode
The switching off and on of the doubler stage changes the thermal conditions in the
instrument.
In order to achieve correct adjustment of the instrument, make sure that the instrument
is warm before performing adjustments. The warm-up time is 30 minutes.

Performing adjustment in eco mode
The instrument performs the internal adjustment within the currently active frequency
range, i.e. up to 6 GHz for enabled mode "Eco Mode 1". The correct alignment of the
parameters outside of the current active frequency range is not guaranteed. A subse-
quent readjustment for the total frequency range of the instrument is recommended.

The state of this parameter is not affected by an instrument "Preset". This parameter is
influenced only by the Factory Preset.

SCPI command:

:SYSTem:EMODe on page 266

8.13  Standby and Restart

See Chapter 9.9, "How to Switch between the Operating States", on page 156.

8.14  Diagnostic and Tests

This section describes the settings provided for diagnostic and test purposes.

Diagnostic and Tests
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8.14.1  Self-test

1. To access this dialog, select "SGMA-GUI > Instrument Name > Diagnostic Tests >
Self-test".

2. To trigger a self-test, select "Self-test".

Performs a self-test on all installed hardware options.

The result of the self-test, succeeded or failed, is displayed. The list of the numeric
results of the performed test cases is protected by protection level 2.

SCPI command:

:TEST:ALL:STARt on page 278

:TEST:ALL:RESult? on page 278

8.14.2  Keyboard Tests

Access:

► Select "SGMA-GUI > Instrument Name > Diagnostic Tests > Keyboard Test".

Use this function to check the proper operation of all front panel elements.

If "Keyboard Test" is enabled, all front panel LEDs except the [POWER ON] are
orange.

The exact test procedure is described in the service manual.

SCPI command:

:TEST:KEYBoard[:STATe] on page 278

Diagnostic and Tests
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8.15  External Adjustments

The external adjustment is a protected service procedure, that requires a Protection
Level 2 password. The exact test procedure is described in the service manual.

Access:

1. Select "SGMA-GUI > Instrument Name > Protection" and enter the Protection
Level 2 password.
(See "Unlocking of protected service functions" on page 134)

2. Select "SGMA-GUI > Instrument Name > Service > External Adjustments".

Depending on the installed options, the R&S SGS is equipped with a TCXO or OCXO
reference oscillator. The reference oscillator is factory calibrated to a specific calibra-
tion value. In the external adjustment dialog, you can select a different (custom) cali-
bration value.

Active Adjustment Data
Selects whether the factory provided or a custom defined calibration value is used to
adjust the reference oscillator.

Remote command: 
:CALibration:ROSCillator:DATA:MODE on page 207

Calibration Value
Sets a user definable calibration value.

The permanent storage of this value in the instrument's memory is a password protec-
ted function. The exact test procedure is described in the service manual.

This parameter is restored to its permanently stored value by "Preset" and instrument
restart.

Remote command: 
:CALibration:ROSCillator[:DATA] on page 208

External Adjustments
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9  Performing Configuration Tasks
This section provides a general explanation on how to operate the instrument manually
via the R&S SGMA-GUI software.

We assume, that the R&S SGS is connected to a remote PC. The R&S SGMA-GUI
software has to be installed on this remote PC and the instrument has to be added to
the list of "Available Instruments".

For information on how to fulfill these requirements, refer to:
● Chapter 2.3.2.1, "Connecting the Instrument to the Network", on page 25
● Chapter 2.3.1, "Installing the R&S SGMA-GUI Software", on page 23
● Chapter 2.3.2.3, "Automatically Adding Instruments to the SGMA-GUI ",

on page 27

General workflow

The general workflow for generating a signal with the R&S SGS comprises the follow-
ing main steps:

1. Decide whether you want to generate a CW or an I/Q modulated signal.
See Chapter 9.1, "How to Generate an I/Q Modulated Signal", on page 147.

2. Select the operating mode.
See Chapter 9.3, "How to Enable a Baseband Bypass Mode", on page 151.

3. Configure the reference and local oscillator settings.
See Chapter 9.4, "How to Configure the Reference Oscillator Source",
on page 152 and Chapter 9.5, "How to Configure the Local Oscillator (LO) Cou-
pling Source", on page 153.

4. Adjust the frequency, level and I/Q settings, for example, to optimize performance
or to add impairments to the generated signal (see Chapter 9.11, "How to Optimize
Performance", on page 158).

9.1  How to Generate an I/Q Modulated Signal

The instrument is manually operated via the R&S SGMA-GUI software.

The I/Q Modulator requires the hardware option R&S SGS-B106V and for operation up
to 12.75 GHz also the hardware option R&S SGS-B112V.

An example of how to configure the instrument to generate a continuous wave (CW)
signal is provided in Chapter 4, "First Steps with the Instrument", on page 36.

How to Generate an I/Q Modulated Signal
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To generate an I/Q modulated signal

1. Connect the test equipment. Provide the external analog signal to be modulated at
the I and Q connectors of the instrument.
The Figure 9-1 shows an example of the test setup. A signal generator, e.g. R&S
AFQ100B is used as a source of the external analog signal. The R&S signal gener-
ator provides its internal reference signal to the R&S SGS and the connected sig-
nal analyzer, e.g. the R&S FSW.

Figure 9-1: Example of the setup

Tip: Refer to the user manual of the R&S signal generator and the R&S signal ana-
lyzer for information on how to configure the corresponding instrument.

2. Select "SGMA-GUI main panel > Instrument Name > Reference Oscillator > Ext"
and adjust the settings as required.

3. Select "SGMA-GUI main panel > Instrument Name > Frequency/Phase > LO Cou-
pling Source > Int".

Tip:
For detailed description on how to select the reference frequency source and the
LO coupling source, refer to:
● Chapter 9.4, "How to Configure the Reference Oscillator Source", on page 152

and
● Chapter 9.5, "How to Configure the Local Oscillator (LO) Coupling Source",

on page 153.

4. In the "Frequency/Phase" dialog, configure the frequency settings.

5. Select the "SGMA-GUI > Instrument Name > Level > RF Level > Level" and set
the"RF Level".
In the same dialog, configure the further "Level" and "Power-On" settings.

6. Select the "SGMA-GUI main panel > Instrument Name > I/Q settings > Analog
Impairments" and enable I/Q impairments.

How to Generate an I/Q Modulated Signal
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In the "I/Q settings >General" dialog, set "State > On" to enable the I/Q modulator.

7. Select "SGMA-GUI main panel > RF > On" or press the [RF ON] key on the front
panel of the instrument.

The [RF ON] key is green.

The I/Q modulated signal is output at the RF connector of the instrument.

How to generate an I/Q modulated signal with higher RF?
If the R&S SGS is equipped with one of the options R&S SGS-B112/B112V, you can
connect an extension, an R&S SGU, to it and thus extend the frequency range of the
generated I/Q signal up to 40 GHz.
Refer to Chapter 9.2, "How to Generate I/Q Signals with an R&S SGS and an R&S
SGU Upconverter", on page 149 for more information.

9.2  How to Generate I/Q Signals with an R&S SGS and an
R&S SGU Upconverter

Options R&S SGS-B112V and R&S SGU-B120V/-B140V are required for the I/Q mod-
ulation.

To generate an I/Q modulated signal with higher frequency

In this example, the R&S SGU acts as an extension to the R&S SGS extending its fre-
quency range to 40 GHz.

The Figure 9-2 shows an example of the test setup.

How to Generate I/Q Signals with an R&S SGS and an R&S SGU Upconverter
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Figure 9-2: Example of the test setup

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

If a common reference frequency is required, use the internal reference signal of the
signal generator and provide it to the R&S SGS and the connected signal analyzer,
e.g. the R&S FSW.

1. Connect the test equipment as shown on Figure 9-2:

a) Connect the R&S SGS, the R&S SGU and the controller to a LAN switch.
b) Connect the [I/Q OUT] of the base band signal source to the[I/Q IN] of the R&S

SGU.
c) Connect the [I/Q OUT] of the R&S SGS to the I and Q connectors of the R&S

SGS.
d) Connect the [RF OUT] of the R&S SGS to the [LO IN] of the R&S SGU.
e) Connect the [TRIG] connectors of the R&S SGS and the R&S SGU.
f) Connect the [RF OUT] of the R&S SGU to the [RF IN] of the signal analyzer.

2. Select "SGMA-GUI main panel > R&S SGS > Extension".

Tip: Steps 3 to 5 can be omitted if the R&S SGS and a single R&S SGU are con-
nected using PCIe or USB or by a direct LAN connection. In this case, the R&S
SGS automatically activates the R&S SGU.

3. Press the ID key on the front panel of the R&S SGU (only required if the compo-
nents are connected via a company network).

4. In the "Extension" dialog, trigger "Scan".

How to Generate I/Q Signals with an R&S SGS and an R&S SGU Upconverter
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The scan function finds out the connected R&S SGU.

5. Select the R&S SGU from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection to the extension.

6. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

7. Select "SGMA-GUI > R&S SGS > Freq = 20 GHz", "Lev = -30 dBm" and enable
"RF > State > On".

The extension adopts these values and states automatically. Generated is an I/Q
signal with "RF = 20 GHz" and "Level = -30 dBm".

9.3  How to Enable a Baseband Bypass Mode

1. Provide an external analog signal at the I or Q connector or on both at the rear of
the instrument.
Refer to Figure 5-9 for visualization of the signal flow.

2. Select "SGMA-GUI > Instrument Name > Operation Mode > Baseband Bypass".

How to Enable a Baseband Bypass Mode
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Some instrument's functions like "Frequency" and I/Q settings are disabled.

3. Select "SGMA-GUI > Instrument Name > Level > RF Level" and adjust the level of
the output signal.

4. Set "SGMA-GUI > RF > On" or press the [RF ON] key on the front panel of the
instrument to enable the output of the generated signal at the RF connector.

The [RF ON] key is green.

The fed signal is amplified with the selected value and output at the RF connector
of the instrument.

9.4  How to Configure the Reference Oscillator Source

To use the internal reference frequency source

1. To enable the instrument to use its internal reference frequency source, perform
one of the following:

a) Select "SGMA-GUI main panel > Ext Ref Off ".
b) Select "SGMA-GUI > Instrument Name > Reference Oscillator > Source > Int".

2. In the "Reference Oscillator" dialog, set the "REF/LO Out > REF".

The "Output Frequency" can be configured to either 10 MHz or 1 GHz.

The instrument uses the internal reference signal. The [REF EXT] LED at the front
panel of the instrument is off.

To output the reference frequency (internal or external) at the REF/LO OUT connector
of the instrument, select "Reference Oscillator > REF/LO Output > REF".

To use an external reference frequency source

To improve measurement accuracy, it is advisable to provide an external reference fre-
quency to all the instruments in the test setup or to distribute the internal reference sig-
nal of the signal generator to the remaining instruments.

1. Provide the signal of an external reference frequency source to the REF/LO IN
connector of the instrument.

2. To enable the instrument to use the external reference frequency source, perform
one of the following:

a) Select "SGMA-GUI main panel > REF > Ext Ref On ".
b) Select "SGMA-GUI > Instrument Name > Reference Oscillator > Source > Ext".

How to Configure the Reference Oscillator Source
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3. In the "Reference Oscillator" dialog, set the parameter "Ext. Ref. Input Frequency"
to the value of the fed external reference frequency.

Now, the instrument uses an external reference signal. The green [REF EXT] LED
at the front panel of the instrument indicates that the instrument is synchronized to
the external reference signal.

If the instrument is configured to use an external reference signal but no signal is fed in
at the REF/LO IN connector, the [REF EXT] LED on the front panel of the instrument is
red and an error message is displayed in the "Info" line.

9.5  How to Configure the Local Oscillator (LO) Coupling
Source

The R&S SGS can use two frequency sources for the carrier frequency (LO signal) of
the I/Q modulator, an internal and an external one. The first possibility is to use the out-
put signal of the internal synthesizer. If an external LO signal is provided at the REF/
LO IN connector, this signal can alternatively be directly routed to the LO input of the
I/Q modulator.

To use an external LO source

1. Provide the signal of an external LO source to the REF/LO IN connector of the
instrument.

Note: The local oscillator input/output requires the additional software option
R&S SGS-K90.

2. Select "SGMA-GUI > Instrument Name > Frequency/Phase > LO Coupling Source
> Ext".

Tip: When you select "Source > Ext", the icon LO Scr Ext appears in the
R&S SGMA-GUI.

The signal provided by the external frequency source is directly routed to the input
of the I/Q modulator and used as carrier frequency.

To use the internal LO source

► Select "SGMA-GUI > Instrument Name > Frequency/Phase > LO Coupling Source
> Int".

The output signal of the internal synthesizer is used.

How to Configure the Local Oscillator (LO) Coupling Source



Performing Configuration TasksR&S®SGS100A

154User Manual 1173.9105.02 ─ 12

9.6  How to Define the Signal at the REF/LO OUT Connec-
tor

The reference oscillator and the LO use the same [REF/LO IN] connector. Hence, it is
not possible to use both an external reference source and an external LO source signal
at the same time.

The signal at the [REF/LO OUT] connector also depends on the selected reference
oscillator and LO sources. The following table gives an overview of this dependency.

Table 9-1: Selection available at the REF/LO OUT connector depending on the LO and reference
oscillator sources

 LO coupling source  

Ref. oscillator source Int "Ext"

"Int" "OFF/REF/LO" "OFF/LO"

"Ext" "OFF/REF/LO" Combination not possible

To define the signal at the REF/LO OUT connector

1. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select the "LO
Source" as required.

2. In the "Reference Oscillator" dialog, select the "Ref. Oscillator Source" as required.

3. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, set the
"REF/LO Output".
Consider the dependencies, see Table 9-1.

9.7  How to Connect and Configure Instruments for Opti-
mum Phase Coherence

Using the LO input/output connectors, two or more instruments can be coupled to ach-
ieve optimum phase coherence between their RF output signals. The first instrument in
the chain delivers the LO signal at the [REF/LO OUT] connector to the [REF/LO IN]
connector of second instrument. If necessary, more instruments can be connected in
the same way. The first instrument is set such that the internal synthesizer generates
the system LO frequency. In all following instruments, the internal synthesizer is
switched off and the LO signal from the [REF/LO IN] connector drives the I/Q modula-
tor or the CW path.

To connect the instruments

1. Connect the instruments as a daisy chain (see Figure 9-3), i.e. connect the
[REF/LO IN] connector of each further instrument to the [REF/LO OUT] connector
of the previous one.

2. Optionally, provide an external reference signal for the first instrument.

How to Connect and Configure Instruments for Optimum Phase Coherence
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3. Avoid unnecessary cable lengths and branching points.

Refer to Figure 9-3 for an example of how to connect two instruments for achieving
phase coherence. The configuration can be extended by further instruments.

Figure 9-3: Example of a setup: LO coupling

To configure the first instrument in the chain

1. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "LO
Source > Internal".

2. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "REF/LO
Output > LO".

3. If an external reference frequency is used, select "SGMA-GUI > Instrument Name
> Reference Oscillator > Source > External".

To configure next instruments

1. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "LO
Source > External".

2. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "REF/LO
Output > LO".

9.8  How to Restore the LAN Connection to an Instrument

► If the LAN connection to an instrument configured to use a static IP address is lost,
press the [LAN LED] on the instrument's front panel for more than 3 seconds to
reset the LAN settings and to set the "Address Mode" on page 140 to DHCP.

Provided the network supports automatic assignment of IP address, new IP
address is automatically assigned to the instrument.

How to Restore the LAN Connection to an Instrument
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9.9  How to Switch between the Operating States

The Figure 9-4 gives an overview of the operating states of the instruments and how to
trigger the switch-over between them.

Figure 9-4: Operating states

:RESTart, :STANdby = SCPI commands
"Setup > Standby", "Setup > Restart", "Shut Down Instru-
ments and Exit"

= R&S SGMA-GUI controls

POWER ON/STANDBY, POWER SWITCH ON/OFF = Hardkey controls on the front/rear panel of the
instrument

The Table 9-2 provides a short description of the operating states and their indication.

Table 9-2: Indication of the operating states

Operating
state

Description Indication

Off The instrument is shut down. All LEDs on the front panel of the instrument
are off.

Booting The instrument boots the operating system
and starts the instrument firmware.

If the previous session was terminated reg-
ularly, the instrument uses the last setup
with the relevant instrument settings.

The green [POWER ON /STAND BY] key
blinks.
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Operating
state

Description Indication

Standby The standby power mode keeps the power
switch circuits and the remote control sys-
tem active.

In this state, it is safe to switch off the AC
power and disconnect the instrument from
the power supply.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is red.

The orange [POWER ON /STAND BY] key is
on.

Ready

(normal
operation)

The instrument is ready for operation. All
modules are power-supplied.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is green.

The green [POWER ON /STAND BY] key is
on.

To switch the instrument to standby state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Standby".
b) Press the [POWER ON /STAND BY] key on the front panel of the instrument.
c) Send the SCPI command:

:SYSTem:REBoot
The current instruments settings are automatically stored. The instrument switches
to a power-saving mode.
In the R&S SGMA-GUI, the standby state is indicated by the red state symbol in
front of the corresponding instrument's name, on the front panel, by the orange
[POWER ON /STAND BY] button.
The instrument can still be remote controlled.

To return the instrument from standby to ready state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Restart".
b) Press the orange [POWER ON /STAND BY] key on the front panel of the

instrument.
c) Send the SCPI command:

:SYSTem:RESTart
The instrument loads the last setup with all instrument settings, switches to ready
state and is ready for normal operation.
In the R&S SGMA-GUI, the ready state is indicated by the green state symbol in
front of the instrument's name.
On the front panel, the ready state is indicated by the green [POWER ON /STAND
BY] button.

To switch all connected instruments to standby state and close the R&S SGMA-
GUI

► In the R&S SGMA-GUI main panel, select "File > Shut down instruments and exit".

The R&S SGMA-GUI quits and switches the connected instruments to standby
state.

How to Switch between the Operating States



Performing Configuration TasksR&S®SGS100A

158User Manual 1173.9105.02 ─ 12

For description on how to terminate work and shut down the instrument regularly, refer
to Chapter 2.1.5, "Switching the Instrument On and Off", on page 19.

9.10  How to Use Computer Names

If there is a name server in the network, alternatively to the IP address each PC or
instrument connected in a LAN can be accessed via an unambiguous computer name.
Each instrument is delivered with an assigned computer name, but this name can be
changed.

For instruction on how to find out the default computer name, refer to Chapter 6.4.3,
"Finding Out the Default Hostname of the Instrument", on page 71.

To query and change a computer name

To avoid violations and to make use of the easy identification provided by the computer
name, it is recommended to keep the default hostname unchanged.

1. Open "SGMA-GUI > Instrument Name > Setup > Network Settings" dialog.

The computer name is displayed under "Hostname".

2. Select "SGMA-GUI > Instrument Name > Setup > Protection" and enable the "Pro-
tection Level 1".

The parameter "Hostname" in the "Network Settings" dialog is now enabled for
configuration.

3. Change the "Hostname".

4. Press the [POWER ON /STAND BY] key to restart the instrument.

Note: The "Factory Preset" function restores the factory value of the parameter
"Hostname".

9.11  How to Optimize Performance

In its (factory) preset state, the instrument uses predefined frequency and level setting
designed for best performance. The predefined settings, e.g. the"Level modes" "Auto"
and "Normal", ensure that the instrument automatically selects the optimal settings
according to the configured RF frequency and level.

However, in some special application cases it might be necessary to choose different
settings or to optimize the signal for the particular application. This section describes
instructions on how to achieve that.

How to Optimize Performance
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Restoring the default settings
Use the "R&S SGMA-GUI main panel > Instrument name > Preset" or the "R&S
SGMA-GUI main panel > Instrument name > Setup > Factory Preset" function to return
the instrument to its predefined state.

For information on how to adjust the quality characteristics of the RF output signal, i.e.
to optimize the quality characteristics of RF output signal, refer to Chapter 7.5, "Level
and Power-On Settings", on page 87.

For information on how to adjust the reference oscillator, e.g. to allow the frequency of
the internal reference oscillator to be impaired, refer to Chapter 7.4, "Reference Oscil-
lator", on page 84.

9.12  How to Install a New Firmware Version on the Instru-
ment

You can update the firmware of the R&S SGS .

Firmware installation through the R&S SGMA-GUI

If an update to a new firmware version is required for both the R&S SGMA-GUI and the
instrument, it is mandatory that the new instrument's firmware is installed before the
update of the R&S SGMA-GUI to the new version.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintenance > Oper-
ation > Install firmware package".

2. Press "Select Package" and navigate to the directory the new firmware is stored in.

3. If several instruments have to be updated to new firmware version, enable the fea-
ture "Update All " to accelerate the update process.

All instruments that are in active state and are connected to this controller are
updated simultaneously.

4. Enter the "Security Password".

5. Confirm the update with "Accept".

The software transfers the firmware file and automatically starts the update proce-
dure. During the update, the message "Updating Firmware" is displayed in the
"Info" line. The update process is indicated by an LED running light.

Note: The update procedure requires a restart of the instrument. The restart is per-
formed automatically. The instrument is not accessible during that time.

6. Wait until the message "Updating Firmware" disappears and the update is comple-
ted.

The green [POWER ON /STAND BY] LED is on.

How to Install a New Firmware Version on the Instrument



Performing Configuration TasksR&S®SGS100A

160User Manual 1173.9105.02 ─ 12

Tip: Calibration error. If the "Info" line shows the message "Calibration Error",
select "SGMA-GUI main panel > Instrument Name > Setup > Internal Adjustments
> Adjust All" to trigger internal adjustment.

7. If necessary, install the new R&S SGMA-GUI.
For detailed description, refer to Chapter 2.3.1, "Installing the R&S SGMA-GUI
Software", on page 23

8. If the instrument and the controller/PC are connected over the PCIe interface and
the external PC does not support hot-plugging, restart the external PC.

Firmware update through a session control protocol (SCP)

If an update to a new firmware version is required for both the R&S SGMA-GUI and the
instrument, it is mandatory that the new instrument's firmware is installed before the
update of the R&S SGMA-GUI to the new version.

1. Connect the R&S SGS and a Windows PC to the same network.

2. On the PC, open a windows explorer window.

3. To connect to the R&S SGS, enter the name of the instrument or its IP address in
the windows taskbar.

4. Enter the user name and password to connect to the R&S SGS. The default user
name is instrument and the password is instrument.

A folder opens, containing the share and the update folder.

5. Open the update folder and copy the new firmware update file in it.

The update starts automatically.

Unsuccessful or erroneous firmware update
An erroneous or unsuccessful installation of firmware update package is indicated by a
combination of one orange and red LEDs on the front panel.
Refer to the service manual for a description of the displayed error code or contact the
customer support center.
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Performing Configuration TasksR&S®SGS100A

161User Manual 1173.9105.02 ─ 12

9.13  How to Activate Options

A firmware update before the activation of the SW option may be required.
Refer to the description of the SW option for the required firmware version.
See also Chapter 9.12, "How to Install a New Firmware Version on the Instrument",
on page 159 for instruction on how to update the firmware version.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Install SW-Options".

2. Select "Option Key" and enter the key code delivered with the new option.

The new option is now enabled and ready for operation.

9.14  How to Manually Set a PCIe Direct Connection
between an R&S SGS and an R&S SGU

To build a direct PCIe connection between an R&S SGU and an R&S SGS, which has
a "Controller > Revision" < 5, first you have to set the correct PCIe interface mode
manually. If your R&S SGS has a "Controller > Revision" 5 or higher, these settings are
done automatically.

You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

Toset a PCIe direct connection between an R&S SGS and an R&S SGU manually

1. Connect the R&S SGS and the R&S SGU directly using a PCIe cable. Refer to
Chapter 10.3.4, "Connecting the Controller and the Instrument", on page 176 for
cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

3. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintainance".

4. Select "Operation > PCIe Interface Mode".

5. Select "PCIe Interface Mode > Root Complex".

6. Restart your instrument for the changes to take place.

The PCIe connection between the R&S SGS and the R&S SGU is established and
the instruments can be used.

How to Manually Set a PCIe Direct Connection between an R&S SGS and an R&S SGU
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10  Network and Remote Control Operation
As an alternative to operating the R&S SGS interactively via the R&S SGMA-GUI, one
can also control the R&S SGS using programmed commands from a remote PC.

The description in this section requires basic knowledge of the remote control opera-
tion. Definitions specified in the SCPI standard are not provided.
Nevertheless, you can find some basic information to the SCPI syntax, command lists,
and general programming recommendations in Chapter A, "Remote Control Basics",
on page 291. In addition, this chapter provides information on the status reporting sys-
tem of the instrument.

10.1  Remote Control Interfaces and Protocols

The instrument supports several interfaces for remote control. The following table gives
an overview.

Table 10-1: Remote control interfaces and protocols

Interface Protocols, VISA*) address string and Library Remarks

Local Area
Network
(LAN)

● HiSLIP High-Speed LAN Instrument Protocol
(IVI-6.1)
TCPIP::host address::hislip0[::
INSTR]

● VXI-11
TCPIP::host address::inst0[::INSTR]
Library: VISA

● socket communication (Raw Ethernet, simple
Telnet)
TCPIP::host address[::
LAN device name]::<port>::SOCKET
Library: VISA or socket controller

A LAN connector is located on the
rear panel of the instrument.

The interface is based on TCP/IP and
supports various protocols.

For details, see Chapter 10.1.2, "LAN
Interface", on page 165

USB USBTMC
USB::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: VISA

A USB connector is located on the
rear panel of the instrument.

For details, see Chapter 10.1.3, "USB
Interface", on page 168

PCIe Proprietary
PCIe::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: pcie controller

A PCIe connector is located on the
rear panel of the instrument.

For details, see Chapter 10.1.4, "PCI
Express Interface", on page 169

GPIB (IEC/
IEEE Bus
Interface)

–
● GPIB::<address>[::INSTR] (no secondary

address)
VISA

The instrument is not equipped with
GPIB bus interfaces. Use a GPIB-to-
LAN or GPIB-to-USB adapter instead.

For details, see Chapter 10.1.5,
"GPIB Interface (IEC/IEEE Bus Inter-
face)", on page 170

*) VISA is a standardized software interface library providing input and output functions
to communicate with instruments. A VISA installation on the controller is a prerequisite

Remote Control Interfaces and Protocols



Network and Remote Control OperationR&S®SGS100A

163User Manual 1173.9105.02 ─ 12

for remote control over LAN (when using VXI-11 or HiSLIP protocol) or USB. However,
no VISA installation is necessary for remote control while using socket communication.
For more information about VISA, refer to the user documentation.

Rohde & Schwarz provides the standardized I/O software library R&S VISA for com-
munication via TCP/IP (LAN: HiSLIP, VXI-11 and raw socket) or USB (USBTMC) inter-
faces.
R&S VISA is available for download at the Rohde & Schwarz website http://
www.rohde-schwarz.com/rsvisa.

SCPI (Standard Commands for Programmable Instruments)

SCPI commands are used for remote control. Commands that are not taken from the
SCPI standard follow the SCPI syntax rules. The instrument supports the SCPI version
1999. The SCPI standard is based on standard IEEE 488.2 and aims at the standardi-
zation of device-specific commands, error handling and the status registers. The tuto-
rial "Automatic Measurement Control - A tutorial on SCPI and IEEE 488.2" from John
M. Pieper (R&S order number 0002.3536.00) offers detailed information on concepts
and definitions of SCPI.

10.1.1  Remote Control Programs and Libraries

The Figure 10-1 provides a schematic illustration of the remote control capabilities of
the instrument.

Figure 10-1: Remote control interfaces, protocols and libraries

The following examples give an overview of the dependencies between the available
libraries, the possible interfaces and protocols, and whether an instrument driver is pro-
vided. The involved parts are highlighted.
● Remote control program using VISA
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Figure 10-2: Remote control program using VISA

Protocol Remote control program

Socket viOpen (..., "TCPIP:rssgs100a100010::5025::SOCKET", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

VXI-11 viOpen (..., "TCPIP:rssgs100a100010::inst0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

HiSLIP viOpen (..., "TCPIP:rssgs100a100010::hislip0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

USBTMC viOpen (..., "USB::0x0aad::0x0088::1000010::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

● Remote control program using instrument driver (VISA available)

Figure 10-3: Remote control program using instrument driver (VISA available)
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Network and Remote Control OperationR&S®SGS100A

165User Manual 1173.9105.02 ─ 12

Protocol Remote control program

Socket rssgs_init ("TCPIP:rssgs100a100010::5025::SOCKET", ...)
rssgs_SetFrequency (..., 2e9)

VXI-11 rssgs_init ("TCPIP:rssgs100a100010::inst0::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

HiSLIP rssgs_init ("TCPIP:rssgs100a100010::hislip0::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

USBTMC rssgs_init ("USB::0x0aad::0x0088::1000010::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

PCIe rssgs_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

● Remote control program using instrument driver (VISA not available)

Figure 10-4: Remote control program using instrument driver (VISA not available)

Protocol Remote control program

Socket rssgs_init ("TCPIP:rssgs100a100010::5025::SOCKET", ...)
rssgs_SetFrequency (..., 2e9)

PCIe rssgs_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

10.1.2  LAN Interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, consisting
of a connector, a network interface card and protocols.

For remote control via a network, the PC and the instrument must be connected via the
LAN interface to a common network with TCP/IP network protocol. They are connected
using a RJ45 cable (shielded or unshielded twisted-pair category 5). The TCP/IP net-
work protocol and the associated network services are preconfigured on the instru-

Remote Control Interfaces and Protocols



Network and Remote Control OperationR&S®SGS100A

166User Manual 1173.9105.02 ─ 12

ment. Software for instrument control and (for specified protocols only) the VISA pro-
gram library must be installed on the controller.

Identifying instruments in a network
If several instruments are connected to the network, each instrument has its own IP
address and associated resource string. The controller identifies these instruments by
the resource string.

10.1.2.1  VISA Resource Strings

The VISA resource string is required to establish a communication session between
the controller and the instrument in a LAN. The resource string is a unique identifier,
composed of the specific IP address of the instrument and some network and VISA-
specific keywords.

TCPIP::host address[::LAN device name][::INSTR]
● TCPIP designates the network protocol used
● host address is the IP address or host name of the device

See also Chapter 6.4.3, "Finding Out the Default Hostname of the Instrument",
on page 71.

● [::LAN device name] defines the protocol and the instance number of a subinstru-
ment:

● [::INSTR] indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to identify and
control the instrument. It is automatically assigned by the DHCP server the first time
the device is registered on the network. Alternatively, you can also assign its LAN
device name.

You can find the IP address in the "SGMA-GUI > Instrument Name > Setup > Remote"
dialog, and also adjust it manually, if necessary.

See below the characteristics of the VISA resource strings for the corresponding inter-
face protocols. The highlighted characters are crucial.

HiSLIP

TCPIP::host address::hislip0[::INSTR]
● hislip0 HiSLIP device name, designates that the interface protocol HiSLIP is used

(mandatory).

hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be assigned.

For details of the HiSLIP protocol, refer to Chapter 10.1.2.2, "HiSLIP Protocol",
on page 167.

VXI-11

TCPIP::host address[::inst0][::INSTR]
● [::inst0] LAN device name, indicates that the VXI-11 protocol is used (optional).
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inst0 currently selects the VXI-11 protocol by default and can be omitted.

For details of the VXI-11 protocol, refer to .Chapter 10.1.2.3, "VXI-11 Protocol",
on page 168

Socket communication

TCPIP::host address::port::SOCKET
● port determines the used port number
● SOCKET indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred to as
port number) and of "SOCKET" to complete the VISA resource string with the associ-
ated protocol used.

The registered port for socket communication is port 5025.

See also Chapter 10.1.2.4, "Socket Communication", on page 168.

Example: 
● Instrument has the IP address 10.113.11.91; the valid resource string using VXI-11

protocol is:
TCPIP::10.113.11.91::INSTR

● The DNS host name is rssgs100a100021; the valid resource string is:
TCPIP::rssgs100a100021::hislip0 (HiSLIP)
TCPIP::rssgs100a100021::inst0 (VXI-11)

● A raw socket connection can be established using:
TCPIP::10.113.11.91::5025::SOCKET

10.1.2.2  HiSLIP Protocol

The HiSLIP (High Speed LAN Instrument Protocol) is the successor protocol for
VXI-11 for TCP-based instruments specified by the IVI foundation. The protocol uses
two TCP sockets for a single connection - one for fast data transfer, the other for non-
sequential control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

● High performance as with raw socket network connections
● Compatible IEEE 488.2 support for Message Exchange Protocol, Device Clear,

Serial Poll, Remote/Local, Trigger, and Service Request
● Uses a single IANA registered port (4880), which simplifies the configuration of fire-

walls
● Supports simultaneous access of multiple users by providing versatile locking

mechanisms
● Usable for IPv6 or IPv4 networks
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Using VXI-11, each operation is blocked until a VXI-11 device handshake returns. How-
ever, using HiSLIP, data is sent to the device using the "fire and forget" method with
immediate return. Thus, a successful return of a VISA operation such as viWrite()
does not guarantee that the instrument has finished or started the requested com-
mand, but is delivered to the TCP/IP buffers.

For more information see also the application note:

1MA208: Fast Remote Instrument Control with HiSLIP

10.1.2.3  VXI-11 Protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing Remote
Procedure Call) protocol which in turn relies on TCP/IP as the network/transport layer.
The TCP/IP network protocol and the associated network services are preconfigured.
TCP/IP ensures connection-oriented communication, where the order of the
exchanged messages is adhered to and interrupted links are identified. With this proto-
col, messages cannot be lost.

10.1.2.4  Socket Communication

An alternative way for remote control of the software is to establish a simple network
communication using sockets. The socket communication, also referred to as “Raw
Ethernet communication”, does not require a VISA installation on the remote controller
side.

The simplest way to establish socket communication is to use the built-in telnet pro-
gram. The telnet program is part of every operating system and supports communica-
tion with the software on a command-by-command basis.

Socket connections are established on a specially defined port. The socket address is
a combination of the IP address or the host name of the instrument and the number of
the port configured for remote-control. All instruments use port number 5025 for this
purpose. The port is configured for communication on a command-to-command basis
and for remote control from a program running on a connected PC.

10.1.3  USB Interface

For remote control via USB connection, the PC and the instrument must be connected
via the USB interface. A USB connection requires the VISA library to be installed. VISA
detects and configures the R&S instrument automatically when the USB connection is
established. You do not have to install a separate driver.

USB resource string

The syntax of the used USB resource string is:
USB::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● USB denotes the used interface

Remote Control Interfaces and Protocols
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● <vendor ID> is the manufacturer ID for Rohde&Schwarz
● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the USB resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
USB::0x0AAD::0x0088::100021::INSTR
0x0AAD is the vendor ID for Rohde&Schwarz
0x0088 is the product ID for the R&S SGS
100021 is the serial number of the particular instrument

10.1.4  PCI Express Interface

A PCI Express (PCIe) connector is provided on the rear panel of the instrument.

Refer to Chapter 10.3, "Advanced Remote Control Using PCIe", on page 172 for a
description of how to set up a remote control connection via PCIe and the permitted
cables.

Via PCI Express some commands can be sent to the instrument with optimized speed
(memory-mapped remote control), e.g. frequency or level settings. This allows mini-
mum setup time.

PCIe resource string

The syntax of the used PCIe resource string is:
PCIe::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● PCIe denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde&Schwarz
● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the PCIe resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
PCIe::0x162f::0x132e::100021::INSTR
0x162f is the vendor ID for Rohde&Schwarz
0x132e is the product ID for the R&S SGS
100021 is the serial number of the particular instrument

Remote Control Interfaces and Protocols
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10.1.5  GPIB Interface (IEC/IEEE Bus Interface)

The R&S SGS is not equipped with an IEC/IEEE bus interface.

To be able to control the instrument via the GPIB bus:

1. Connect a GPIB-to-LAN or a GPIB-to-USB adapter to the instrument.

2. Use a GPIB bus cable to connect the instrument and the controller.

3. Provide the GPIB bus card, the card drivers and the program libraries for the pro-
gramming language in the controller.

4. In the "SGMA-GUI > Setup > Instruments > instrument name > Remote Control",
set the "GPIB Address".
See "GPIB Address" on page 59.

5. If the controller is equipped with several GPIB bus cards, define the used "Board
Number".

GPIB address

The controller must address the instrument with the GPIB bus channel. GPIB provides
channel addresses from 0 to 30.

The GPIB resource string is GPIB::<address>[::INSTR], where:
● GPIB denotes the used interface
● <address> indicates the used channel
● [::INSTR] indicates the instrument resource class (optional)

Note: If the VISA implementation supports the GPIB interface, you can optionally
define the VISA instrument control resource (INSTR). It is used to define the basic
operations and attributes for a device, such as reading, writing, or triggering.

Any connected IEC bus cable must be terminated by an instrument or controller.

10.2  Starting a Remote Control Session

The instrument and the controller have to be connected with a suitable cable and
switched on.

A remote control program must open a connection to the instrument, before it can send
commands to and receive device responses from the instrument.

Starting a Remote Control Session
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Instrument address
To operate the instrument via remote control, it must be addressed using the defined
interface address.
See Chapter 10.1.2, "LAN Interface", on page 165, Chapter 10.1.3, "USB Interface",
on page 168 or Chapter 10.1.4, "PCI Express Interface", on page 169 for details.

The VISA resource strings are indicated in the "SGMA-GUI main panel > Instrument
name > Setup > Remote Channels" dialog.

10.2.1  How to Find the VISA Resource String

To find the VISA resource strings of your instrument:

► Select "SGMA-GUI main panel > Instrument name > Setup > Remote Channels".

The "Remote Channel Settings" dialog shows all specified resource strings of the
supported remote control interfaces.

10.2.2  Example: Remote Control over LAN Using Socket Communication

This section provides an example on how to establish a remote control connection over
telnet protocol and a simple sockets-based program example that can be further devel-
oped (see also Chapter B, "Telnet program examples", on page 312).

Basic knowledge of programming and operation of the controller are assumed. A
description of the interface commands can be obtained from the relevant manuals.

Refer to the getting started manual for an example on how to set up remote control
connection over LAN using VXI-11 protocol.
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To set up a Telnet connection

To control the software, only a telnet program is required. The telnet program is part of
every operating system.

1. To establish a Telnet connection with the R&S SGS, start the telnet program. Enter
the socket address.
The socket address is a combination of the IP address or the host name of the
R&S SGS and the number of the port configured for remote-control via telnet.
Tip: The R&S SGS uses the port number 5025 for remote connection via Telnet.

The connection to the instrument is set up and remote-control commands can be
sent.

2. Even if the cursor is not visible on the screen, enter blind a remote-control com-
mand and confirm with Enter.

10.3  Advanced Remote Control Using PCIe

The PCIe bus is a high-speed serial bus, composed of point-to-point serial links. A pair
of serial links, one transmitting and one receiving link, make up a lane.

Advanced Remote Control Using PCIe
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Fast settings

The PCIe interface can be utilized not only to transfer text messages e.g. SCPI com-
mands but also to carry register based remote control messages. The latter mode is
called fast settings mode. The specially for this purpose provided instrument's driver is
mandatory for the instrument control with fast settings. This instrument driver contains
special functions for fast setup.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● Using the PCIe interface is mandatory (see also Chapter 10.3.1, "Setting Up a

Remote Control Connection via PCIe", on page 173)
● The fast settings must be enabled with the function rssgs_useFastSettings

(see also Chapter 10.3.5, "Enabling Fast Settings", on page 177).

The instrument driver automatically uses the fast settings method whenever possible -
currently only for the parameters frequency, level, RF state, modulator state - and
sends SCPI messages in all other cases.

Remote control programs written for PCIe will, without modifications, also run if one of
the other control channels, LAN or USB is used.

10.3.1  Setting Up a Remote Control Connection via PCIe

To set up a remote control connection vie PCIe, perform the following steps:

1. Download the drivers, see 10.3.2.

2. Configure the controller, see 10.3.3

3. Connect the controller and the instrument, see 10.3.4

4. Enable fast settings, see 10.3.5.

10.3.2  Download the Drivers

All required driver files are available for download on the product page at:

http://www.rohde-schwarz.com/product/SGS100A.html  > "Downloads" > "Drivers"

Provided are the following files:
● LabWindows/CVI, Linux/OSX driver rssgs (InstrumentDriver)

C source code files which provide a functional application programming interface
(API) to R&S SGS instruments. Required if you want to control an instrument via
PCIe.

● Low-Level SGS drivers
Archive file that contains the following:
– KernelDriver

Advanced Remote Control Using PCIe
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C source code files from which you can build a Linux kernel mode driver for the
R&S SGS PCIe remote control interface.

– SgsDriverDemo
C source code module for a demo program using the instrument driver API.

– SharedLibraries-Dlls
Shared libraries (Dlls) for remote control channels Socket and PCIe. To be
used with the instrument driver.

● VXIplug&play x64/x86 driver rssgs
Download the required archive and extract the files on a remote PC.

10.3.3  Configuring the Controller

This section lists the steps necessary to configure a controller with Linux or Windows
operating system.

10.3.3.1  Building and Installing the Hardware Driver

The hardware driver defines the way to communicate with the instrument via PCIe
interface.

For Windows operating systems, the hardware driver is installed automatically together
with the installation of the R&S SGMA-GUI software.
See also section "Installation of R&S SGMA-GUI Software" in the getting started man-
ual.

For Linux operating system, the source code of the driver is included in the
Low-Level SGS drivers file.

To build and install this driver, root authority is required.

1. Copy folder KernelDriver to your hdd

2. Go to directory host.

3. On the command line, enter make.

The driver sgshost.ko is automatically built.

4. Enter make install.

Device nodes sgsX are created under the folder /dev (X from 0 to 31).
The module sgshost is loaded.

5. Enter lsmod to verify the module.
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10.3.3.2  Making Shared Libraries Accessible

Two library files per operating system are included in SharedLibraries-Dlls file:
● For Linux operating system

libsocketcontroller.so and libpciecontroller.so
● For Windows operating system

SocketController.dll and PCIeController.dll
These libraries act as the dynamic link libraries for programs using the socket or PCIe
interface.

Linux operating system

► To make the libraries accessible, perform one of the following:

a) Append the environment variable LD_LIBRARY_PATH with the path of these
two files e.g. by changing the /etc/environment file.

b) Move these two files to /usr/lib or /lib directory.

Windows operating system

► To make the libraries accessible, perform one of the following:

a) Copy these two files to the folder of your executable.
b) Copy these two files to the WINDOWS\system32 folder.

10.3.3.3  Building a Program

The help file rssgs_vxi.chm shows all functions of the instrument which you can use
in your own remote control program.

An example file is provided ( SgsDriverDemo.c), too.

Building the example program (Linux)

1. Copy folders InstrumentDriver and SgsDriverDemo to your hard disk.

2. Go to folder Build

3. On the command line, enter cmake ..

4. Enter make
Folder Build contains the executable SgsDriverDemo.

Building the example program (Windows)

1. Copy folders InstrumentDriver and SgsDriverDemo to your hard disk.

2. Open SgsDriverDemo.vcproj with Visual Studio.

3. Build the program.
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Running the example program

► On the command line, enter ./SgsDriverDemo RESOURCESTRING [cmd].

Where
● RESOURCESTRING is the (VISA) resource string of your instrument, e.g.

TCPIP::ipaddress::5025::SOCKET or PCIE::0x162f::
0x132e::serialno::INSTR.
Where ipaddress is the IP address or hostname of your instrument and
serialno is its serial number.

● cmd is an optional command (see table).

The following table list the available commands.

Command Description

? Usage

q Quit

f value Set frequency

f? Query frequency

l value Set level

l? Query level

r value Set RF state (value = 0 | 1 | ON | OFF)

r? Query RF state

If you enter an additional optional command, SgsDriverDemo executes it and
enters a loop waiting for further commands.

Example: 
TCPIP::10.111.11.44::5025::SOCKET ?
Lists the available commands.

10.3.4  Connecting the Controller and the Instrument

A PCIe connector is provided on the rear panel of the instrument.

Risk of device failure
The R&S SGS is equipped with a single lane PCIe interface that supports hot plugging.
Do not connect an external PC to the PCIe connector of the instrument during opera-
tion if this external PC does not support hot-plugging!
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Permitted PCIe cables
PCIe extension cables must fulfill the following requirements:
● Single lane connectors
● Max. cable length of 5 m.

For example: OSS-PCIe-CBL-x1 cable from One Stop Systems or 74576-000x cable
from Molex.

Connecting an external PC that does not support hot-plugging

1. Switch off the external PC and the instrument.
See also Chapter 2.1.5, "Switching the Instrument On and Off", on page 19.

2. Connect the instrument and the controller with the suitable cable.

3. Switch on the instrument.

4. Wait until the instrument has completed the booting (the "POWER" LED on the
instrument's front panel is constantly on).

5. Switch on the external PC.

10.3.5  Enabling Fast Settings

► To enable the special PCI express feature fast settings, enable the function
rssgs_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.

To disable the fast settings, call the function rssgs_UseFastSettings with argu-
ment fastEnabled=false.

10.4  Advanced Remote Control Using Fast Socket

Fast settings

The socket interface can be utilized not only to transfer text messages e.g. SCPI com-
mands but also to carry register based remote control messages. The latter mode is
called fast settings mode. The fast socket communication is based on the Ethernet pro-
tocol which does not support routing. Therefore a controller PC can only control devi-
ces within its own network segment using the fast socket method.

Advanced Remote Control Using Fast Socket
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To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● On Windows operating systems, the fast socket driver must be installed.
● The application program must be run with root/administrator rights.
● The fast settings must be enabled with the function rssgs_useFastSettings

(see also Chapter 10.3.5, "Enabling Fast Settings", on page 177).

The instrument driver uses the fast settings method whenever possible, currently for
the parameters frequency, level, RF state, I/Q modulator state, IQ wideband state. In
all other cases, SCPI messages are sent.

10.4.1  Setting Up a Remote Control Connection via Fast Socket

Download the required archive and extract the files on a remote PC, as described in
Chapter 10.3.2, "Download the Drivers", on page 173.

Windows operating systems

To set up a remote control connection via fast socket for Windows operating systems,
perform the following steps:

1. Connect the controller and the instrument, see Chapter 2.3.2, "Connecting a
Remote PC via LAN", on page 24.

2. Install the protocol driver to the controller, see Chapter 10.4.2, "Installing the Proto-
col Driver", on page 179.

3. On the controller start the driver by using one of the following:

a) Start the Windows console user interface as an administrator.
Excute the command net start SGMANDISPROT.

b) Use a program for opening the driver.
See for example the example file SgsDriverDemo.c.

4. Start the application with administrator rights.

5. Enable fast settings, see Chapter 10.4.3, "Enabling Fast Settings", on page 179.

Linux operating systems

To set up a remote control connection via fast socket for Linux operating systems, per-
form the following steps:

1. Connect the controller and the instrument, see Chapter 2.3.2, "Connecting a
Remote PC via LAN", on page 24.

2. Start the application as root.

3. Enable fast settings, see Chapter 10.4.3, "Enabling Fast Settings", on page 179.
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10.4.2  Installing the Protocol Driver

The protocol driver defines the way to communicate with the instrument via the LAN
fast socket interface.

For Linux operating system, no special driver is needed.

For Windows operating systems, the SGMANDISPROT driver is required. The protocol
driver is installed automatically together with the installation of the R&S SGMA-GUI
software. It is also provided in the Low-Level SGS drivers file.

To install the driver manually on a Windows operating system:

1. Open "Control Panel > Network and Sharing Center".

2. Select the network adapter on which you want to install the driver and click it.

The "Local Area Connection Status" dialog opens.

3. Click "Properties" to open the "Local Area Connection Properties" dialog.

4. Click "Install" to open the "Select Network Feature Type" dialog.

5. Select "Protocol" and select "Add".

6. In the "Select Network Protocol" dialog, select "Have Disk".
Navigate to the directory where the driver is saved and click "OK" to install the
driver.

10.4.3  Enabling Fast Settings

► To enable the fast settings for the fast socket, call function
rssgs_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.

To disable the fast settings, call the function rssgs_UseFastSettings with argu-
ment fastEnabled=false.

10.5  LXI Configuration

LAN eXtensions for Instrumentation (LXI) is an instrumentation platform for measuring
instruments and test systems that is based on standard Ethernet technology. LXI is
intended to be the LAN-based successor to GPIB, combining the advantages of Ether-
net with the simplicity and familiarity of GPIB.

LXI Configuration
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On the R&S SGS the LXI functionality is already installed and enabled. Thus, the
instrument can be accessed via any web browser (like the Microsoft Internet Explorer)
to perform the following tasks:
● Modifying network configurations
● Remote control of the instrument
● Performing SCPI remote diagnostics

10.5.1  Default State of the Network Settings

According to the LXI standard, an LCI must set the following parameters to a default
state.

Parameter Value

TCP/IP mode DHCP + Auto IP Address

Dynamic DNS Enabled

ICMP ping Enabled

Password for LAN configuration LxiWebIfc

The LAN reset also resets the following parameters for the R&S SGS:

Parameter Value

Hostname <Instrument-specific host name>

Description Signal generator

Negotiation Auto detect

VXI-11 discovery Enabled

The LAN settings are configured using the instrument's LXI Browser Settings.

10.5.2  LXI Browser Settings

To access the instrument via the web browser:

► Type in the instrument's host name or IP address in the address field of the
browser on your PC, for example "http://10.111.0.125".
Note: Do not add the missing zeros in the IP address, while opening the instru-
ment home page.
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The instrument home page (welcome page) opens.

The navigation pane of the browser interface contains the following elements:
● "LXI"

– "Home" opens the instrument home page.
The home page displays the device information required by the LXI stan-
dard, including the VISA resource string in read-only format.

– "Device Indicator" activates or deactivates the LXI status indication.
When activated, the LXI LEDs flash in the browser dialog. A green LXI sta-
tus symbol indicates that a LAN connection has been established; a red
symbol indicates that no LAN cable is connected.

– "Lan Configuration" allows you to configure LAN parameters and to initiate
a ping, see Chapter 10.5.3, "LAN Configuration", on page 181.

– "Status" displays information about the LXI status of the instrument.
– "Utilities" provides access to the LXI event log functionality required by the

LXI standard.
● "Instrument Control"

– "Web Control" opens the R&S SGS Web-GUI for remote access to the
instrument, see Chapter 4.2, "Configuring a CW Signal with the R&S
SGS100A Web-GUI", on page 38.

● "Diagnostics"
– "SCPI Remote Trace" records messages exchanged via the remote control

interface, see Chapter 10.5.3.4, "SCPI Remote Trace", on page 184.
● "Help"

– "Glossary" explains terms related to the LXI standard.
– www.rohde-schwarz.com opens the Rohde & Schwarz home page.

10.5.3  LAN Configuration

The "LAN Configuration" web page displays all mandatory LAN parameters and allows
their modification.

LXI Configuration
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It comprises the following navigation entries.

● IP Configuration.................................................................................................... 182
● Advanced Config...................................................................................................182
● Ping Client.............................................................................................................183
● SCPI Remote Trace.............................................................................................. 184

10.5.3.1  IP Configuration

The "IP configuration" web page displays all mandatory LAN parameters and allows
their modification.

The "IP Address Mode" selects a configuration mode for the IP address of the instru-
ment. With static configuration, the entered IP address, subnet mask, and default gate-
way are used. With dynamic configuration, DHCP or dynamic link local addressing
(automatic IP) are used to obtain the instrument IP address.

Password protection
Changing the LAN configuration is password-protected and requires the security pass-
word. The default password is "instrument".

10.5.3.2  Advanced Config

The "Advanced Config" web page provides LAN settings that are not declared manda-
tory by the LXI standard.
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The following advanced parameters are available:
● "mDNS and DNS-SD": The additional protocols "multicast DNS" and "DNS service

discovery" are used for device communication in zero configuration networks,
working without DNS and DHCP.

● "ICMP Ping": Must be enabled to use the ping utility.
If you disable this setting, the instrument does not answer ping requests. The set-
ting does not affect the LXI ping client. You can ping other hosts from the instru-
ment, even if the setting is disabled.

● "VXI-11 Discovery": Must be enabled to detect the instrument in the LAN.
If you disable this setting, the instrument cannot be detected by the VXI-11 discov-
ery protocol mechanism. The setting does not affect other detection mechanisms.
Setting up a VXI-11 connection via the IP address or the host name is independent
of this setting.

Password protection
Changing the LAN configuration is password-protected and requires the security pass-
word. The default password is "instrument".

10.5.3.3  Ping Client

The "Ping Client" page provides the ping utility to verify the connection between the
LXI-compliant instrument and another device.

The ping is initiated from the instrument. Using the ICMP echo request and echo reply
packets, the function checks whether the communication with a device via LAN is
working. Ping is useful for the diagnosis of IP network or router failures.
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To initiate a ping at the instrument:

1. On the "Ping Client" page, enter the IP address of the host in the "Destination
Address" field (for example 10.111.0.125).

2. Select "Submit".

10.5.3.4  SCPI Remote Trace

The remote trace functionality allows you to trace input and output strings at the
remote control interface of the R&S SGS, see Chapter 10.5.4, "How to Record SCPI
Commands and Messages exchanged via the LXI Web Browser Interface",
on page 186.

A recorded trace (message log) can be evaluated directly in the dialog. Use the high-
lighting and navigation functions provided by the lower toolbar to locate error mes-
sages and messages containing arbitrary search strings. You can also export the mes-
sage log to a *.csv file and evaluate the file using a suitable program.

To trace and display messages, switch on "logging" and "live mode" in the toolbar.
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Toolbars

The toolbar at the top of the dialog provides basic settings and functions.

● "Live mode" / "logging": If logging is switched on, messages are traced. They are
stored in an internal database and can be displayed upon request, using the
refresh button (live mode off) or they can be displayed automatically (live mode
on).

● "Filter": applies a filter to columns and/or rows when working (live mode off)
● "Refresh": reads the message log from the internal database and displays it
● "Download": stores the SCPI trace log to a *.csv file
● "Clear": deletes all message log entries in the database and at the screen
● "Details": displays details of the selected message, for example an SCPI command

in hex format (also possible by double\-clicking a message)

Columns

The following columns are available if no column filter is applied:

● "Rec": record number of the message within the message log
● "MT": indicates the type of the message. Possible values and related message

contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, highlighted by red color
– T = execution time, i.e. time required by the instrument to process the com-

mand internally
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● I: number of the subinstrument
● "message": indicates the type of the message. Possible values and related mes-

sage contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, denoted in red
– T = execution time, i.e. time required by the instrument to process the com-

mand internally

10.5.4  How to Record SCPI Commands and Messages exchanged via the
LXI Web Browser Interface

The remote trace functionality allows you to trace commands and messages
exchanged via a remote control interface of the R&S SGS.

To activate the SCPI remote trace:

1. Start a web browser that supports html5 (W3C compliant).

2. Enter the IP address of the R&S SGS in the browser's address bar.

The R&S SGS's welcome page is displayed.

3. In the navigation pane, select "Diagnostics > SCPI Remote Trace".

4. In the toolbar bar of the "SCPI Remote Trace" page, select "live mode > on" and
"logging > on".

"live mode > on" displays all commands and responses, and "logging > on" also
traces messages.

If you now control the R&S SGS with SCPI commands, using an appropriate tool,
the LXI function records the information sent and received.
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The function records all sent commands, received responses and messages, and
stores them in an internal database. If "live mode" is disabled, you can display the
recent traces upon request, using the "refresh" button. You can also store the log in
a file.

10.6  Using the R&S SGMA-GUI to Monitor the Remote
Control Operation

The R&S SGMA-GUI can be used to monitor the behavior of one or more instruments
while they are remote controlled.

A typical configuration consists of one monitor, controllers and instruments. The moni-
tor is the remote PC on which the R&S SGMA-GUI is installed and the controller is the
remote PC on which the application program runs.

Simultaneous control of an instrument from a controller and a monitor may lead to colli-
sions whenever both the controller and the monitor utilize the same remote channel.
These collisions are indicated by an error message in the "Info" line, e.g. "Query inter-
rupted" or "Resource locked". Simultaneous monitoring and control over the same
remote channel is only possible, if the used protocols support
viLock()/viUnlock() and the remote program use these functions.

The Table 10-2 shows whether a collision-free communication over a particular combi-
nation of remote channels is possible or not and if there are any restrictions.

Using the R&S SGMA-GUI to Monitor the Remote Control Operation



Network and Remote Control OperationR&S®SGS100A

188User Manual 1173.9105.02 ─ 12

Table 10-2: Cross-reference between used remote channels and collision-free communication

Monitor/

Controller

LAN
(VXI-11)

LAN (HiSLIP) USB LAN (Socket) PCIe

LAN (VXI-11) OK* OK OK OK OK

LAN (HiSLIP) OK OK OK OK OK

USB OK OK viLock/viUnlock OK OK

LAN (Socket) OK OK OK X OK

PCIe OK OK OK OK X

Where:
● OK: communication possible, no collisions

*) the R&S SGMA-GUI always uses the LAN device name instr1, see also Chap-
ter 10.1.2.3, "VXI-11 Protocol", on page 168.

● X: communication is not possible without collisions
● viLock/viUnlock: communication is only possible, if the remote control com-

mands are enclosed in a viLock () - viUnlock() pair.

The R&S SGMA-GUI uses the viLock()/viUnlock() functions.

The figure below shows an example of configuration where the monitor and the con-
troller are two different computers, connected to the same instrument over two different
hardware interfaces.

Figure 10-5: Example of a setup for remote control monitoring

Using the R&S SGMA-GUI to Monitor the Remote Control Operation
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Connecting and configuring the monitoring PCs

In the "Setup > Security > Security Settings" dialog, check the state of the LAN and
USB interfaces and enable them if necessary.

1. Connect the monitoring PC to the instrument.

Note: Choose the hardware interface considering the limitations described in
Table 10-2.

2. Configure the instrument in the R&S SGMA-GUI, see Chapter 6.4.2, "Handling
Instruments in the R&S SGMA-GUI", on page 68.

3. In the "SGMA-GUI > Setup > Instruments > Edit Instruments" dialog, disable
"Exclusive Access".

Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.

4. Send remote control commands from the controller to the instrument.

5. Open the corresponding dialogs in the R&S SGMA-GUI. Observe the status of the
parameters.

Using the R&S SGMA-GUI to Monitor the Remote Control Operation
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11  Remote Control Commands
In the following, all remote-control commands will be presented in detail with their
parameters and the ranges of numerical values.

For an introduction to remote control and the status registers, refer to Chapter A,
"Remote Control Basics", on page 291.

Conventions used in SCPI Command Descriptions

Note the following conventions used in the remote command descriptions:
● Command usage

If not specified otherwise, commands can be used both for setting and for querying
parameters.
If a command can be used for setting or querying only, or if it initiates an event, the
usage is stated explicitly.

● Parameter usage
If not specified otherwise, a parameter can be used to set a value and it is the
result of a query.
Parameters required only for setting are indicated as Setting parameters.
Parameters required only to refine a query are indicated as Query parameters.
Parameters that are only returned as the result of a query are indicated as Return
values.

● Conformity
Commands that are taken from the SCPI standard are indicated as SCPI con-
firmed. All commands used by the R&S SGS follow the SCPI syntax rules.

● Asynchronous commands
A command which does not automatically finish executing before the next com-
mand starts executing (overlapping command) is indicated as an Asynchronous
command.

● Reset values (*RST)
Default parameter values that are used directly after resetting the instrument (*RST
command) are indicated as *RST values, if available.

● Factory preset values
Default parameter values that are reset only by factory preset.

● Default unit
The default unit is used for numeric values if no other unit is provided with the
parameter.

● Manual operation
If the result of a remote command can also be achieved in manual operation, a link
to the description is inserted.
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11.1  Programming Examples

This chapter provides simple programming examples for the R&S SGS. The purpose
of the examples is to present all commands for a given task. In real applications, one
would rather reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of most remote control program, an instrument (p)reset is recommen-
ded to set the R&S SGS to a defined state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

It is also recommended that you lock the instrument for remote control from the
selected controller prior to further configuration. Use the LOCK command for this pur-
pose.

We assume that the R&S SGS is fully equipped with all available options.

11.1.1  Performing General Task for Instrument Setup

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS
// :SYSTem:PRESet
// :RESTart
// :SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Launch selftest, diagnostic and internal adjustments and retrieve results
// ******************************************************************

Programming Examples
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:TEST:ALL:STARt?
:TEST:ALL:RESult?
// Response: RUN
// Call :TEST:ALL:RESult? repeatedly until finished (0 or 1 is returned)

:DIAGnostic:POINt:CATalog?
// Response: D_TEMP_RFB,D_TEMP_CPU,D_TEMP_DBL,...
:DIAGNostic:MEASure:POINt? 'D_TEMP_RFB'

// Calibration functions may take several minutes
// Set timeout values of controller accordingly

:CALibration:ALL:MEASure?
// starts the adjustment of all functions for the entire instrument
// Response: 0 / 1
// i.e. adjustment has been performed successfully / adjustment failed
:CALibration:FREQuency:MEASure?
// starts the adjustment of frequency and level
:CALibration:LEVel:MEASure?
// starts adjustments for maximum level accuracy

// Options R&S SGS-B106V or R&S SGS-B112V required for modulator functions
:CALibration:IQModulator:FULL?
:CALibration:IQModulator:LOCal

// ******************************************************************
// Query the entries in the error queue
// ******************************************************************

:SYSTem:SERRor?
// Query static errors
// :SYSTem:ERRor:CODE:COUNT?
// :SYSTem:ERRor:CODE:NEXT?
// :SYSTem:ERRor:NEXT?
// :STATus:QUEue:NEXT?
// :SYSTem:ERRor:CODE:ALL?
:SYSTem:ERRor:ALL?
// Query error queue

// ******************************************************************
// Query system information
// ******************************************************************

SYSTem:VERSion?

// ******************************************************************
// Activate eco mode
// ******************************************************************

Programming Examples



Remote Control CommandsR&S®SGS100A

193User Manual 1173.9105.02 ─ 12

:SYSTem:EMODe EM1

// ******************************************************************
// Query the installed common assemblies and HW options 
// ******************************************************************

:SYSTem:SOFTware:OPTion1:NAME?
:SYSTem:SOFTware:OPTion1:DESignation?
:SYSTem:SOFTware:OPTion1:LICenses?
:SYSTem:SOFTware:OPTion1:EXPiration?

:SYSTem:HARDware:ASSembly1:NAME?
:SYSTem:HARDware:ASSembly1:PNUMber?
:SYSTem:HARDware:ASSembly1:SNUMber?
:SYSTem:HARDware:ASSembly1:REVision?

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 72349234

11.1.2  Generating an I/Q Modulated Signal

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established. An external analog signal is provided at the I and Q connectors of the
instrument.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Select normal operation mode
// ******************************************************************

Programming Examples
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:SOURce:OPMode NORMal

// ******************************************************************
// Set RF frequency and level 
// ******************************************************************

:SOURce:FREQuency:CW 2 GHz
// :SOURce:PHASe 0
// :SOURce:PHASe:REFerence
:SOURce:POWer -10dBm
:SOURce:POWer:PEP?

// ******************************************************************
// Enable internal reference frequency source 
// ******************************************************************

:SOURce:ROSCillator:SOURce INTernal

// ******************************************************************
// Enable internal LO source 
// ******************************************************************

:SOURce:LOSCillator:SOURce INT

// ******************************************************************
// Define and enable impairments
// Enable modulation
// ******************************************************************

:SOURce:IQ:IMPairment:LEAKage:I -1
:SOURce:IQ:IMPairment:LEAKage:Q 1
:SOURce:IQ:IMPairment:IQRatio:MAGNitude 1
// Sets the gain imbalance to 1 %
:SOURce:IQ:IMPairment:IQRatio:MAGNitude?
// Response: 0.087 dB
:SOURce:IQ:IMPairment:QUADrature:ANGLe 2
:SOURce:IQ:WBSTate ON
:SOURce:IQ:CREStfactor 0.05

:SOURce:IQ:IMPairment:STATe ON
:SOURce:IQ:STATe ON

// ******************************************************************
// Enable output of the generated signal at the RF connector
// ******************************************************************

:OUTPut:STATe ON

// ******************************************************************

Programming Examples
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// Unlock the instrument
// ******************************************************************

:UNL 72349234

11.1.3  Adjusting Network and Remote Channel Settings

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Query the VISA resource strings
// ******************************************************************

:SYSTem:COMMunicate:NETWork:RESource?
// Response: TCPIP::10.113.11.91::INSTR
:SYSTem:COMMunicate:SOCKet:RESource?
// Response: TCPIP:rssgs100a100021::5025::SOCKET
:SYSTem:COMMunicate:USB:RESource?
// Response: USB::0x0AAD::0x0088::100021::INSTR
:SYSTem:COMMunicate:PCIexpress:RESource?
// Response: PCIe::0x0AAD::4909::100021::INSTR

// ******************************************************************
// Query network settings
// ******************************************************************

:SYSTem:COMMunicate:NETWork:COMMon:HOSTname?
// Response: rssgs100a100021
:SYSTem:COMMunicate:NETWork:IPADdress:MODE?
// Response: AUTO

Programming Examples
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:SYSTem:COMMunicate:NETWork:IPADdress?
// Response: 10.113.11.91
:SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:MASK?
//Response: 255.255.0.0
:SYSTem:COMMunicate:NETWork:IPADdress:GATeway?
//Response: 10.113.0.1

// ******************************************************************
// Changing network settings
// ******************************************************************

:SYSTem:PROTect1:STATe OFF,123456
// :SYSTem:COMMunicate:NETWork:COMMon:HOSTname "mySGS"
// :SYSTem:COMMunicate:NETWork:IPADdress:MODE STATic
// :SYSTem:COMMunicate:NETWork:IPADdress 9.8.7.6
:SYSTem:COMMunicate:NETWork:RESTart

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 72349234

11.1.4  Advanced Task for Optimizing Performance

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS
// :SYSTem:PRESet
// :RESTart
// :SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

Programming Examples
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// ******************************************************************
// Query and adjust the reference oscillator settings
// ******************************************************************

:SOURce:ROSCillator:SOURce?
// Response: EXT
:SOURce:ROSCillator:EXTernal:FREQuency?
// Response: 100MHZ
:SOURce:ROSCillator:EXTernal:SBANdwidth?
//Response: WIDE
:SOURce:ROSCillator:SOURce INTernal
:SOURce:ROSCillator:OUTput:FREQuency 100MHZ
:SOURce:ROSCillator:INTernal:ADJust:STATe OFF
// uses the calibrated adjustment value of the internal ref. frequency
:SOURce:ROSCillator:INTernal:ADJust:VALue?
:CONNector:REFLo:OUTPut?
// Response: REF

// ******************************************************************
// Optimizing the quality characteristics of the RF signal
// ******************************************************************

:SOURce:POWer:LMODe LNO
// optimize the signal to noise ratio
:SOURce:POWer:SCHaracteristic AUTO
// ensure highest dynamic range and fastest setting time
:SOURce:POWer:LEVel:IMMediate:AMPLitude -30dBm
:SOURce:POWer:LIMit:AMPLitude 30dBm
:SOURce:POWer:ALC:SONCe
:OUTPut:STATe:PON UNCHanged

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 72349234

11.1.5  Enabling and Configuring an Extension Mode

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established; the required application program is running on the remote PC. We
assume that at least one R&S SGU is connected to the instrument, directly or over net-
work/switch, i.e. there is a remote control connection between the instrument and the
extension; we assume, that the required signal connections between the instrument
and the extension are established, too.

// ******************************************************************
// Reset instrument first

Programming Examples
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// ******************************************************************

*RST; *CLS
// :SYSTem:PRESet
// :RESTart
// :SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Confirm that there is no extension currently enabled for the instrument 
// Scan the network for available extension instruments and
// query information on the available instruments:
// hostname/IP adress, serial number, used remote channel
// select and enable an extension
// ******************************************************************
:EXTension:SELect?
// 0
// no extension is currently enabled

:EXTension:INSTruments:SCAN:STATe 1
:EXTension:INSTruments:SCAN:STATe?
// 1
// scan process is running
:EXTension:INSTruments:SCAN:STATe?
// 0
// scan finished

:EXTension:INSTruments:REMote:LAN:NAME?
// rssgu100a100002,rssgu100a101010
:EXTension:INSTruments:REMote:CHANnel?
// LAN,LAN
:EXTension:INSTruments:REMote:SERial?
// 100002,101010
// there are two available extensions

// select and enalbe the first extension (rssgu100a100002)
:EXTension:SELect 1
// determines the extension
// all further remote control commands are related to this extension
:EXTension:REMote:STATe?

Programming Examples
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// 1
:EXTension:BUSY:STATe?
// 0
// extension is connected and ready for operation

// ******************************************************************
// Send remote commands to the extension to control it
// e.g. activate the RF optput of the extension and subsequently confirm this
// ******************************************************************
:EXTension:SEND ":OUTP:STAT ON"
:EXTension:SEND? ":OUTP:STAT?"
// 1
// the RF ouptput of the extension is active

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 72349234

11.2  Common Commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These
commands have the same effect and are employed in the same way on different devi-
ces. The headers of these commands consist of "*" followed by three letters. Many
common commands are related to the Status Reporting System.

Available common commands:

*CLS.............................................................................................................................200
*ESE.............................................................................................................................200
*ESR?...........................................................................................................................200
*IDN?............................................................................................................................200
*IST?............................................................................................................................ 200
*OPC............................................................................................................................201
*OPT?...........................................................................................................................201
*PRE............................................................................................................................ 201
*PSC............................................................................................................................ 201
*RCL.............................................................................................................................202
*RST.............................................................................................................................202
*SAV.............................................................................................................................202
*SRE............................................................................................................................ 202
*STB?...........................................................................................................................202
*TRG............................................................................................................................ 203
*TST?........................................................................................................................... 203
*WAI.............................................................................................................................203

Common Commands
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*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of
the QUEStionable and the OPERation registers to zero. The command does not
alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only

*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the con-
tents of the event status enable register in decimal form.

Parameters:
<Value> Range: 0 to 255

*ESR?

Event status read

Returns the contents of the event status register in decimal form and then sets the reg-
ister to zero.

Return values: 
<Contents> Range: 0  to  255

Usage: Query only

*IDN?

Identification

Returns the instrument identification.

Return values: 
<ID> "Rohde&Schwarz,<device type>,<part number>/<serial num-

ber>,<firmware version>"

Example: Rohde&Schwarz,SGS100A,
1412.0000K02/000000,3.1.17.1-03.01.158

Usage: Query only

*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit
which is sent during a parallel poll.

Common Commands
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Return values: 
<ISTflag> 0 | 1

Usage: Query only

*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been execu-
ted. This bit can be used to initiate a service request. The query writes a "1" into the
output buffer when all preceding commands have been executed, which is useful for
command synchronization.

*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and
their description, refer to the data sheet.

Return values: 
<Options> The query returns a list of options. The options are returned at

fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only

*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents
of the parallel poll enable register in decimal form.

Parameters:
<Value> Range: 0  to  255

*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when
the instrument is switched on. Thus a service request can be triggered when the instru-
ment is switched on, if the status registers ESE and SRE are suitably configured. The
query reads out the contents of the "power-on-status-clear" flag.

Parameters:
<Action> 0 | 1

0
The contents of the status registers are preserved.

Common Commands
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1
Resets the status registers.

*RCL <Number>

Recall

Loads the instrument settings from an intermediate memory identified by the specified
number. The instrument settings can be stored to this memory using the command
*SAV with the associated number.

It also activates the instrument settings which are stored in a file and loaded using the
MMEMory:LOAD <number>, <file_name.extension> command.

*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the
description of commands.

The command is equivalent to SYSTem:PRESet.

Usage: Setting only

*SAV <Number>

Save

Stores the current instrument settings under the specified number in an intermediate
memory. The settings can be recalled using the command *RCL with the associated
number.

To transfer the stored instrument settings in a file, use the command :MMEMory:
STORe:STATe.

*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command deter-
mines under which conditions a service request is triggered.

Parameters:
<Contents> Contents of the service request enable register in decimal form.

Bit 6 (MSS mask bit) is always 0.
Range: 0  to  255

*STB?

Status byte query

Common Commands
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Reads the contents of the status byte in decimal form.

Usage: Query only

*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual
trigger signal. This common command complements the commands of the TRIGger
subsystem.

Usage: Event

*TST?

Self-test query

Initiates self-tests of the instrument and returns an error code.

Return values: 
<ErrorCode> integer > 0 (in decimal format)

An error occurred.
(For details, see the Service Manual supplied with the instru-
ment).
0
No errors occurred.

Usage: Query only

*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have
been executed and all signals have settled (see also command synchronization and
*OPC).

Usage: Event

11.3  General Commands

:LOCK?.........................................................................................................................203
:UNLock........................................................................................................................204

:LOCK? <LockRequestId>

Sends a lock request ID which uniquely identifies the controller to the instrument.

Parameters:
<LockRequestId> Number

General Commands
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0
test query to prove whether the instrument is locked
Controller ID
request lock from the controller with the specified Controller ID

Return values: 
<Value> Number

0
request refused; the instrument is already locked to other <Lock
Request Id>, i.e. to another controller
1
request granted

Example: :LOCK? 12345
Response: 1
:UNL 12345

Usage: Query only

Manual operation: See "Exclusive Access" on page 58

:UNLock <UnlockId>

Unlocks an instrument locked to a controller with Controller ID = <Unlock Id>.

Setting parameters: 
<UnlockId> Number

Unlock ID which uniquely identifies the controller to the instru-
ment. The value must match the Controller ID <Lock Request
Id> set with the command :LOCK?.

0
Clear lock regardless of locking state

Usage: Setting only

Manual operation: See "Exclusive Access" on page 58

11.4  Preset Commands

The preset commands are not bundled into one subsystem. Therefore, they are listed
separately in this section. In addition, a specific preset command is provided for each
digital standard and for the fader. These specific commands are described in the asso-
ciated subsystems.

The following presetting actions are available:
● Activating the default state of all internal instrument functions (*RST on page 202).

Functions that concern the integration of the instrument into a measurement setup
are not changed, e.g. TCP/IP address or reference oscillator source settings.

Preset Commands
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● Activating the original state of delivery (factory reset, :SYSTem:FPReset
on page 205). Only functions that are protected by a password remain unchanged
as well as the passwords themselves.

:SOURce<hw>:PRESet
:SYSTem:PRESet
Triggers an instrument reset. It has the same effect as:
● The *RST command
● The "SGMA-GUI > Instrument Name > Preset" function

For an overview of the settings affected by the preset function, see Chapter 7.9, "Pre-
set", on page 123.

Example: SYST:PRES
All instrument settings (also the settings that are not currently
active) are reset to their default values.

Usage: Setting only

:SYSTem:FPReset

Triggers an instrument reset to the original state of delivery.

Example: SYST:FPR
all instrument settings (also those that are not currently active)
are reset to the factory values.

Usage: Event

Manual operation: See "Execute Factory Preset" on page 143

11.5  CALibration Subsystem

:CALibration:ALL[:MEASure]?......................................................................................... 205
:CALibration:FREQuency[:MEASure]?..............................................................................206
:CALibration:IQModulator:FULL?..................................................................................... 206
:CALibration:IQModulator:LOCal?....................................................................................206
:CALibration:LEVel[:MEASure]?.......................................................................................206
:CALibration:LEVel:TEMPerature?................................................................................... 207
:CALibration:FREQuency:TEMPerature?..........................................................................207
:CALibration:IQModulator:TEMPerature?..........................................................................207
:CALibration:OEXTension................................................................................................207
:CALibration:ROSCillator:DATA:MODE.............................................................................207
:CALibration:ROSCillator[:DATA]......................................................................................208

:CALibration:ALL[:MEASure]?

Starts all internal adjustments for which no external measuring equipment is needed.

CALibration Subsystem
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Return values: 
<All> 0 | 1 | OFF | ON

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Adjust All" on page 129

:CALibration:FREQuency[:MEASure]?

Performs all adjustments which affect the frequency.

Return values: 
<Synthesis> 0 | 1 | OFF | ON

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Synthesis" on page 129

:CALibration:IQModulator:FULL?

Starts the adjustment of the I/Q modulator for the entire frequency range. The I/Q mod-
ulator is adjusted with respect to carrier leakage, I/Q imbalance and quadrature.

Return values: 
<Modulator> 0 | 1

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "I/Q Modulator" on page 130

:CALibration:IQModulator:LOCal?

Starts the adjustment of the I/Q modulator for the current frequency. The I/Q modulator
is adjusted with respect to carrier leakage, I/Q imbalance and quadrature.

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Adjust I/Q Modulator at Current Frequency" on page 129

:CALibration:LEVel[:MEASure]?

Starts all adjustments which affect the level.

CALibration Subsystem
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Return values: 
<Level> 0 | 1 | OFF | ON

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Level" on page 129

:CALibration:LEVel:TEMPerature?
:CALibration:FREQuency:TEMPerature?
:CALibration:IQModulator:TEMPerature?
Queries the delta temperature since the last performed adjustment.

Return values: 
<Temperature> string

Usage: Query only

Manual operation: See "Delta Temperature" on page 130

:CALibration:OEXTension <OExtension>

This SCPI command is used when the instrument is in extension mode.

Enables you to run an internal adjustment only on the extension instrument.

Parameters:
<OExtension> 0 | 1 | OFF | ON

*RST: 0

Example: :CAL:OEXT ON
activates the mode for calibrating only the extension instrument
:CAL:LEV:MEAS?
calibrates only the extension instrument
:CAL:OEXT OFF
deactivates the mode for calibrating only the extension instru-
ment

:CALibration:ROSCillator:DATA:MODE <Mode>

Defines whether the factory provided or a custom defined calibration value is used to
adjust the reference oscillator.

Parameters:
<Mode> FACTory | CUSTomer

*RST: FACTory

Example: :CALibration1:ROSCillator:DATA:MODE CUSTomer
:CALibration1:ROSCillator:DATA 35600

Manual operation: See "Active Adjustment Data" on page 146
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:CALibration:ROSCillator[:DATA] <Data>

Sets the calibration value for the custom defined external adjustment.

Parameters:
<Data> integer

Range: 0  to  INT_MAX
*RST: 0

Example: See :CALibration:ROSCillator:DATA:MODE on page 207

Manual operation: See "Calibration Value" on page 146

11.6  CONNector Subsystem

:CONNector:REFLo:OUTPut........................................................................................... 208
:CONNector:TRIGger:OMODe.........................................................................................208

:CONNector:REFLo:OUTPut <Output>

Determines the signal provided at the output connector [REF/LO OUT] (rear of the
instrument).

Parameters:
<Output> REF | LO | OFF

*RST: REF

Manual operation: See "REF/LO Output" on page 84

:CONNector:TRIGger:OMODe <Mode>

Sets the operating mode of the trigger connector.

The parameters PVOut|PETRigger|PEMSource are available only with option
R&S SGS-K22.

Parameters:
<Mode> SVALid | SNValid | PVOut | PETRigger | PEMSource

SVALid|SNValid
signal valid /not valid
PVOut
pulse generator video out
PETRigger
pulse generator external trigger
PEMSource
external pulse modulator source

Manual operation: See "Trigger Connector Mode" on page 116
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11.7  DIAGnostic Subsystem

:DIAGnostic:POINt:CATalog?...........................................................................................209
:DIAGnostic[:MEASure]:POINt?.......................................................................................209

:DIAGnostic:POINt:CATalog?

Queries the test points available in the instrument.

For description of the test points, see the service manual.

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

:DIAGnostic[:MEASure]:POINt? <Name>

Triggers voltage or temperature measurement at the specified test point and returns
the measured value.

Use the command :DIAGnostic:POINt:CATalog? to retrieve a list of the available
test points.

For description of the test points, see the service manual.

Query parameters: 
<Name> string

Return values: 
<Value> number

Default unit: V or °C

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

11.8  EXTension Subsystem

:EXTension:REMote:STATe?........................................................................................... 210
:EXTension:INSTruments:NAME?....................................................................................210
:EXTension:INSTruments:SCAN[:STATe].......................................................................... 210
:EXTension:INSTruments:REMote:CHANnel?................................................................... 210
:EXTension:INSTruments:REMote:LAN:NAME?................................................................ 211
:EXTension:INSTruments:REMote:SERial?....................................................................... 211
:EXTension:BUSY[:STATe]?.............................................................................................211
:EXTension:SELect.........................................................................................................212
:TEST:EXTension:CONNection?...................................................................................... 212
:TEST:EXTension:CONNection:RF?.................................................................................212
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:EXTension:REMote:STATe?

Queries the state of the remote control connection to the extension.

Return values: 
<State> 0 | 1 | OFF | ON

1|ON
Connected
0|OFF
Not connected

Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

Usage: Query only

Manual operation: See "Available Instruments" on page 126

:EXTension:INSTruments:NAME?

Queries the list of the symbolic names of the available extension devices.

Usage: Query only

Manual operation: See "Available Instruments" on page 126

:EXTension:INSTruments:SCAN[:STATe] <State>

Starts a scan for the available extension instruments.

Parameters:
<State> 0 | 1 | OFF | ON

1
Starts scan.
0
Aborts scan.
*RST: OFF

Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

Manual operation: See "Available Instruments" on page 126

:EXTension:INSTruments:REMote:CHANnel?

Queries the remote channels of the available extension instruments. Possible interfa-
ces are: LAN, USB, SOCKet, PCIe.
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Parameters:
<Channel> <Channellnstr#1>[,<Channellnstr#2>,...]

Returns a list of the used remote channels of the available
extensions, one interface per instrument. If an extension uses
more than one remote channels, the fastest one is returned.

Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

Usage: Query only

Manual operation: See "Available Instruments" on page 126

:EXTension:INSTruments:REMote:LAN:NAME?

Queries the IP addresses/instrument names of the available extension instruments.

Return values: 
<IPAddress> <IPAdr_Inst#1>[,<IPAdr_Inst#2>,...]

Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

Usage: Query only

Manual operation: See "Available Instruments" on page 126

:EXTension:INSTruments:REMote:SERial?

Queiries the serial numbers of the available extension instruments.

Parameters:
<Serial> <SerialNumberInstr#1>[, <SerialNumberInstr#2>,...]

Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

Usage: Query only

Manual operation: See "Available Instruments" on page 126

:EXTension:BUSY[:STATe]?

Queries the state of the extension instrument.

Return values: 
<State> 0 | 1 | OFF | ON

0
The extension is connected to the master instrument and can be
remotely operated.
1
The extension is busy, i.e. in standby or locked state, or is per-
forming a time consuming operation.
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Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

Usage: Query only

Manual operation: See "Available Instruments" on page 126

:EXTension:SELect <SelNr>

Selects an extension by its index number. The subsequent SCPI commands are rela-
ted to this extension.

Parameters:
<SelNr> float

0
no selection

Example: See Chapter 11.1.5, "Enabling and Configuring an Extension
Mode", on page 197.

:TEST:EXTension:CONNection?

Returns the results of a test to all signal connections between the instrument and the
extension.

Return values: 
<State> 0 | 1 | OFF | ON

0: no error detected
1: error detected

Usage: Query only

Manual operation: See "Test Signal Connections" on page 126

:TEST:EXTension:CONNection:RF?

Returns the results of a test of the RF signal connection to the extension. This query
does not report errors to the SCPI error queue.

You can use this SCPI to detect which extension is physically connected to a device.

Return values: 
<State> 0 | 1 | OFF | ON

0: no error detected
1: error detected

Usage: Query only

Manual operation: See "Test Signal Connections" on page 126
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11.9  MMEMory Subsystem

The MMEMory subsystem (Mass Memory) contains the commands for managing files
and directories as well as for loading and storing complete instrument settings in files.

The files are stored on the internal flash memory of the instrument or on external USB
memory devices.

The default directory is determined using the command MMEMory:CDIR.

Use the command :SYSTem:MMEMory:PATH:USER? to query the path of the direc-
tory for user-defined data.

The /opt directory is a protected and therefore a not accessible system directory. The
files on this directory contain data that must not be changed. Therefore, this directory
should not be accessed, since reconstruction of the system partition will lead to data
loss.

11.9.1  File Naming Conventions

To enable files in different file systems to be used, the following file naming conven-
tions should be observed.

The file name can be of any length and is case-sensitive, meaning it is distinguished
between uppercase and lowercase letters.

The file and the optional file extension are separated by a dot. All letters and numbers
are permitted (numbers are, however, not permitted at the beginning of the file name).
If possible, special characters should not be used. The use of the slashes "\" and "/"
should be avoided since they are used in file paths. A number of names are reserved
for the operating system, e.g. CLOCK$, CON, AUX, COM1...COM4, LPT1...LPT3, NUL
and PRN.

In the R&S SGS all files in which lists and settings are stored are given a characteristic
extension. The extension is separated from the actual file name by a dot (see Chap-
ter 11.9.2, "Extensions for User Files", on page 214 for an overview of the file types).

The two characters "*" and "?" function as "wildcards", meaning they are used for
selecting several files. The "?" character represents exactly one character, while the "*"
character represents all characters up to the end of the file name. "*.*" therefore stands
for all files in a directory.

When used in conjunction with the commands, the parameter <file_name> is speci-
fied as a string parameter with quotation marks. It can contain either the complete path
including the drive, only the path and the file name, or only the file name. The file name
must include the file extension. The same applies for the parameters
<directory_name> and <path>.
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Depending on how much information is provided, either the values specified in the
parameter or the values specified with the command MMEM:CDIR (default directory)
are used for the path and the drive settings in the commands.

Before the instrument settings can be stored in a file, they have to be stored in an inter-
mediate memory using common command *SAV <number>. The specified number is
subsequently used in the :MMEMory:STORe:STATe on page 221 command. Also,
subsequently to loading a file with instrument settings with command :MMEMory:
LOAD:STATe on page 219, these settings have to be activated with the common com-
mand *RCL <number>.

11.9.2  Extensions for User Files

The following table lists all available file extensions for user files.

Table 11-1: Automatically assigned file extensions in the instrument

Function Contents File suffix

R&S SGMA-GUI Save As/Open Software settings *.savrcl

11.9.3  Examples

In these examples, the current instrument setting is stored in the file
test.savrcltxt in the directory /var/sgs/..

Storing and Loading Current Settings

1. Store the current setting in an intermediate memory with the number 4. This setting
can be called using command *RCL and the associated number of the memory, for
example *RCL 4.
*SAV 4

2. To store the settings in a file in a specific directory, specify the complete path.
MMEM:STOR:STAT 4,"/var/sgs/test.savrcltxt"

3. To store the settings in a file in the default drive, set the default drive and specify
only the file name.
MMEM:CDIR '/var/sgs/'*SAV 4
MMEM:STOR:STAT 4,"test.savrcltxt"

4. Load the file test.savrcltxt in the user directory.
MMEM:LOAD:STAT 4,'/var/sgs/test.savrcltxt'

5. Activate the instrument setting of the file test.savrcltxt.
*RCL 4

Working with Files and Directories

1. Read out all files in the specified directory.
MMEM:CAT? 'usbuser'
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Response: 127145265,175325184,"test,DIR,0","temp,DIR,0",
"readme.txt,ASC,1324","state.savrcltxt,STAT,5327",
"waveform.wv,BIN,2342"
the directory usbuser contains the subdirectories test and temp as well as the
files readme.txt, state.savrcltxt and waveform.wv which have different
file types.

Tip: To query only the subdirectories of the current or specified directory, perform:
MMEM:DCAT? 'usbuser'
Response: 'test', 'temp'
To query only the number of subdirectories in the current or specified directory, per-
form:
MMEM:DCAT:LENG? 'usbuser'
Response: 2

2. To query the number of files in the current or specified directory, perform:
MMEM:CAT:LENG? 'usbuser'
Response: 3

3. Create a new subdirectory for mass memory storage in the specified directory.
MMEM:MDIR 'usbnew'

4. Copy the file state to a new file.
MMEM:COPY '/var/sgs/state.savrcltxt','usbnew'

5. Rename the file state.
MMEM:MOVE 'state.savrcltxt','state_new.savrcltxt'

6. Remove the test directory.
MMEM:RDIR 'usbtest'

11.9.4  Remote Control Commands

:MMEMory:CATalog?......................................................................................................216
:MMEMory:CATalog:LENGth?......................................................................................... 216
:MMEMory:CDIRectory...................................................................................................216
:MMEMory:COPY...........................................................................................................217
:MMEMory:DATA............................................................................................................217
:MMEMory:DCATalog?....................................................................................................218
:MMEMory:DCATalog:LENGth?....................................................................................... 218
:MMEMory:DELete.........................................................................................................219
:MEMory:HFRee?.......................................................................................................... 219
:MMEMory:LOAD:STATe.................................................................................................219
:MMEMory:MDIRectory...................................................................................................220
:MMEMory:MOVE.......................................................................................................... 220
:MMEMory:MSIS............................................................................................................220
:MMEMory:RDIRectory...................................................................................................220
:MMEMory:STORe:STATe...............................................................................................221
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:MMEMory:CATalog? <path>

Returns the content of a particular directory.

Query parameters: 
<path> string

String parameter to specify the directory.
If you leave out the path, the command returns the contents of
the directory selected with :MMEMory:CDIRectory.
The path may be relative or absolute.

Return values: 
<UsedDiskSpace> Byte size of all files in the directory.

<FreeDiskSpace> Remaining disk space in bytes.

<FileInfo> <NameFileN>,<SuffixFileN>,<SizeFileN>
List of files, separated by commas
<NameFileN>
Name of the file.
<SuffixFileN>
Type of the file. Possible suffixes are: ASCii, BINary, DIRectory
<SizeFileN>
Size of the file in bytes.

Example: See "Working with Files and Directories" on page 214.

Usage: Query only

:MMEMory:CATalog:LENGth? <Path>

Returns the number of files in the current or in the specified directory.

Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<FileCount> integer

Number of files.

Example: See "Working with Files and Directories" on page 214.

Usage: Query only

:MMEMory:CDIRectory <Directory>

Changes the default directory for mass memory storage. The directory is used for all
subsequent MMEM commands if no path is specified with them.
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Parameters:
<Directory> <directory_name>

String containing the path to another directory. The path can be
relative or absolute.
To change to a higher directory, use two dots '..' .

Example: See "Working with Files and Directories" on page 214.

Usage: SCPI confirmed

:MMEMory:COPY <SourceFile>[,<DestinationFile>]

Copies an existing file to a new file. Instead of just a file, this command can also be
used to copy a complete directory together with all its files.

Setting parameters: 
<SourceFile> string

String containing the path and file name of the source file

<DestinationFile> string
String containing the path and name of the target file. The path
can be relative or absolute.
If <DestinationFile> is not specified, the <SourceFile> is
copied to the current directory, queried with the :MMEMory:
CDIRectory command.
Note: Existing files with the same name in the destination direc-
tory are overwritten without an error message.

Example: See "Working with Files and Directories" on page 214.

Usage: Setting only
SCPI confirmed

:MMEMory:DATA <Filename>, <BinaryBlock>
:MMEMory:DATA? <Filename>

The setting command writes the block data <BinaryBlock> to the file identified by
<Filename>.

Tip: Use this command to read/transfer stored instrument settings or waveforms
directly from/to the instrument.

Parameters:
<BinaryBlock> #<number><length_entry><data>

#: Hash sign; always comes first in the binary block
<number>: the first digit indicates how many digits the subse-
quent length entry has
<length_entry>: indicates the number of subsequent bytes
<data>: binary block data for the specified length.
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For files with a size with more than nine digits (gigabytes), the
instrument allows the syntax #(<Length>), where <Length>
is the file size in decimal format.

Parameters for setting and query: 
<Filename> string

String parameter to specify the name of the file.

Example: MMEMory:DATA '/var/sgs/test.txt',#15hallo
Writes the block data to the file test.txt.
The digit 1 indicates a length entry of one digit; the digit 5 indi-
cate a length of the binary data (hallo) in bytes.
MMEMory:DATA? '/var/sgs/test.txt'
Sends the data of the file test.txt from the instrument to the
controller in the form of a binary block.
Response: #15hallo

Usage: SCPI confirmed

:MMEMory:DCATalog? <path>

Returns the subdirectories of a particular directory.

Query parameters: 
<path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<Catalog> <file_entry>

Names of the subdirectories separated by colons. The first two
strings are related to the parent directory.

Example: See "Working with Files and Directories" on page 214.

Usage: Query only

:MMEMory:DCATalog:LENGth? [<Path>]

Returns the number of subdirectories in the current or specified directory.

Query parameters: 
<Path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the contents of the current directory,
to be queried with :MMEMory:CDIRectory command.

Return values: 
<DirectoryCount> integer

Number of parent and subdirectories.

Example: See "Working with Files and Directories" on page 214.

Usage: Query only
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:MMEMory:DELete <Filename>

Removes a file from the specified directory.

Setting parameters: 
<Filename> string

String parameter to specify the name and directory of the file to
be removed.

Example: See "Working with Files and Directories" on page 214.

Usage: Event
SCPI confirmed

:MEMory:HFRee?

Returns the used and available memory in Kb.

Return values: 
<TotalPhysMemKb> integer

Total physical memory.

<ApplicMemKb> integer
Application memory.

<HeapUsedKb> integer
Used heap memory.

<HeapAvailableKb> integer
Available heap memory.

Usage: Query only

:MMEMory:LOAD:STATe <SavRclStateNumb>, <file_name>

Loads the specified file stored under the specified name in an internal memory.

After the file has been loaded, the instrument setting must be activated using an *RCL
command.

Setting parameters: 
<SavRclStateNumb> Determines to the specific <number> to be used with the *RCL

command, e.g. *RCL 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 214.

Usage: Setting only
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:MMEMory:MDIRectory <Directory>

Creates a subdirectory for mass memory storage in the specified directory. If no direc-
tory is specified, a subdirectory is created in the default directory. This command can
also be used to create a directory tree.

Setting parameters: 
<Directory> string

String parameter to specify the new directory.

Example: See "Working with Files and Directories" on page 214.

Usage: Event

:MMEMory:MOVE <SourceFile>, <DestinationFile>

Moves an existing file to a new location or, if no path is specified, renames an existing
file.

Setting parameters: 
<SourceFile> string

String parameter to specify the name of the file to be moved.

<DestinationFile> string
String parameters to specify the name of the new file.

Example: See "Working with Files and Directories" on page 214.

Usage: Event
SCPI confirmed

:MMEMory:MSIS <Msis>

Defines the drive or network resource (in the case of networks) for instruments with
windows operating system, using msis (MSIS = Mass Storage Identification String).

Note: Instruments with Linux operating system ignore this command, since Linux does
not use drive letter assignment.

Usage: SCPI confirmed

:MMEMory:RDIRectory <Directory>

Removes an existing directory from the mass memory storage system. If no directory
is specified, the subdirectory with the specified name is deleted in the default directory.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Example: See "Working with Files and Directories" on page 214.

Usage: Event
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:MMEMory:STORe:STATe <savrcl_state_nr>, <file_name>

Stores the current instrument setting in the specified file.

The instrument setting must first be stored in an internal memory with the same num-
ber using the common command *SAV.

Setting parameters: 
<savrcl_state_nr> Corresponds to the specific <number> defined with the *SAV

command, e.g. *SAV 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 214.

Usage: Event

11.10  Fast Speed Commands

This section describes special commands that allow a fast frequency and level setting.

:FFASt.......................................................................................................................... 221
:PFASt.......................................................................................................................... 221

:FFASt <Freq>

Special command to set the RF output frequency with minimum latency. No unit (e.g.
Hz) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Freq> float

Example: FFASt 12750000000

:PFASt <Pow>

Special command to set the RF output level with minimum latency at the RF output
connector. This value does not consider a specified offset. No unit (e.g. dBm) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Pow> float

Example: :PFASt -20
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11.11  OUTPut Subsystem

:OUTPut:AFIXed:RANGe:LOWer?...................................................................................222
:OUTPut:AFIXed:RANGe:UPPer?....................................................................................222
:OUTPut:AMODe........................................................................................................... 222
:OUTPut[:STATe]:PON....................................................................................................223
:OUTPut[:STATe]............................................................................................................223

:OUTPut:AFIXed:RANGe:LOWer?

Queries the minimum level which can be set without the attenuator being adjusted
(Attenuator FIXed).

Return values: 
<Lower> float

Default unit: dBm

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Usage: Query only

Manual operation: See "Level Range" on page 91

:OUTPut:AFIXed:RANGe:UPPer?

Queries the maximum level which can be set without the attenuator being adjusted
(Attenuator FIXed).

Return values: 
<Upper> float

Default unit: dBm

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Usage: Query only

Manual operation: See "Level Range" on page 91

:OUTPut:AMODe <AMode>

Switches the mode of the attenuator at the RF output.

Parameters:
<AMode> AUTO | FIXed | APASsive

AUTO
The attenuator is switched automatically. The level settings are
made in the full range.
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APASsive
The attenuator is switched automatically. The level settings are
made only for the passive reference circuits. The high-level
ranges are not available.
FIXed
The level settings are made without switching the attenuator.
When this operating mode is switched on, the attenuator is fixed
to its current position and the resulting variation range is defined.
*RST: AUTO

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Mode" on page 90

:OUTPut[:STATe]:PON <Pon>

Selects the state which the RF output assumes when the instrument is switched on.

Parameters:
<Pon> OFF | UNCHanged

*RST: UNCHanged

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Power-On State" on page 92

:OUTPut[:STATe] <State>

Activates/ deactivates the RF output.

Parameters:
<State> 0 | 1 | OFF | ON

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "RF On/Off" on page 66

11.12  SENSe, READ, INITiate and SLISt Subsystems

These subsystems contain the commands for configuring the power measurements
with R&S NRP power sensor connected to the R&S SGS.

SENSe, READ, INITiate and SLISt Subsystems
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The local state is set with the INIT command. Switching off the local state enhances
the measurement performance. Measurements results can be retrieved in local state
on or off.
Sensor parameters are set with the SENSe commands.

To start the measurement and retrieve the result, use the :READ<ch>[:POWer]?
command.

Suffix Value range Description

SENSe<ch> [1] to 4 Indicates the sensor

Use the :SLISt commands to change the sensor mapping

READ<ch> [1] to 4 Sensor assignment

INIate<hw> [1] to 4 Sensor assignment

ELEMent<ch> [1] to 25 Sensor mapping list

Programming examples

Example: Detecting and assigning a power sensor
SLISt:LIST?
// Response: "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy"
// list of automatically detected sensors

SLISt:SCAN:STATe 1
// searches for sensors connected in the LAN or via the USBTMC protocol

SLISt:LIST?
// Response: 
// "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy",
// "NRP33SN-V-900005-USBTMC","NRP33SN-V-900011-LAN"
// list of automatically detected sensors
// the list can contain more entries

SLISt:ELEMent3:MAPPing SENS1
// maps the third sensor from the list to the first sensor channel

SLISt:SENSor:MAP "NRPS18S-100654-USB Legacy", SENS3
// maps the sensor directly to channel 3

Example: Performing a simple power measurement
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
:INITiate1:CONTinuous ON
//Switches the continous power measurement on 

:READ1?
// Triggers the measurement and displays the results
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Example: Performing a power measurement with a fixed filter
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
SENSe1:SOURce RF 
//Sensor measures the power of the RF signal

SENSe1:FILTer:TYPE NSRatio
//Selects fixed noise filter mode

SENSe1:FILTer:NSRatio 0.02 DB
//Sets the maximum noise component in the result to 0.02 DB

SENSe1:FILTer:NSRatio:MTIMe 10
//Limits the settling time to 10 seconds.

:SENSe1:APERture:DEFault:STATe 0
// Deactivates the default aperture time of the sensor

:SENSe1:APERture:TIMe 10e-6
// Sets the aperture time to 10 us

SENSe1:UNIT DBM
//Selects unit dBm for the measured value

:INITiate:CONTinuous ON
//Switches the continous power measurement on 

:READ?
//Triggers the measurement and displays the results

:SLISt[:LIST]?................................................................................................................ 226
:SLISt:SCAN[:STATe]......................................................................................................226
:SLISt:ELEMent<ch>:MAPPing........................................................................................226
:SLISt:SENSor:MAP.......................................................................................................227
:INITiate<hw>[:POWer]:CONTinuous............................................................................... 227
:READ<ch>[:POWer]?.................................................................................................... 227
:SENSe<ch>:UNIT[:POWer]............................................................................................228
:SENSe<ch>[:POWer]:APERture:DEFault:STATe.............................................................. 228
:SENSe<ch>[:POWer]:APERture:TIMe.............................................................................229
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect.......................................................229
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe........................................................229
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?.........................................................229
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?.................................................................. 230
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER].................................................................. 230
:SENSe<ch>[:POWer]:FILTer:NSRatio............................................................................. 231
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe.................................................................. 231
:SENSe<ch>[:POWer]:FILTer:SONCe.............................................................................. 231
:SENSe<ch>[:POWer]:FILTer:TYPE................................................................................. 232
:SENSe<ch>[:POWer]:FREQuency..................................................................................232
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:SENSe<ch>[:POWer]:LOGGing:STATe............................................................................233
:SENSe<ch>[:POWer]:OFFSet........................................................................................ 233
:SENSe<ch>[:POWer]:OFFSet:STATe..............................................................................233
:SENSe<ch>[:POWer]:SNUMber?................................................................................... 233
:SENSe<ch>[:POWer]:SOURce.......................................................................................234
:SENSe<ch>[:POWer]:STATus[:DEVice]?......................................................................... 234
:SENSe<ch>[:POWer]:SVERsion?...................................................................................234
:SENSe<ch>[:POWer]:TYPE?......................................................................................... 235
:SENSe<ch>[:POWer]:ZERO.......................................................................................... 235

:SLISt[:LIST]?

Returns a list of all detected sensors in a comma-separated string.

Return values: 
<SensorList> String of comma-separated entries

Each entry contains information on the sensor type, serial num-
ber and interface.
The order of the entries does not correspond to the order the
sensors are displayed in the "NRP Sensor Mapping" dialog.

Example: See Example "Detecting and assigning a power sensor"
on page 224.

Usage: Query only

Manual operation: See " Sensor Mapping List " on page 104

:SLISt:SCAN[:STATe] <State>

Starts the search for R&S NRP power sensors, connected in the LAN or via the
USBTMC protocol.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 224.

Manual operation: See " Scan " on page 105

:SLISt:ELEMent<ch>:MAPPing <Mapping>

Assigns an entry from the :SLISt[:LIST]? to one of the four sensor channels.

Parameters:
<Mapping> SENS1 | SENSor1 | SENS2 | SENSor2 | SENS3 | SENSor3 |

SENS4 | SENSor4 | UNMapped
Sensor channel.
*RST: UNMapped
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Example: See Example "Detecting and assigning a power sensor"
on page 224.

Manual operation: See " Sensor Mapping List " on page 104

:SLISt:SENSor:MAP <SensorId>, <Mapping>

Assigns a sensor directly to one of the sensor channels, using the sensor name and
serial number.

To find out the the sensor name and ID, you can get it from the label of the R&S NRP,
or using the command :SLISt:SCAN[:STATe]. This command detects all R&S NRP
power sensors connected in the LAN or via 'USBTMC protocol.

Setting parameters: 
<SensorId> string

<Mapping> enum

Example: See Example "Detecting and assigning a power sensor"
on page 224.

Usage: Setting only

Manual operation: See " Sensor Mapping List " on page 104

:INITiate<hw>[:POWer]:CONTinuous <Continuous>

Switches the local state of the continuous power measurement by R&S NRP power
sensors on and off. Switching off local state enhances the measurement performance
during remote control.

The remote measurement is triggered with :READ<ch>[:POWer]?). This command
also returns the measurement results. The local state is not affected, measurement
results can be retrieved with local state on or off.

Parameters:
<Continuous> 0 | 1 | OFF | ON

*RST: 0

Example: INIT1:CONT ON
Switches local state of continuous power measurement on.

Manual operation: See " State " on page 109

:READ<ch>[:POWer]?

Triggers power measurement and displays the results.

Note: This command does not affect the local state, i.e. you can get results with local
state on or off. For long measurement times, we recommend that you use an SRQ for
command synchronization (MAV bit).

Suffix: 
<ch>

.
1 to 3
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Return values: 
<Power> float or float,float

The sensor returns the result in the unit set with command :
SENSe<ch>:UNIT[:POWer]
Certain power sensors, such as the R&S NRP-Z81, return two
values, first the value of the average level and - separated by a
comma - the peak value.

Example: SENS1:UNIT DBM
// Selects unit dBm for presentation of measurement result
READ1?
// Queries the measurement result of the sensor
// -45.6246576745440230
// -45.6 dBm were measured at the given frequency

Example: R&S NRP-Z81
READ1?
-55.62403263352178,-22.419472478812476
-55.6 dBm is the measured average level, -22. 4 dBm is the measured peak level at the given frequency

Usage: Query only

Manual operation: See " Level (Peak) / Level (Average) " on page 109

:SENSe<ch>:UNIT[:POWer] <Power>

Selects the unit (Watt, dBm or dBμV) of measurement result display, queried with :
READ<ch>[:POWer]?.

Parameters:
<Power> DBM | DBUV | WATT

*RST: DBM

Example: SENS2:UNIT DBM
Selects dBm as unit for the measured value returned by com-
mand READ.
READ2?
Response: 7.34
7.34 dBm are measured by sensor 2.

Manual operation: See " Level (Peak) / Level (Average) " on page 109

:SENSe<ch>[:POWer]:APERture:DEFault:STATe <UseDefAp>

Deactivates the default aperture time of the respective sensor.

To specify a user-defined value, use the command :SENSe<ch>[:POWer]:
APERture:TIMe on page 229.

Parameters:
<UseDefAp> 0 | 1 | OFF | ON

*RST: 1
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Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 225.

Manual operation: See "Default Aperture Time" on page 111

:SENSe<ch>[:POWer]:APERture:TIMe <ApTime>

Defines the aperture time (size of the acquisition interval) for the corresponding sensor.

Parameters:
<ApTime> float

Range: depends on connected power sensor
Increment: 1E-9
*RST: depends on connected power sensor

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 225.

Manual operation: See "Aperture Time" on page 112

:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect <Select>

Several S-parameter tables can be stored in a sensor. The command selects a loaded
data set for S-parameter correction for the corresponding sensor.

Parameters:
<Select> float

*RST: 0

Manual operation: See " S-Parameter " on page 112

:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe <State>

Activates the use of the S-parameter correction data.

Note: If you use power sensors with attenuator, the instrument automatically activates
the use of S-parameter data.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SENSe1:POWer:CORRection:SPDevice:STATe 1
Activates the use of the S-parameters correction data.

Manual operation: See " S-Parameter " on page 112

:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?

Queries the list of the S-parameter data sets that have been loaded to the power sen-
sor.
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Return values: 
<List> string list

*RST: 0

Usage: Query only

Manual operation: See " S-Parameter " on page 112

:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?

Queries the current filter length in filter mode AUTO (:SENSe<ch>[:POWer]:
FILTer:TYPE)

Return values: 
<Auto> float

Range: 1  to  65536

Example: SENS1:FILT:TYPE AUTO
Selects auto filter.
SENS1:FILT:LENG:AUTO?
Queries the automatically set filter length.
Response: 1024

Usage: Query only

Manual operation: See "Filter Length" on page 111

:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] <User>

Selects the filter length for SENS:POW:FILT:TYPE USER. As the filter length works as
a multiplier for the time window, a constant filter length results in a constant measure-
ment time (see also "About the measuring principle, averaging filter, filter length, and
achieving stable results" on page 105).

The R&S NRP power sensors provide different resolutions for setting the filter length,
depending on the used sensor type:
● Resolution = 1 for R&S NRPxx power sensors
● Resolution = 2n for sensors of the R&S NRP-Zxx family, with n = 1 to 16

Parameters:
<User> float

Range: 1  to  65536
*RST: 1

Example: SENS1:FILT:TYPE USER
Selects user filter mode.
SENS1:FILT:LENG 16
Sets a filter length of 16. E.g. using a sensor with 20 ms time
window, the resulting measurement time is 640 ms (2x16x20
ms)

Manual operation: See "Filter Length" on page 111
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:SENSe<ch>[:POWer]:FILTer:NSRatio <NSRatio>

Sets an upper limit for the relative noise content in fixed noise filter mode (:
SENSe<ch>[:POWer]:FILTer:TYPE). This value determines the proportion of intrin-
sic noise in the measurement results.

Parameters:
<NSRatio> float

Range: 0.001  to  1
Increment: 0.001
*RST: 0.01

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 225.

Manual operation: See "Noise Content" on page 111

:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe <MTime>

Sets an upper limit for the settling time of the auto-averaging filter in the NSRatio
mode and thus limits the length of the filter. The filter type is set with command :
SENSe<ch>[:POWer]:FILTer:TYPE.

Parameters:
<MTime> float

Range: 1  to  999.99
Increment: 0.01
*RST: 4

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 225.

Manual operation: See "Timeout" on page 111

:SENSe<ch>[:POWer]:FILTer:SONCe

Starts searching the optimum filter length for the current measurement conditions. You
can check the result with command :SENS1:POW:FILT:LENG:USER? in filter mode
USER (:SENSe<ch>[:POWer]:FILTer:TYPE).

Example: SENS1:FILT:TYPE USER
Selects user filter mode.
SENS1:FILT:SONC
Activates the search for the optimum filter length.
SENS1:FILT:LENG?
Returns the found optimum filter length.
Response: 128

Usage: Event

Manual operation: See "Auto Once" on page 111
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:SENSe<ch>[:POWer]:FILTer:TYPE <Type>

Selects the filter mode. The filter length is the multiplier for the time window and thus
directly affects the measurement time.

Parameters:
<Type> AUTO | USER | NSRatio

AUTO
Automatically selects the filter length, depending on the mea-
sured value. The higher the power, the shorter the filter length,
and vice versa.
USER
Allows you to set the filter length manually. As the filter-length
takes effect as a multiplier of the measurement time, you can
achieve constant measurement times.
NSRatio
Selects the filter length (averaging factor) according to the crite-
rion that the intrinsic noise of the sensor (2 standard deviations)
does not exceed the specified noise content. You can define the
noise content with command :SENSe<ch>[:POWer]:FILTer:
NSRatio.
Note: To avoid long settling times when the power is low, you
can limit the averaging factor limited with the "timeout" parame-
ter (:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe).

*RST: AUTO

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 225.

Manual operation: See " Filter" on page 110

:SENSe<ch>[:POWer]:FREQuency <Frequency>

Sets the RF frequency of the signal, if signal source "USER" is selected (:
SENSe<ch>[:POWer]:SOURce).

Parameters:
<Frequency> float

*RST: 1 GHz

Example: SENS1:SOUR USER
Selects user-defined source.
SENS1:FREQ 2.44GHz
Sets the RF frequency of the source which is 2.44 GHz.

Manual operation: See " Frequency " on page 110
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:SENSe<ch>[:POWer]:LOGGing:STATe <State>

Activates the recording of the power values, measured by a connected R&S NRP
power sensor.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SENS:LOGG:STAT ON
Activates recording of the power measurement of the first sen-
sor.

Manual operation: See "Enable Logging" on page 112

:SENSe<ch>[:POWer]:OFFSet <Offset>

Sets a level offset which is added to the measured level value after activation with
command :SENSe<ch>[:POWer]:OFFSet:STATe. The level offset allows, e.g. to
consider an attenuator in the signal path.

Parameters:
<Offset> float

Range: -100.0  to  100.0
*RST: 0
Default unit: dB

Example: SENS1:POW:OFFS 10.0
Sets a level offset of 10 dB

Manual operation: See " Level Offset State,Level Offset" on page 110

:SENSe<ch>[:POWer]:OFFSet:STATe <State>

Activates the addition of the level offset to the measured value. The level offset value is
set with command :SENSe<ch>[:POWer]:OFFSet.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SENS1:POW:OFFS 0.4dB
Sets a level offset of 0.4 dB
SENS1:POW:OFFS:STAT ON
A level offset of 0.4 dB is added to the measured value.

Manual operation: See " Level Offset State,Level Offset" on page 110

:SENSe<ch>[:POWer]:SNUMber?

Queries the serial number of the sensor.
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Return values: 
<SNumber> string

Example: SENS1:SNUM?
Queries the serial number.

Usage: Query only

Manual operation: See " Sensor type and serial number " on page 109

:SENSe<ch>[:POWer]:SOURce <Source>

Determines the signal to be measured.

Note: When measuring the RF signal, the sensor considers the corresponding correc-
tion factor at that frequency, and uses the level setting of the instrument as reference
level.

Parameters:
<Source> A | USER | RF

*RST: A

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 225.

Manual operation: See " Source" on page 110

:SENSe<ch>[:POWer]:STATus[:DEVice]?

Queries if a sensor is connected to the instrument.

Return values: 
<Status> 0 | 1 | OFF | ON

*RST: 0

Example: SENS1:STAT?
Response: 1
A sensor is connected.

Usage: Query only

Manual operation: See " State " on page 109

:SENSe<ch>[:POWer]:SVERsion?

Queries the software version of the connected R&S NRP power sensor.

Return values: 
<SVersion> string

Example: SENS1:POW:SVER?
Queries the software version of the power sensor.

Usage: Query only
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:SENSe<ch>[:POWer]:TYPE?

Queries the sensor type. The type is automatically detected.

Return values: 
<Type> string

Example: SENS1:TYPE?
Queries the type of sensor.
Response: NRP-Z21
The R&S NRP-Z21 sensor is used.

Usage: Query only

Manual operation: See " Sensor type and serial number " on page 109

:SENSe<ch>[:POWer]:ZERO

Performs zeroing of the sensor.

Zeroing is required after warm-up, i.e. after connecting the sensor.

Note: Switch off or disconnect the RF power source from the sensor before zeroing.

We recommend that you zero in regular intervals (at least once a day), if:
● The temperature has varied more than about 5 °C.
● The sensor has been replaced.
● You want to measure very low power.

Example: SENS1:ZERO
Executes zeroing.

Usage: Event

Manual operation: See " Zero " on page 109

11.13  SOURce Subsystem

[:SOURce]:OPMode....................................................................................................... 235
[:SOURce]:FREQuency[:CW|FIXed].................................................................................236
[:SOURce]:FREQuency:OFFSet......................................................................................236
[:SOURce]:LOSCillator:SOURce......................................................................................236
[:SOURce]:PATH:COUNt?...............................................................................................237

[:SOURce]:OPMode <OpMode>

Sets the operation mode.

Parameters:
<OpMode> NORMal | BBBYpass

NORMal
normal operation
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BBBYpass
Baseband bypass mode
*RST: NORMal

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Operation Mode" on page 80

[:SOURce]:FREQuency[:CW|FIXed] <Cw>

Sets the RF frequency at the RF output connector of the selected instrument.

Note: Enabled frequency offset affects the result of this query. The query returns the
frequency, including frequency offset.

See [:SOURce]:FREQuency:OFFSet on page 236.

Parameters:
<Cw> float

*RST: 1 GHz

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Freq/Freq (Offs)" on page 66

[:SOURce]:FREQuency:OFFSet <Offset>

Sets a frequency offset, for example include the frequency shift of downstream instru-
ment.

Note: Enabled frequency offset affects the result of the query :SOURce:FRE 
Quency:CW?
The query returns the frequency, including frequency offset.

Parameters:
<Offset> float

Range: -3e9  to  3e9
Increment: 0.001
*RST: 0

Example: SOURce:FREQuency:OFFSet 0
SOURce:FREQuency:CW 6000000000
SOURce:FREQuency:OFFSet 20000000
SOURce:FREQuency:CW?
// 6020000000

Manual operation: See "Offset" on page 81

[:SOURce]:LOSCillator:SOURce <Source>

Selects the source of the local oscillator signal.
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Parameters:
<Source> INTernal | EXTernal

INT: use built in oscillator; EXT: use signal at [REF/LO IN] con-
nector

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Source" on page 83

[:SOURce]:PATH:COUNt?

Queries the number of installed RF paths.

Return values: 
<Count> integer

Range: 1  to  INT_MAX
*RST: 1

Example: PATH:COUN?
Queries the number of RF paths.
Response: 1
The instrument is equipped with one RF path.

Usage: Query only

11.14  SOURce:CORRection Subsystem

The output level is corrected in the CORRection subsystem. Correction is performed
by user-defined table values being added to the output level for the respective RF fre-
quency. In the R&S SGS, this subsystem is used to select, transfer and activate user
correction tables.

Each list is stored as a file. The name of the user correction file can be freely selected.
The file extension *.uco is assigned automatically and cannot be changed.

The files can be stored in a freely selectable directory and opened from there. The
default directory is set using command :MMEMory:CDIRectory on page 216. In the
case of files which are stored in the default directory, only the file name has to be
specified in commands. Otherwise, the complete absolute path has to be specified with
every command. The extension can be omitted in any case.

In the following command examples, the files are stored in the default directory.

[:SOURce]:CORRection:CSET:CATalog?..........................................................................238
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency.....................................................238
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency:POINts?........................................239
[:SOURce<hw>]:CORRection:CSET:DATA:POWer............................................................ 239
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[:SOURce<hw>]:CORRection:CSET:DATA:POWer:POINts?...............................................239
[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe.........................240
[:SOURce]:CORRection:CSET:DELete.............................................................................240
[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog?...............................................240
[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension.............................................241
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect..................................................241
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn................................242
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal................................242
[:SOURce<hw>]:CORRection:DEXChange:EXECute.........................................................243
[:SOURce<hw>]:CORRection:DEXChange:MODE............................................................ 243
[:SOURce<hw>]:CORRection:DEXChange:SELect............................................................244
[:SOURce<hw>]:CORRection:CSET[:SELect]................................................................... 244
[:SOURce<hw>]:CORRection[:STATe]..............................................................................245
[:SOURce<hw>]:CORRection:VALue?..............................................................................245
[:SOURce<hw>]:CORRection:ZERoing:STATe.................................................................. 245

[:SOURce]:CORRection:CSET:CATalog?

Requests a list of user correction tables. The individual lists are separated by commas.

The lists are stored with the fixed file extensions *.uco in a directory of the user's
choice. The directory applicable to the commands is defined with the command
MMEMory:CDIR.

Return values: 
<Catalog> string

Example: MMEM:CDIR '/var/sgs/ucor'
selects the directory for the user correction files.
CORR:CSET:CAT?
queries which correction tables are available.
Response:UCOR1,UCOR2,UCOR3
the correction tables UCOR1, UCOR2 and UCOR3 are availa-
ble.

Usage: Query only

[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency <Frequency>

Transfers the frequency data to the table selected with :CORRection:CSET:SELect.

The numerical suffix at SOURce must not be used for this command.

Parameters:
<Frequency> Frequency#1[, Frequency#2, ...]

Range: 300 kHz  to  RFmax (depending on model)

Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR:CSET:DATA:FREQ 100MHz,102MHz,103MHz,...
enters the frequency value in the table ucor1.

Manual operation: See " Edit User Cor. Data " on page 95
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[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency:POINts?

Queries the number of frequency values in the selected table.

The numerical suffix at SOURce must not be used for this command.

Return values: 
<Points> integer

Range: 0  to  10000
*RST: 0

Example: CORR:CSET '/var/sgs/'
selects the table ucor1.
CORR:CSET:DATA:FREQ:POIN?
queries the number of frequency values in the table ucor1.
Response: 440
the table ucor1 contains 440 frequency values.

Usage: Query only

[:SOURce<hw>]:CORRection:CSET:DATA:POWer <Power>

Transfers the level data to the table selected with [:SOURce<hw>]:CORRection:
CSET[:SELect].

*RST does not affect data lists. The numerical suffix at SOURce must not be used for
this command.

Parameters:
<Power> Power#1[, Power#2, ...]

Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR:CSET:DATA:POW 1dB, 0.8dB, 0.75dB,...
enters the level values in the table ucor1.

Manual operation: See " Edit User Cor. Data " on page 95

[:SOURce<hw>]:CORRection:CSET:DATA:POWer:POINts?

Queries the number of level values in the selected table.

The numerical suffix at SOURce must not be used for this command.

Return values: 
<Points> integer

Range: 0  to  10000
*RST: 0
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Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR:CSET:DATA:POW:POIN?
queries the number of level values in the table ucor1.
Response: 440
the table ucor1 contains 440 level values.

Usage: Query only

[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe

The command fills the selected user correction list with the level values measured by
the power sensor for the given frequencies.

To select the used power sensor set the suffix in key word SENSe.

Example: CORR:CSET:DATA:SENS:POW:SONC
fills the user correction list with level values acquired by the
power sensor connector to the [SENSOR] connector.

Usage: Event

Manual operation: See " Fill User Correction Data with Sensor" on page 100

[:SOURce]:CORRection:CSET:DELete <Filename>

Deletes the specified table.

The lists are stored with the fixed file extensions *.uco in a directory of the user's
choice. The directory applicable to the commands is defined with the command
MMEMory:CDIR. A path can also be specified in command SOUR:CORR:CSET:CAT?,
in which case the file in the specified directory is deleted.

Setting parameters: 
<Filename> <table name>

Example: MMEM:CDIR '/var/sgs/ucor'
selects the directory for the user correction files.
CORR:CSET:DEL 'UCOR1'
deletes the table ucor1.

Usage: Setting only

Manual operation: See " User Cor. Data " on page 95

[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog?

Requests a list of available ASCII files for export/import of user correction data. The
individual files are separated by commas.

The ASCII files are stored with the fixed file extensions *.txt or *.csv in a directory
of the user's choice. The directory applicable to the commands is defined with the com-
mand MMEMory:CDIR.
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Return values: 
<Catalog> string

Example: MMEM:CDIR '/var/sgs/import'
selects the directory for the ASCII files with frequency and level
value pairs.
CORR:DEXC:AFIL:EXT TXT
selects that ASCII files with extension *.txt are listed.
CORR:DEXC:AFIL:CAT?
queries the available files with extension *.txt.
Response: 'ucor1,ucor2'
the ASCII files ucor1.txt and ucor2.txt are available.

Usage: Query only

[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension <Extension>

Selects the file extension of the ASCII file to be imported or exported. Selection TXT
(text file) or CSV (Excel file) is available.

Parameters:
<Extension> TXT | CSV

*RST: TXT

Example: MMEM:CDIR '/var/sgs/import'
selects the directory for the ASCII files with frequency and level
value pairs.
CORR:DEXC:AFIL:EXT TXT
selects that ASCII files with extension *.txt are listed.
CORR:DEXC:AFIL:CAT?
queries the available files with extension *.txt.
Response: 'list1,list2'
the ASCII files ucor1.txt and ucor2.txt are available.

Manual operation: See " Extension" on page 97

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect <Filename>

Selects the ASCII file to be imported or exported.

The ASCII files are stored with the fixed file extensions *.txt or *.csv in a directory
of the user's choice. The directory applicable to the commands is defined with the com-
mand MMEMory:CDIR. A path can also be specified in command
SOUR:CORR:DEXC:AFIL:SEL, in which case the files are stored or loaded in the
specified directory.

Parameters:
<Filename> <ascii file name>
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Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.

Manual operation: See " Select ASCII Source/Destination " on page 98

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn <Column>

Selects the separator between the frequency and level column of the ASCII table.

Parameters:
<Column> TABulator | SEMicolon | COMMa | SPACe

*RST: COMMa

Example: CORR:DEXC:MODE EXP
selects that the user correction list is exported into an ASCII file.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects ASCII file ucor.csv as destination for the user correction
list data.
CORR:DEXC:AFIL:SEP:COL TAB
the pairs of frequency and level values are separated by a tabu-
lator.
CORR:DEXC:AFIL:SEP:DEC DOT
selects the decimal separator dot.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the user correction list ucor_imp is imported into
ASCII file ucor.csv.

Manual operation: See " Column Separator" on page 97

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal <Decimal>

Selects the decimal separator used in the ASCII data between '.' (decimal point) and ','
(comma) with floating-point numerals.

Parameters:
<Decimal> DOT | COMMa

*RST: DOT
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Example: CORR:DEXC:MODE EXP
selects that the user correction list is exported into an ASCII file.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects ASCII file ucor.csv as destination for the user correction
list data.
CORR:DEXC:AFIL:SEP:COL TAB
the pairs of frequency and level values are separated by a tabu-
lator.
CORR:DEXC:AFIL:SEP:DEC DOT
selects the decimal separator dot.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the user correction list ucor_imp is imported into
ASCII file ucor.csv.

Manual operation: See " Decimal Point" on page 97

[:SOURce<hw>]:CORRection:DEXChange:EXECute

Starts the export or import of the selected file. When import is selected, the ASCII file is
imported as user correction list. When export is selected, the user correction list is
exported into the selected ASCII file.

Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.
CORR:DEXC:EXEC
starts the import of the ASCII file data into the user correction
file.

Usage: Event

Manual operation: See " Import/Export " on page 98

[:SOURce<hw>]:CORRection:DEXChange:MODE <Mode>

Selects if user correction lists should be imported or exported. Depending on the selec-
tion her, the file select command define either the source or the destination for user
correction lists and ASCII files.

Parameters:
<Mode> IMPort | EXPort

*RST: IMPort
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Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.

Manual operation: See " Mode" on page 97

[:SOURce<hw>]:CORRection:DEXChange:SELect <Filename>

Selects the user correction list to be imported or exported.

The user correction files are stored with the fixed file extensions *.uco in a directory
of the user's choice. The directory applicable to the commands is defined with the com-
mand MMEMory:CDIR. A path can also be specified in command
SOUR:CORR:DEXC:SEL, in which case the files are stored or loaded in the specified
directory.

Parameters:
<Filename> string

Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.

Manual operation: See " Select Destination/Source " on page 98

[:SOURce<hw>]:CORRection:CSET[:SELect] <Filename>

Selects or creates a file for the user correction data.

If the file does not exist, the instrument automatically creates a new file with the name
you assigned. Note the predefined file extensions under Chapter 11.9.2, "Extensions
for User Files", on page 214.

To determine the file location (directory/path) you can either enter it with the command
directly, or use the command MMEMory:CDIR.

To activate level correction use the command [:SOURce<hw>]:CORRection[:
STATe].

Parameters:
<Filename> <table name>
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Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR ON
activates level correction. Correction is performed using the
table ucor1.

Manual operation: See " User Cor. Data " on page 95

[:SOURce<hw>]:CORRection[:STATe] <State>

Activates/deactivates level correction. Level correction is performed using the table
which has been selected with the command [:SOURce<hw>]:CORRection:CSET[:
SELect].

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SOUR:CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
SOUR:CORR ON
activates user correction.

Manual operation: See " State " on page 94

[:SOURce<hw>]:CORRection:VALue?

Queries the current value for user correction.

Return values: 
<Value> float

Range: -100  to  100
Increment: 0.01
*RST: 0

Example: CORR:VAL?
queries the value currently used for level correction.
Response: -3
the correction value is - 3 dB.

Usage: Query only

Manual operation: See " User Correction " on page 94

[:SOURce<hw>]:CORRection:ZERoing:STATe <State>

Activates the zeroing procedure before filling the user correction data acquired by a
sensor.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 1
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Manual operation: See " Fill User Correction Data with Sensor" on page 100

11.15  SOURce:IQ Subsystem

[:SOURce]:IQ:STATe...................................................................................................... 246
[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude]................................................................246
[:SOURce]:IQ:IMPairment:LEAKage:I...............................................................................246
[:SOURce]:IQ:IMPairment:LEAKage:Q.............................................................................246
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe]...............................................................247
[:SOURce]:IQ:IMPairment[:STATe]................................................................................... 247
[:SOURce]:IQ:CREStfactor..............................................................................................247
[:SOURce]:IQ:WBSTate.................................................................................................. 248

[:SOURce]:IQ:STATe <State>

Switches the I/Q modulation on and off.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Mod State" on page 66

[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude] <IqRatio>

Sets the ratio of I modulation to Q modulation (amplification “imbalance”). The input
may be either in dB or %. The resolution is 0.001 dB, an input in percent is rounded to
the closest valid value in dB. A query returns the value in dB.

Parameters:
<IqRatio> float

Range: -1  to  1
Increment: 1E-3
*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Gain Imbalance" on page 122

[:SOURce]:IQ:IMPairment:LEAKage:I <I>
[:SOURce]:IQ:IMPairment:LEAKage:Q <Q>

Sets the carrier leakage amplitude for the I-signal/ Q-signal component.

SOURce:IQ Subsystem



Remote Control CommandsR&S®SGS100A

247User Manual 1173.9105.02 ─ 12

Parameters:
<Q> float

Range: -5  to  5
Increment: 0.01
*RST: 0
Default unit: PCT

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Offset" on page 122

[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] <Angle>

Sets the quadrature offset for the digital I/Q signal.

Parameters:
<Angle> float

Range: -8  to  8
Increment: 0.01
*RST: 0
Default unit: DEG

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Quadrature Offset" on page 123

[:SOURce]:IQ:IMPairment[:STATe] <State>

Activates/ deactivates the three impairment or correction values LEAKage, QUADra-
ture and IQRatio for the baseband signal prior to input into the I/Q modulator.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "State" on page 122

[:SOURce]:IQ:CREStfactor <CrestFactor>

Sets the crest factor of the IQ modulation signal.

Parameters:
<CrestFactor> float

Range: 0  to  80
Increment: 0.01
*RST: 0
Default unit: dB
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Example: see Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193

Manual operation: See "Crest Factor" on page 121

[:SOURce]:IQ:WBSTate <State>

Selects optimized settings for wideband modulation signals.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "I/Q Wideband" on page 121

11.16  SOURce:PHASe Subsystem

[:SOURce]:PHASe......................................................................................................... 248
[:SOURce]:PHASe:REFerence........................................................................................248

[:SOURce]:PHASe <Phase>

Specifies the phase variation relative to the current phase.

Parameters:
<Phase> float

Range: -360  to  360
Increment: 0.1
*RST: 0
Default unit: DEG

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Delta Phase" on page 82

[:SOURce]:PHASe:REFerence

Adopts the phase set with command [:SOURce]:PHASe as the current phase.

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Usage: Event

Manual operation: See "Reset Delta Phase Display" on page 82
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11.17  SOURce:POWer Subsystem

[:SOURce]:POWer:ALC:DSENsitivity............................................................................... 249
[:SOURce]:POWer:ALC[:STATe]...................................................................................... 249
[:SOURce]:POWer:ALC:SONCe...................................................................................... 249
[:SOURce]:POWer:ATTenuation:RFOFf:MODE................................................................. 250
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet]..............................................................250
[:SOURce]:POWer:LMODe............................................................................................. 250
[:SOURce]:POWer:POWer..............................................................................................250
[:SOURce]:POWer:SCHaracteristic..................................................................................251
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude]..........................................................251
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet................................................................ 252
[:SOURce]:POWer:LIMit[:AMPLitude]...............................................................................252
[:SOURce]:POWer:PEP?................................................................................................ 252
[:SOURce]:POWer:RANGe:LOWer?................................................................................ 253
[:SOURce]:POWer:RANGe:UPPer?................................................................................. 253

[:SOURce]:POWer:ALC:DSENsitivity <Sensitivity>

Sets the power detector sensitivity. Used for compatibility reasons only.

Parameters:
<Sensitivity> OFF | LOW | MED | HIGH

*RST: OFF

Manual operation: See "Detector Sensitivity" on page 93

[:SOURce]:POWer:ALC[:STATe] <State>

Activates/deactivates automatic level control.

Parameters:
<State> 1 | OFFTable | OFF | ONTable | AUTO | ON

*RST: ONTable

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "State" on page 93

[:SOURce]:POWer:ALC:SONCe

Briefly activates level control for correction purposes.

Usage: Event

Manual operation: See "Readjust" on page 90
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[:SOURce]:POWer:ATTenuation:RFOFf:MODE <Mode>

Determines the attenuator's state after the instrument is switched on.

Parameters:
<Mode> MAX | FATTenuated | FIXed | UNCHanged

MAX = FATTenuated
Sets attenuation to maximum when the RF signal is switched off.
This setting is recommended for applications that require a high
level of noise suppression.
FIXed = UNCHanged
Retains the current setting and keeps the output impedance
constant during RF off.
*RST: n.a. (factory preset: MAX)

Manual operation: See "RF-Off-Mode" on page 91

[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] <Offset>

Sets the switch-over offset value of the attenuator.

Parameters:
<Offset> float

Range: -10  to  10
Increment: 0.1
*RST: 0

Manual operation: See "SATT Switch-Over Offset" on page 91

[:SOURce]:POWer:LMODe <LevMode>

Selects the level mode.

Parameters:
<LevMode> NORMal | LNOise | LDIStortion

NORM
automatic selection of the best settings
LNOISe
settings for lowest noise
LDIStortion
settings for lowest distortions

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Mode" on page 89

[:SOURce]:POWer:POWer <Amplitude>

Sets the level at the RF output connector.
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This value does not consider a specified offset. The command [:SOURce]:POWer[:
LEVel][:IMMediate][:AMPLitude] sets the level of the "Level" display, that
means the level containing offset.

Parameters:
<Amplitude> float

Range: -20  to  25
Increment: 0.01
*RST: -10

Example: POW:POW 15
sets the RF level at output to 15 dBm.

Manual operation: See "Level/Level Offset" on page 66

[:SOURce]:POWer:SCHaracteristic <Characteristic>

Selects the characteristic for the level setting.

Parameters:
<Characteristic> AUTO | UNINterrupted | CVSWr | USER | MONotone

UNINterrupted
uninterrupted level setting
CVSWr
constant-VSWR
MONotone
strictly monotone
*RST: AUTO

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Setting Characteristic" on page 89

[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] <Amplitude>

Sets the RF level at the RF output connector of the instrument.

Parameters:
<Amplitude> float

Range: -20  to  25
Increment: 0.01
*RST: -10

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Level/Level Offset" on page 66
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[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

Note: The level offset is also effective for level sweeps!

The command specifies the constant level offset of a downstream attenuator/amplifier.
If a level offset is entered, the level entered with [:SOURce]:POWer:POWer no longer
corresponds to the RF output level.

The following correlation applies:

:POWer = RF output level + POWer:OFFSet.

Entering a level offset does not change the RF output level, but rather the query value
of :POWer.

Parameters:
<Offset> float

Range: -100  to  100
Increment: 0.1
*RST: 0

Manual operation: See "Offset" on page 88

[:SOURce]:POWer:LIMit[:AMPLitude] <Amplitude>

Sets the upper limit of the RF signal power.

The value is not affected by an instrument preset and *RST function. This parameter is
influenced only by the factory preset (SYST:FPR) and its factory value is equal to the
upper limit.

Parameters:
<Amplitude> float

Range: -120  to  25
Increment: 0.01
Default unit: dBm

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Limit" on page 90

[:SOURce]:POWer:PEP?

Queries the RF signal's peak envelope power.

Return values: 
<PEP> float

Example: see Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193

Usage: Query only

Manual operation: See "PEP" on page 66
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[:SOURce]:POWer:RANGe:LOWer?
[:SOURce]:POWer:RANGe:UPPer?
Queries the minimum/maximum level range in the current level mode

Return values: 
<Upper> float

Usage: Query only

Manual operation: See "Level Range" on page 89

11.18  SOURce:PULM Subsystem

This subsystem contains the commands for setting the pulse modulation.

Programming Examples

Example: Performing pulse modulation
This example shows a command sequence to perform pulse modulation.

// ******************************************************************
// Reset the instrument to start from an initial state
// ******************************************************************
*RST; *CLS

// ******************************************************************
// Set the RF signal frequency and level
// ******************************************************************
SOURce:FREQuency:CW 4000000000
SOURce:POWer:LEVel:IMMediate:AMPLitude -25

// ******************************************************************
// Configure the pulse modulation settings
// ******************************************************************
// Select the internal modulation generator
SOURce:PULM:SOURce INT
// Set trigger mode
SOURce:PULM:TRIGger:MODE AUTO
// Select pulse mode
SOURce:PULM:MODE DOUB 

// ******************************************************************
// Alternatively configure the pulse modulation settings for 
// external modulation source
// ******************************************************************
// Select the external modulation source
SOURce:PULM:SOURce EXT
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// Set the polarity of the externally applied modulation signal.
SOURce:PULM:POLarity NORMal
// Select the impedance for the external pulse modulation trigger input 
SOURce:PULM:TRIGger:EXTernal:IMPedance G10K

// ******************************************************************
// Configure the pulse generator settings
// ******************************************************************
// Set pulse period
SOURce:PULM:PERiod 10 us
// Set pulse width
SOURce:PULM:WIDth 8 us
// Set double pulse width
SOURce:PULM:DOUBle:WIDTh 0.0000012
// Set double pulse delay
SOURce:PULM:DOUBle:DELay 0.0000045

// ******************************************************************
// Activate the signal output
// ******************************************************************
SOURce:PGENerator:OUTPut:STATe 1
SOURce:PULM:STATe 1
OUTPut1:STATe 1

Example: Generating a pulse train signal
This example shows a command sequence to create a pulse train signal.

Prior to the selection of the pulse train mode make sure that you have generated and
selected a pulse train data list. Otherwise, the instrument generates an error.

// ******************************************************************
// Reset the instrument to start from an initial state
// ******************************************************************
*RST; *CLS

// ******************************************************************
// Set the RF signal frequency and level
// ******************************************************************
SOURce:FREQuency:CW 4000000000
SOURce:POWer:LEVel:IMMediate:AMPLitude -25

// ******************************************************************
// Create a pulse train data list
// ******************************************************************
// Select the directory
MMEM:CDIR '/var/user/Lists/'
// Create and/or select the pulse train data file
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SOURCe:PULM:TRAin:SEL ‘P_FIVE'
// Enter the pulse train data
SOURCe:PULM:TRAin:ONTime 10ns,30ns,40ns,20ns,10ns
SOURCe:PULM:TRAin:OFFTime 30ns,40ns,50ns,40ns,30ns
SOURCe:PULM:TRAin:REPetition 10,1,3,10,6

// ******************************************************************
// Select pulse train mode
// ******************************************************************
// Select the internal modulation generator and the pulse mode
SOURce:PULM:SOURce INTernal
SOURce:PULM:MODE PTRain 

// ******************************************************************
// Activate the signal output
// ******************************************************************
SOURce:PGENerator:OUTPut:STATe 1
SOURce:PULM:STATe 1
OUTPut1:STATe 1

[:SOURce<hw>]:PULM:DELay........................................................................................ 255
[:SOURce<hw>]:PULM:DOUBle:DELay............................................................................256
[:SOURce<hw>]:PULM:DOUBle:WIDTh........................................................................... 256
[:SOURce<hw>]:PULM:MODE........................................................................................ 256
[:SOURce<hw>]:PULM:PERiod....................................................................................... 256
[:SOURce<hw>]:PULM:POLarity..................................................................................... 257
[:SOURce<hw>]:PULM:SOURce..................................................................................... 257
[:SOURce<hw>]:PULM:STATe.........................................................................................257
[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity.................................................258
[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance...................................................... 258
[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe............................................................ 258
[:SOURce<hw>]:PULM:TRIGger:MODE........................................................................... 258
[:SOURce<hw>]:PULM:WIDTh........................................................................................259

[:SOURce<hw>]:PULM:DELay <Delay>

Sets the pulse delay.

Parameters:
<Delay> float

Range: 0  to  100 s
Increment: 10 ns
*RST: 10 ns

Example: PULM:DEL 13 us
13 us elapse after a trigger before the first pulse is generated.

Manual operation: See "Pulse Delay" on page 116
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[:SOURce<hw>]:PULM:DOUBle:DELay <Delay>

Sets the delay from the start of the first pulse to the start of the second pulse.

Parameters:
<Delay> float

Range: 40 ns  to  100 s
Increment: 10 ns
*RST: 1 ns

Example: PULM:DOUB:DEL 22 us
22 us elapse between the beginning of the first pulse and the
beginning of the second pulse in double-pulse mode.

Manual operation: See "Double Pulse Delay" on page 116

[:SOURce<hw>]:PULM:DOUBle:WIDTh <Width>

Sets the width of the second pulse in case of double pulse generation.

Example: PULM:DOUB:WIDT 33 us
sets a width of 33 us for the second pulse.

Manual operation: See "Double Pulse Width" on page 115

[:SOURce<hw>]:PULM:MODE <Mode>

Sets the mode of the pulse generator.

Parameters:
<Mode> SINGle | DOUBle

SINGle
Enables single pulse generation.
DOUBle
Enables double pulse generation. The two pulses are generated
in one pulse period.
*RST: SINGle

Example: PULM:MODE DOUB
enables double pulse generation.

Manual operation: See "Pulse Mode" on page 115

[:SOURce<hw>]:PULM:PERiod <Period>

Sets the period of the generated pulse. The period determines the repetition frequency
of the internal signal.

Example: PULM:PER 220 us
the pulse period is 220 us.

Manual operation: See "Pulse Period" on page 115
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[:SOURce<hw>]:PULM:POLarity <Polarity>

Sets the polarity of the pulse modulator signal. This command is effective only for an
external modulation signal.

Parameters:
<Polarity> NORMal | INVerted

NORMal
The RF signal is suppressed during the pulse pause.
INVerted
The RF signal is suppressed during the pulse.
*RST: NORMal

Example: PULM:SOUR EXT
selects the external modulation source.

Example: PULM:POL INV
selects inverted polarity.

Manual operation: See "Polarity" on page 114

[:SOURce<hw>]:PULM:SOURce <Source>

Selects the source for pulse modulation.

Parameters:
<Source> INTernal | EXTernal

INTernal
The internal pulse generator is used for the pulse modulation.
EXTernal
The signal applied externally via the trigger connector is used for
the pulse modulation.
*RST: INTernal

Manual operation: See "Source" on page 114

[:SOURce<hw>]:PULM:STATe <State>

Activates the pulse modulation.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: PULM:STAT ON
activates pulse modulation.

Manual operation: See "State" on page 114
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[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity <Polarity>

Selects the polarity of the Gate signal.

Parameters:
<Polarity> NORMal | INVerted

*RST: NORMal

Example: PULM:TRIG:EXT:GATE:POL NORM
The pulse signal is generated while the gate signal is high.

Manual operation: See "Gate Input Polarity" on page 117

[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance <Impedance>

Selects the impedance for external pulse trigger.

Parameters:
<Impedance> G50 | G10K

*RST: G50

Example: SOUR:PULM:TRIG:EXT:IMP G50
selects 50 Ohm as the trigger impedance for the external pulse
trigger.

Manual operation: See "External Impedance" on page 114

[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe <Slope>

Sets the polarity of the active slope of an externally applied trigger signal.

Parameters:
<Slope> NEGative | POSitive

*RST: POSitive

Example: PULM:TRIG:EXT:SLOP NEG
The pulse generator is triggered on the negative slope of the
external trigger signal.

Manual operation: See "Ext. Trigger Input Slope" on page 117

[:SOURce<hw>]:PULM:TRIGger:MODE <Mode>

Selects the trigger mode for pulse modulation.

Parameters:
<Mode> AUTO | EXTernal | EGATe

AUTO
The pulse modulation is generated continuously.
EXTernal
The pulse modulation is triggered by an external trigger event.
The trigger signal is supplied via the trigger connector.
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EGATe
The pulse modulation is gated by an external gate signal. The
trigger signal is supplied via the trigger connector.
*RST: AUTO

Example: PULM:TRIG:MODE EXT
selects triggering by an external trigger event.

Manual operation: See "Trigger Mode" on page 117

[:SOURce<hw>]:PULM:WIDTh <Width>

Sets the width of the generated pulse. The width determines the pulse length. The
pulse width must be at least 20ns less than the set pulse period.

Parameters:
<Width> float

Range: 20 ns  to  100 s
Increment: 10 ns
*RST: 2 us

Example: PULM:WIDT 33 us
sets a width of 33 us for the pulse.

Manual operation: See "Pulse Width" on page 115

11.19  SOURce:ROSCillator Subsystem

[:SOURce]:ROSCillator:EXTernal:FREQuency.................................................................. 259
[:SOURce]:ROSCillator:OUTPut:FREQuency....................................................................260
[:SOURce]:ROSCillator:SOURce..................................................................................... 260
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue.............................................................. 260
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe].............................................................260
[:SOURce]:ROSCillator:EXTernal:SBANdwidth..................................................................261

[:SOURce]:ROSCillator:EXTernal:FREQuency <ExtFreq>

Selects the frequency of the external reference.

Parameters:
<ExtFreq> 10MHZ | 100MHZ | 1000MHZ | 13MHZ

13MHZ requires RF board with part number 1419.5308.02.
To find out the RF board installed in the instrument:
Select "SGMA-GUI > instrument name > Setup > Hardware
Config" > "RF Assembly"
Observe the part number of the assembly "RfBoard".

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Ext. Ref. Input Frequency" on page 85
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[:SOURce]:ROSCillator:OUTPut:FREQuency <OutputFreq>

Selects the output for the reference oscillator signal.

Parameters:
<OutputFreq> 10MHZ | 100MHZ | 1000MHZ | 13MHZ

13MHZ requires RF board with part number 1419.5308.02.

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "Output Frequency" on page 86

[:SOURce]:ROSCillator:SOURce <Source>

Select the reference oscillator signal source.

Parameters:
<Source> INTernal | EXTernal

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 193.

Manual operation: See "Ref. Oscillator Source/Ext Ref On/Off" on page 67

[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue <Value>

Allows an application to shift the reference oscillator frequency by a small amount.

The setting range depends on the reference oscillator type and its factory calibration
value. Allowed are the following ranges:

● For TCXO oscillator: Max - Min = 1023
● For OCXO oscillator: Max - Min = 65535 (option R&S SGS-B1 required.)

Parameters:
<Value> integer

Range: Min  to  Max
*RST: 0

Example: See Chapter 11.1.4, "Advanced Task for Optimizing Perform-
ance", on page 196.

Manual operation: See "DAC Value" on page 87

[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] <State>

Determines whether the calibrated (OFF) or a user-defined (ON) adjustment value is
used for fine adjustment of the frequency.

If user-defined values are used, the instrument is no longer in the calibrated state.
However, the calibration value is not changed and the instrument resumes the calibra-
ted state after sending the com-
mand :SOURce:ROSCillator:INTernal:ADJust:STATe OFF.
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Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: ROSC:SOUR INT
Selects the internal source.
ROSC:ADJ ON
Activates use of a user-defined adjustment value.
ROSC:ADJ:VAL 1400
Sets the adjustment value to 1400.

Manual operation: See "Adjustment Active" on page 87

[:SOURce]:ROSCillator:EXTernal:SBANdwidth <SBandwidth>

Sets the synchronization bandwidth for an external reference signal.

Parameters:
<SBandwidth> WIDE | NARRow

NARRow
The synchronization bandwidth is 40 Hz.
WIDE
Synchronization bandwidth is 250 Hz.
*RST: n.a. (factory preset)

Example: ROSC:SOUR EXT
Selects the external source.
ROSC:EXT:FREQ 10 MHz
Informs the instrument that the external reference has a fre-
quency of 10 MHz.
ROSC:EXT:SBAN WID
Selects wideband setting for synchronization bandwidth.

Manual operation: See "Synchronization Bandwidth" on page 85

11.20  STATus Subsystem

This system contains the commands for the status reporting system. See also Chap-
ter A.5, "Status Reporting System", on page 302 for detailed information.

*RST on page 202 has no effect on the status registers.

Value ranges

● Queries return the current value of the respective register, which permits a check of
the device status.
Return values: A decimal value in the range 0 to 32767 (=215-1)

● The configuration commands set the respective register thus determining which
status changes of the R&S SGS cause the status registers to be changed.
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Setting values: A decimal value in the range 0 to 32767 (=215-1)

:STATus:OPERation:CONDition?.....................................................................................262
:STATus:OPERation:ENABle...........................................................................................262
:STATus:OPERation[:EVENt]...........................................................................................262
:STATus:OPERation:NTRansition.................................................................................... 263
:STATus:OPERation:PTRansition.....................................................................................263
:STATus:PRESet............................................................................................................263
:STATus:QUEStionable:CONDition.................................................................................. 263
:STATus:QUEStionable:ENABle.......................................................................................264
:STATus:QUEStionable[:EVENt]...................................................................................... 264
:STATus:QUEStionable:NTRansition................................................................................ 264
:STATus:QUEStionable:PTRansition................................................................................ 264
:STATus:QUEue[:NEXT]?................................................................................................265

:STATus:OPERation:CONDition?

Quieries the content of the CONDition part of the STATus:OPERation register.

This part contains information on the action currently being performed in the instru-
ment. The content is not deleted after being read out because it indicates the current
hardware status.

Return values: 
<Condition> string

Example: :STATus:OPERation:CONDition?

Usage: Query only

:STATus:OPERation:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:OPERation register. This setting deter-
mines which events of the Status-Event part are forwarded to the sum bit in the status
byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: :STAT:OPER:ENAB 32767
all events are forwarded to the sum bit of the status byte.

:STATus:OPERation[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:OPERation register. This part
contains information on the actions performed in the instrument since the last readout.
The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: :STAT:OPER:EVEN?
queries the STATus:OPERation:EVENt register.
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:STATus:OPERation:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 1 to 0 in the condition part causes an entry to be made in the EVENt
part of the register. The disappearance of an event in the hardware is thus registered,
for example the end of an adjustment.

Parameters:
<Ntransition> string

Example: :STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Opera-
tion register does not cause an entry to be made in the EVENt
part.

:STATus:OPERation:PTRansition <Ptransition>

Sets the bits of the PTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 0 to 1 in the condition part causes an entry to be made in the EVENt
part of the register. A new event in the hardware is thus registered, for example the
start of an adjustment.

Parameters:
<Ptransition> string

Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Status:Oper-
ation register cause an entry to be made in the EVENt part.

:STATus:PRESet <Preset>

Resets the status registers. All PTRansition parts are set to FFFFh (32767), i.e. all
transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition
from 1 to 0 in a CONDition bit is not detected. The ENABle parts of STATus:OPERation
and STATus:QUEStionable are set to 0, i.e. all events in these registers are not passed
on.

Parameters:
<Preset> string

Example: STAT:PRES
resets the status registers.

:STATus:QUEStionable:CONDition <Condition>

Queries the content of the CONDition part of the STATus:QUEStionable register. This
part contains information on the action currently being performed in the instrument.
The content is not deleted after being read out since it indicates the current hardware
status.

Parameters:
<Condition> string
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Example: :STATus:QUEStionable:CONDition?
queries the Status:Questionable:Condition register.

:STATus:QUEStionable:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:QUEStionable register. The enable part
determines which events of the STATus:EVENt part are enabled for the summary bit in
the status byte. These events can be used for a service request.

If a bit in the ENABle part is 1, and the correesponding EVENt bit is true, a positive
transition occurs in the summary bit. This transition is reportet to the next higher level.

Parameters:
<Enable> string

Example: STAT:QUES:ENAB 1
Problems when performing an adjustment cause an entry to be
made in the sum bit.

:STATus:QUEStionable[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:QUEStionable register. This
part contains information on the actions performed in the instrument since the last
readout. The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: STAT:QUES:EVEN?
queries the Status:Questionable:Event register.

:STATus:QUEStionable:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<Ntransition> string

Example: STAT:QUES:NTR 0
a transition from 1 to 0 in the condition part of the STA-
Tus:QUEStionable register does not cause an entry to be made
in the EVENt part

:STATus:QUEStionable:PTRansition <PTransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.
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Parameters:
<PTransition> string

Example: STAT:QUES:PTR 32767
all transitions from 0 to 1 in the condition part of the STA-
Tus:QUEStionable register cause an entry to be made in the
EVENt part

:STATus:QUEue[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Positive error numbers
denote device-specific errors, and negative error numbers denote error messages
defined by SCPI. If the error queue is empty, 0 ("No error") is returned.

The command is identical to :SYSTem:ERRor[:NEXT]? on page 268.

Return values: 
<Next> string

Example: :STATus:QUEue?
queries the oldest entry in the error queue.
Response: 0, 'no error'
no errors have occurred since the error queue was last read out

Usage: Query only

11.21  SYSTem Subsystem

The SYSTem subsystem contains a series of commands for general functions which do
not directly affect signal generation.

:SYSTem:EMODe.......................................................................................................... 266
:SYSTem:ERRor:ALL?....................................................................................................266
:SYSTem:ERRor:CODE:ALL?......................................................................................... 267
:SYSTem:ERRor:CODE[:NEXT]?.....................................................................................267
:SYSTem:ERRor:COUNt?...............................................................................................268
:SYSTem:ERRor[:NEXT]?...............................................................................................268
:SYSTem:SERRor?........................................................................................................ 268
:SYSTem:VERSion?.......................................................................................................269
:SYSTem:COMMunicate:NETWork:IPADdress.................................................................. 269
:SYSTem:COMMunicate:NETWork:IPADdress:MODE........................................................269
:SYSTem:COMMunicate:NETWork:MACaddress...............................................................270
:SYSTem:COMMunicate:NETWork:STATus?.................................................................... 270
:SYSTem:COMMunicate:NETWork:RESTart..................................................................... 270
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname................................................270
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway..................................................270
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK..........................................271
:SYSTem:COMMunicate:NETWork:RESource?.................................................................271
:SYSTem:COMMunicate:SERial:BAUD............................................................................ 271
:SYSTem:COMMunicate:SERial:PARity............................................................................271

SYSTem Subsystem



Remote Control CommandsR&S®SGS100A

266User Manual 1173.9105.02 ─ 12

:SYSTem:COMMunicate:SERial:RESource?.....................................................................272
:SYSTem:COMMunicate:SERial:SBITs.............................................................................272
:SYSTem:COMMunicate:HISLip:RESource?..................................................................... 272
:SYSTem:COMMunicate:PCIexpress:RESource?.............................................................. 272
:SYSTem:COMMunicate:SOCKet:PORT...........................................................................273
:SYSTem:COMMunicate:SOCKet:RESource?...................................................................273
:SYSTem:COMMunicate:USB:RESource?........................................................................ 273
:SYSTem:REBoot...........................................................................................................273
:SYSTem:RESTart..........................................................................................................274
:SYSTem:SHUTdown..................................................................................................... 274
:SYSTem:STARtup:COMPlete?....................................................................................... 274
:SYSTem:PROTect<ch>[:STATe]......................................................................................274
:SYSTem:HARDware:ASSembly<dir>:NAME?.................................................................. 275
:SYSTem:HARDware:ASSembly<dir>:PNUMber?............................................................. 275
:SYSTem:HARDware:ASSembly<dir>:REVision?.............................................................. 275
:SYSTem:HARDware:ASSembly<dir>:SNUMber?............................................................. 276
:SYSTem:SOFTware:OPTion<dir>:DESignation?...............................................................276
:SYSTem:SOFTware:OPTion<dir>:EXPiration?................................................................. 276
:SYSTem:SOFTware:OPTion<dir>:LICenses?...................................................................277
:SYSTem:SOFTware:OPTion<dir>:NAME?....................................................................... 277
:SYSTem:MMEMory:PATH:USER?.................................................................................. 277
:SYSTem:OSYStem?......................................................................................................277

:SYSTem:EMODe <Mode>

Enables and selects the Eco Mode. With enabled eco mode EM1 the doubler stage in a
12 GHz instrument is permanently switched off to reduce power consumption and the
maximum frequency is limited to 6 GHz.

Parameters:
<Mode> OFF | EM1

*RST: OFF

Example: see Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191

:SYSTem:ERRor:ALL?

Queries the error/event queue for all unread items and removes them from the queue.

Return values: 
<All> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
A comma separated list of error number and a short description
of the error in FIFO order.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
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Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR:ALL?
Queries all entries in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE:ALL?

Queries the error numbers of all entries in the error queue and then deletes them.

Return values: 
<All> string

Returns the error numbers. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.

0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE:ALL
Queries all entries in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE[:NEXT]?

Queries the error number of the oldest entry in the error queue and then deletes it.

Return values: 
<Next> string

Returns the error number. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.

0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.
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Example: SYST:ERR:CODE
Queries the oldest entry in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:COUNt?

Queries the number of entries in the error queue.

Return values: 
<Count> integer

0
The error queue is empty.

Example: SYST:ERR:COUN
Queries the number of entries in the error queue.
Response: 1
One error has occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the oldest item and removes it from the queue.

Return values: 
<Next> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
Error number and a short description of the error.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR?
Queries the oldest entry in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:SERRor?

Returns a list of all errors existing at the time when the query is started. This list corre-
sponds to the display on the info page under manual control.
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Return values: 
<Serror> string

Example: SYST:SERR
queries all errors existing in the error queue.

Example: Response: -221, 'Settings conflict', 153,
'Input voltage out of range'
The two returned errors have occurred since the error queue
was last queried.

Usage: Query only

:SYSTem:VERSion?

Queries the SCPI version the instrument's command set complies with.

Return values: 
<Version> string

Example: SYST:VERS
queries the SCPI version.
Response: "1996"
The instrument complies with the SCPI version from 1996.

Usage: Query only

:SYSTem:COMMunicate:NETWork:IPADdress <IpAddress>

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0.  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress "7.8.9.10"
sets the IP address of the instrument.

Manual operation: See "IP Address" on page 141

:SYSTem:COMMunicate:NETWork:IPADdress:MODE <Mode>

Selects manual or automatic setting of the IP address.

Parameters:
<Mode> AUTO | STATic

*RST: n.a. (factory preset: AUTO)

Example: SYSTem:COMMunicate:NETWork:IPADdress:MODE AUTO
The IP address is assigned automatically (DHCP)

Manual operation: See "Address Mode" on page 140
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:SYSTem:COMMunicate:NETWork:MACaddress <MacAddress>

Queries the MAC address of the network adapter.

Parameters:
<MacAddress> string

Example: SYST:COMM:NETW:MAC
queries the MAC address.

:SYSTem:COMMunicate:NETWork:STATus?

Queries the network configuration state.

Return values: 
<State> 0 | 1 | OFF | ON

Usage: Query only

:SYSTem:COMMunicate:NETWork:RESTart

Restarts the network connection to the instrument, terminates the connection and sets
it up again.

Example: SYSTem:COMMunicate:NETWork:RESTart
Usage: Event

:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname <Hostname>

Sets the individual host name of the R&S SGS.

Note: it is recommended that you do not change the host name in order to avoid prob-
lems with the networdk connection. However, if you change the host name be sure to
use an unique name.

The host name is a protected parameter, To change it, first disable protection level 1
with command :SYSTem:PROTect<ch>[:STATe] on page 274.

Parameters:
<Hostname> string

Example: SYSTem:PROTect1:STATe OFF,123456
SYSTem:COMMunicate:NETWork:HOSTname 'SIGGEN'
sets the individual computer name of the R&S SGS.

Manual operation: See "Hostname" on page 140

:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway <Gateway>

Sets the IP address of the default gateway.
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Parameters:
<Gateway> string

Range: 0.0.0.0  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress:GATeway
'1.2.3.4'
sets the IP address of the default gateway.

Manual operation: See "Default Gateway" on page 141

:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK <Mask>

Sets the subnet mask.

Parameters:
<Mask> string

Example: SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:
MASK '255.255.0.0'
determines the subnet mask.

Manual operation: See "Subnet Mask" on page 141

:SYSTem:COMMunicate:NETWork:RESource?

Queries the VISA resource string, used for remote control of the instrument with VXI-11
protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:NETWork:RESource?
Response: "TCPIP::192.1.2.3::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 142

:SYSTem:COMMunicate:SERial:BAUD <Baud>

Sets the baudrate for the serial remote control interface.

Parameters:
<Baud> 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200

*RST: n.a. (factory preset: 115200)

Example: SYSTem:COMMunicate:SERial:BAUD 115200
Sets 115200 baudrate.

:SYSTem:COMMunicate:SERial:PARity <Parity>

Sets the parity for the serial remote control interface.
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Parameters:
<Parity> NONE | ODD | EVEN

*RST: n.a. (factory preset: NONE)

Example: SYST:COMM:SER:PAR NONE
Selects parity NONE.

:SYSTem:COMMunicate:SERial:RESource?

Queries the VISA resource string for the serial remote control interface. This string is
used for remote control of the instrument.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SERial:RESource?
queries the VISA resource string.
Response: "ASRL1::INSTR"

Usage: Query only

:SYSTem:COMMunicate:SERial:SBITs <SBits>

Sets the number of stop bits for the serial remote control interface.

Parameters:
<SBits> 1 | 2

*RST: n.a. (factory preset: 1)

Example: SYST:COMM:SER:SBIT 2
Selects 2 stop bits.

:SYSTem:COMMunicate:HISLip:RESource?

Queries the VISA resource string, used for remote control of the instrument with
HiSLIP protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:HISLip:RESource?
Response: "TCPIP::192.1.2.3::hislip0::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 142

:SYSTem:COMMunicate:PCIexpress:RESource?

Queries the visa resource string for remote control via the PCIe interface.

Return values: 
<Resource> string
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Usage: Query only

Manual operation: See "Visa Resource Strings" on page 142

:SYSTem:COMMunicate:SOCKet:PORT <ScpiEthPort>

Sets the port number for remote control via socket communication.

Parameters:
<ScpiEthPort> integer

Range: 1000  to  65535
*RST: n.a. (factory preset: 5025)

Example: SYSTem:COMMunicate:SOCKet:PORT 5030
// specifies the socket port number.

Manual operation: See "SCPI Port" on page 61

:SYSTem:COMMunicate:SOCKet:RESource?

Queries the VISA resource string for remote control via LAN interface, using TCP/IP
socket protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SOCKet:RESource?
Response: "TCPIP::10.113.1.150::5025::SOCKET"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 142

:SYSTem:COMMunicate:USB:RESource?

Queries the VISA resource string for remote control via the USB interface.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:USB:RESource?
queries the VISA resource string for remote control via the USB
interface.
Response: "USB::72::000000::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 142

:SYSTem:REBoot

Restarts the firmware and the operating system.

Usage: Event
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:SYSTem:RESTart

Restarts the firmware. The operating system remains active.

Usage: Event

:SYSTem:SHUTdown

Shuts down the instrument.

Usage: Event

:SYSTem:STARtup:COMPlete?

Queries if the startup of the instrument is completed.

Return values: 
<Complete> 0 | 1 | OFF | ON

*RST: 0

Example: SYST:STAR:COMP?
// 1
// the startup of the instrument is completed

Usage: Query only

:SYSTem:PROTect<ch>[:STATe] <State>[, <Key>]

Activates and deactivates the specified protection level.

Suffix: 
<ch>

.
Indicates the protection level.

Parameters:
<State> select

*RST: n.a. (factory preset: 1)

Setting parameters: 
<Key> integer

The respective functions are disabled when the protection level
is activated. No password is required for activation of a level. A
password must be entered to deactivate the protection level.
The password for the first level is 123456.

Example: // to activate protection level
SYSTem:PROTect1:STATe 1
// internal adjustments or hostname cannot be changed
// to unlock protection level 1
SYSTem:PROTect1:STATe 0,123456
// internal adjustments are accessible
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:SYSTem:HARDware:ASSembly<dir>:NAME?

The query returns a list of hardware assembly names.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<Name> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Assembly" on page 131

:SYSTem:HARDware:ASSembly<dir>:PNUMber?

The query returns the list of hardware module part numbers.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<PNumber> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Assembly" on page 131

:SYSTem:HARDware:ASSembly<dir>:REVision?

Queries the list of hardware module revisions.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<Revision> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Assembly" on page 131
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:SYSTem:HARDware:ASSembly<dir>:SNUMber?

Queries the list of hardware module serial numbers.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<SNumber> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Assembly" on page 131

:SYSTem:SOFTware:OPTion<dir>:DESignation?

Queries the list of option descriptions.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Designation> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 133

:SYSTem:SOFTware:OPTion<dir>:EXPiration?

Queries the list of option expiration informations.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Expiration> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 133
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:SYSTem:SOFTware:OPTion<dir>:LICenses?

Queries the list of option license counts.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Licenses> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 133

:SYSTem:SOFTware:OPTion<dir>:NAME?

Queries the list of option names.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Name> string

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 133

:SYSTem:MMEMory:PATH:USER?

Queries the user directory, that means the directory the instrument stores user files on.

Return values: 
<PathUser> string

Example: SYSTem:MMEMory:PATH:USER?
Response: "/var/sgs/"'

Usage: Query only

:SYSTem:OSYStem?

Queries the operating system of the instrument.

Return values: 
<OperSystem> string
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Example: SYSTem:OSYStem?
Response: "Linux"

Usage: Query only

11.22  TEST Subsystem

The TEST system contains the commands for performing the routines as well as for
direct manipulation of the hardware assemblies (:TEST:DIRect).

The self tests return a "0" if the test is performed successfully, otherwise a value other
than "0" is returned. None of the commands of this system have an *RST value.

Improper use can destroy the assembly
The respective hardware assembly responds directly to the :TEST:DIRect command;
any safety mechanisms are bypassed. The command is intended for servicing purpo-
ses and should be used only by the Rohde & Schwarz service personnel.

:TEST:ALL:STARt...........................................................................................................278
:TEST:ALL:RESult?........................................................................................................278
:TEST:KEYBoard[:STATe]............................................................................................... 278

:TEST:ALL:STARt

Starts the selftest. Use the command :TEST:ALL:RESult? to query the result.

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Event

:TEST:ALL:RESult?

Queries the result of the performed selftest. Start the selftest with :TEST:ALL:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

*RST: STOPped

Example: See Chapter 11.1.1, "Performing General Task for Instrument
Setup", on page 191.

Usage: Query only

:TEST:KEYBoard[:STATe] <State>

Enable/disable keyboard and LED test state.
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Parameters:
<State> 0 | 1 | OFF | ON

11.23  UNIT Subsystem

The UNIT subsystem contains the commands specifying which units are valid if no unit
is indicated in a command. These settings are valid for the entire instrument.

:UNIT:ANGLe <Angle>

Sets the default angle unit for remote control. Does not influence the manual control
parameter units and the display.

Parameters:
<Angle> DEGRee | RADian

*RST: RADian

Example: UNIT:ANGL DEG
sets DEG as a default unit for all commands which determine
angle values.

:UNIT:POWer <Power>

Defines the default unit for power parameters. This setting affects the GUI, as well as
all remote control commands that determine power values.

Parameters:
<Power> V | DBUV | DBM

*RST: DBM

Example: UNIT:POW V
sets V as a default unit for all commands which determine power
values.

11.24  List of R&S SGS Commands

:CALibration:ALL[:MEASure]?....................................................................................................................... 205
:CALibration:FREQuency:TEMPerature?...................................................................................................... 207
:CALibration:FREQuency[:MEASure]?.......................................................................................................... 206
:CALibration:IQModulator:FULL?...................................................................................................................206
:CALibration:IQModulator:LOCal?................................................................................................................. 206
:CALibration:IQModulator:TEMPerature?......................................................................................................207
:CALibration:LEVel:TEMPerature?................................................................................................................ 207
:CALibration:LEVel[:MEASure]?.................................................................................................................... 206
:CALibration:OEXTension.............................................................................................................................. 207
:CALibration:ROSCillator:DATA:MODE......................................................................................................... 207
:CALibration:ROSCillator[:DATA]................................................................................................................... 208
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:CONNector:REFLo:OUTPut......................................................................................................................... 208
:CONNector:TRIGger:OMODe...................................................................................................................... 208
:DIAGnostic:POINt:CATalog?.........................................................................................................................209
:DIAGnostic[:MEASure]:POINt?.....................................................................................................................209
:EXTension:BUSY[:STATe]?...........................................................................................................................211
:EXTension:INSTruments:NAME?................................................................................................................. 210
:EXTension:INSTruments:REMote:CHANnel?...............................................................................................210
:EXTension:INSTruments:REMote:LAN:NAME?............................................................................................211
:EXTension:INSTruments:REMote:SERial?...................................................................................................211
:EXTension:INSTruments:SCAN[:STATe]...................................................................................................... 210
:EXTension:REMote:STATe?......................................................................................................................... 210
:EXTension:SELect........................................................................................................................................ 212
:FFASt............................................................................................................................................................221
:INITiate<hw>[:POWer]:CONTinuous............................................................................................................ 227
:LOCK?.......................................................................................................................................................... 203
:MEMory:HFRee?.......................................................................................................................................... 219
:MMEMory:CATalog:LENGth?....................................................................................................................... 216
:MMEMory:CATalog?..................................................................................................................................... 216
:MMEMory:CDIRectory..................................................................................................................................216
:MMEMory:COPY.......................................................................................................................................... 217
:MMEMory:DATA........................................................................................................................................... 217
:MMEMory:DCATalog:LENGth?.....................................................................................................................218
:MMEMory:DCATalog?...................................................................................................................................218
:MMEMory:DELete.........................................................................................................................................219
:MMEMory:LOAD:STATe............................................................................................................................... 219
:MMEMory:MDIRectory..................................................................................................................................220
:MMEMory:MOVE..........................................................................................................................................220
:MMEMory:MSIS............................................................................................................................................220
:MMEMory:RDIRectory..................................................................................................................................220
:MMEMory:STORe:STATe............................................................................................................................. 221
:OUTPut:AFIXed:RANGe:LOWer?................................................................................................................ 222
:OUTPut:AFIXed:RANGe:UPPer?.................................................................................................................222
:OUTPut:AMODe........................................................................................................................................... 222
:OUTPut[:STATe]............................................................................................................................................223
:OUTPut[:STATe]:PON...................................................................................................................................223
:PFASt............................................................................................................................................................221
:READ<ch>[:POWer]?................................................................................................................................... 227
:SENSe<ch>:UNIT[:POWer]..........................................................................................................................228
:SENSe<ch>[:POWer]:APERture:DEFault:STATe......................................................................................... 228
:SENSe<ch>[:POWer]:APERture:TIMe......................................................................................................... 229
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?...................................................................................229
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect.................................................................................229
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe.................................................................................. 229
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?..............................................................................................230
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER]..............................................................................................230
:SENSe<ch>[:POWer]:FILTer:NSRatio.......................................................................................................... 231
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe..............................................................................................231
:SENSe<ch>[:POWer]:FILTer:SONCe........................................................................................................... 231
:SENSe<ch>[:POWer]:FILTer:TYPE.............................................................................................................. 232
:SENSe<ch>[:POWer]:FREQuency...............................................................................................................232
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:SENSe<ch>[:POWer]:LOGGing:STATe........................................................................................................233
:SENSe<ch>[:POWer]:OFFSet......................................................................................................................233
:SENSe<ch>[:POWer]:OFFSet:STATe...........................................................................................................233
:SENSe<ch>[:POWer]:SNUMber?.................................................................................................................233
:SENSe<ch>[:POWer]:SOURce.................................................................................................................... 234
:SENSe<ch>[:POWer]:STATus[:DEVice]?..................................................................................................... 234
:SENSe<ch>[:POWer]:SVERsion?................................................................................................................234
:SENSe<ch>[:POWer]:TYPE?.......................................................................................................................235
:SENSe<ch>[:POWer]:ZERO........................................................................................................................ 235
:SLISt:ELEMent<ch>:MAPPing..................................................................................................................... 226
:SLISt:SCAN[:STATe].....................................................................................................................................226
:SLISt:SENSor:MAP...................................................................................................................................... 227
:SLISt[:LIST]?.................................................................................................................................................226
:SOURce<hw>:PRESet................................................................................................................................. 205
:STATus:OPERation:CONDition?.................................................................................................................. 262
:STATus:OPERation:ENABle.........................................................................................................................262
:STATus:OPERation:NTRansition..................................................................................................................263
:STATus:OPERation:PTRansition..................................................................................................................263
:STATus:OPERation[:EVENt].........................................................................................................................262
:STATus:PRESet............................................................................................................................................263
:STATus:QUEStionable:CONDition................................................................................................................263
:STATus:QUEStionable:ENABle.................................................................................................................... 264
:STATus:QUEStionable:NTRansition.............................................................................................................264
:STATus:QUEStionable:PTRansition............................................................................................................. 264
:STATus:QUEStionable[:EVENt]....................................................................................................................264
:STATus:QUEue[:NEXT]?.............................................................................................................................. 265
:SYSTem:COMMunicate:HISLip:RESource?.................................................................................................272
:SYSTem:COMMunicate:NETWork:IPADdress............................................................................................. 269
:SYSTem:COMMunicate:NETWork:IPADdress:MODE..................................................................................269
:SYSTem:COMMunicate:NETWork:MACaddress..........................................................................................270
:SYSTem:COMMunicate:NETWork:RESource?............................................................................................271
:SYSTem:COMMunicate:NETWork:RESTart.................................................................................................270
:SYSTem:COMMunicate:NETWork:STATus?................................................................................................ 270
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname......................................................................... 270
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway........................................................................... 270
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK.................................................................. 271
:SYSTem:COMMunicate:PCIexpress:RESource?.........................................................................................272
:SYSTem:COMMunicate:SERial:BAUD.........................................................................................................271
:SYSTem:COMMunicate:SERial:PARity........................................................................................................ 271
:SYSTem:COMMunicate:SERial:RESource?.................................................................................................272
:SYSTem:COMMunicate:SERial:SBITs..........................................................................................................272
:SYSTem:COMMunicate:SOCKet:PORT.......................................................................................................273
:SYSTem:COMMunicate:SOCKet:RESource?.............................................................................................. 273
:SYSTem:COMMunicate:USB:RESource?.................................................................................................... 273
:SYSTem:EMODe.......................................................................................................................................... 266
:SYSTem:ERRor:ALL?...................................................................................................................................266
:SYSTem:ERRor:CODE:ALL?....................................................................................................................... 267
:SYSTem:ERRor:CODE[:NEXT]?.................................................................................................................. 267
:SYSTem:ERRor:COUNt?..............................................................................................................................268
:SYSTem:ERRor[:NEXT]?..............................................................................................................................268
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:SYSTem:FPReset.........................................................................................................................................205
:SYSTem:HARDware:ASSembly<dir>:NAME?..............................................................................................275
:SYSTem:HARDware:ASSembly<dir>:PNUMber?........................................................................................ 275
:SYSTem:HARDware:ASSembly<dir>:REVision?......................................................................................... 275
:SYSTem:HARDware:ASSembly<dir>:SNUMber?........................................................................................ 276
:SYSTem:MMEMory:PATH:USER?............................................................................................................... 277
:SYSTem:OSYStem?.....................................................................................................................................277
:SYSTem:PRESet.......................................................................................................................................... 205
:SYSTem:PROTect<ch>[:STATe]................................................................................................................... 274
:SYSTem:REBoot...........................................................................................................................................273
:SYSTem:RESTart..........................................................................................................................................274
:SYSTem:SERRor?........................................................................................................................................268
:SYSTem:SHUTdown.....................................................................................................................................274
:SYSTem:SOFTware:OPTion<dir>:DESignation?......................................................................................... 276
:SYSTem:SOFTware:OPTion<dir>:EXPiration?............................................................................................ 276
:SYSTem:SOFTware:OPTion<dir>:LICenses?.............................................................................................. 277
:SYSTem:SOFTware:OPTion<dir>:NAME?................................................................................................... 277
:SYSTem:STARtup:COMPlete?.....................................................................................................................274
:SYSTem:VERSion?...................................................................................................................................... 269
:TEST:ALL:RESult?........................................................................................................................................278
:TEST:ALL:STARt.......................................................................................................................................... 278
:TEST:EXTension:CONNection:RF?..............................................................................................................212
:TEST:EXTension:CONNection?....................................................................................................................212
:TEST:KEYBoard[:STATe].............................................................................................................................. 278
:UNIT:ANGLe................................................................................................................................................. 279
:UNIT:POWer................................................................................................................................................. 279
:UNLock......................................................................................................................................................... 204
[:SOURce]:CORRection:CSET:CATalog?......................................................................................................238
[:SOURce]:CORRection:CSET:DELete......................................................................................................... 240
[:SOURce]:FREQuency:OFFSet....................................................................................................................236
[:SOURce]:FREQuency[:CW|FIXed]..............................................................................................................236
[:SOURce]:IQ:CREStfactor............................................................................................................................247
[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude]...........................................................................................246
[:SOURce]:IQ:IMPairment:LEAKage:I........................................................................................................... 246
[:SOURce]:IQ:IMPairment:LEAKage:Q..........................................................................................................246
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe]..........................................................................................247
[:SOURce]:IQ:IMPairment[:STATe]................................................................................................................ 247
[:SOURce]:IQ:STATe......................................................................................................................................246
[:SOURce]:IQ:WBSTate.................................................................................................................................248
[:SOURce]:LOSCillator:SOURce................................................................................................................... 236
[:SOURce]:OPMode.......................................................................................................................................235
[:SOURce]:PATH:COUNt?............................................................................................................................. 237
[:SOURce]:PHASe.........................................................................................................................................248
[:SOURce]:PHASe:REFerence......................................................................................................................248
[:SOURce]:POWer:ALC:DSENsitivity............................................................................................................ 249
[:SOURce]:POWer:ALC:SONCe....................................................................................................................249
[:SOURce]:POWer:ALC[:STATe]....................................................................................................................249
[:SOURce]:POWer:ATTenuation:RFOFf:MODE............................................................................................ 250
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet].........................................................................................250
[:SOURce]:POWer:LIMit[:AMPLitude]............................................................................................................252
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[:SOURce]:POWer:LMODe............................................................................................................................250
[:SOURce]:POWer:PEP?...............................................................................................................................252
[:SOURce]:POWer:POWer............................................................................................................................ 250
[:SOURce]:POWer:RANGe:LOWer?............................................................................................................. 253
[:SOURce]:POWer:RANGe:UPPer?..............................................................................................................253
[:SOURce]:POWer:SCHaracteristic...............................................................................................................251
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet........................................................................................... 252
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude].................................................................................... 251
[:SOURce]:ROSCillator:EXTernal:FREQuency..............................................................................................259
[:SOURce]:ROSCillator:EXTernal:SBANdwidth.............................................................................................261
[:SOURce]:ROSCillator:OUTPut:FREQuency............................................................................................... 260
[:SOURce]:ROSCillator:SOURce...................................................................................................................260
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue......................................................................................... 260
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe]....................................................................................... 260
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency...............................................................................238
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency:POINts?................................................................ 239
[:SOURce<hw>]:CORRection:CSET:DATA:POWer.......................................................................................239
[:SOURce<hw>]:CORRection:CSET:DATA:POWer:POINts?........................................................................ 239
[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe............................................... 240
[:SOURce<hw>]:CORRection:CSET[:SELect]...............................................................................................244
[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog?........................................................................240
[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension......................................................................241
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect............................................................................241
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn....................................................... 242
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal....................................................... 242
[:SOURce<hw>]:CORRection:DEXChange:EXECute...................................................................................243
[:SOURce<hw>]:CORRection:DEXChange:MODE.......................................................................................243
[:SOURce<hw>]:CORRection:DEXChange:SELect...................................................................................... 244
[:SOURce<hw>]:CORRection:VALue?.......................................................................................................... 245
[:SOURce<hw>]:CORRection:ZERoing:STATe............................................................................................. 245
[:SOURce<hw>]:CORRection[:STATe].......................................................................................................... 245
[:SOURce<hw>]:PULM:DELay...................................................................................................................... 255
[:SOURce<hw>]:PULM:DOUBle:DELay........................................................................................................256
[:SOURce<hw>]:PULM:DOUBle:WIDTh........................................................................................................256
[:SOURce<hw>]:PULM:MODE...................................................................................................................... 256
[:SOURce<hw>]:PULM:PERiod.....................................................................................................................256
[:SOURce<hw>]:PULM:POLarity...................................................................................................................257
[:SOURce<hw>]:PULM:SOURce...................................................................................................................257
[:SOURce<hw>]:PULM:STATe.......................................................................................................................257
[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity.......................................................................... 258
[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance................................................................................ 258
[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe.......................................................................................258
[:SOURce<hw>]:PULM:TRIGger:MODE....................................................................................................... 258
[:SOURce<hw>]:PULM:WIDTh......................................................................................................................259
*CLS...............................................................................................................................................................200
*ESE.............................................................................................................................................................. 200
*ESR?............................................................................................................................................................ 200
*IDN?............................................................................................................................................................. 200
*IST?..............................................................................................................................................................200
*OPC..............................................................................................................................................................201
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*OPT?............................................................................................................................................................ 201
*PRE.............................................................................................................................................................. 201
*PSC.............................................................................................................................................................. 201
*RCL.............................................................................................................................................................. 202
*RST.............................................................................................................................................................. 202
*SAV...............................................................................................................................................................202
*SRE.............................................................................................................................................................. 202
*STB?.............................................................................................................................................................202
*TRG..............................................................................................................................................................203
*TST?.............................................................................................................................................................203
*WAI...............................................................................................................................................................203
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12  Maintenance
The instrument does not need periodic maintenance. Only cleaning the instrument is
essential.

Follow the instructions in the service manual and the safety instructions when
exchanging modules or ordering spare parts. The order number for spare parts is inclu-
ded in the service manual. The service manual includes further information particularly
on troubleshooting, repair, exchange of modules (including battery exchange, adjust-
ment of the OCXO oscillator) and alignment.

The address of our support center and a list of all Rohde & Schwarz service centers
can be found at the beginning of this manual.

12.1  Cleaning

Risk of electric shock
If moisture enters the casing, for example if you clean the instrument using a moist
cloth, contact with the instrument can lead to electric shock. Before cleaning the instru-
ment other than with a dry cloth, make sure that the instrument is switched off and dis-
connected from all power supplies.

Instrument damage caused by cleaning agents
Cleaning agents contain substances such as solvents (thinners, acetone, etc.), acids,
bases, or other substances. Solvents can damage the front panel labeling, plastic
parts, or screens, for example.
Never use cleaning agents to clean the outside of the instrument. Use a soft, dry, lint-
free dust cloth instead.

Risk of instrument damage due to obstructed fans
If the instrument is operated in dusty areas, the fans become obstructed by dust or
other particles over time. Check and clean the fans regularly to ensure that they always
operate properly. If the instrument is run with obstructed fans for a longer period, the
instrument overheats, which can disturb the operation and even cause damage.

1. Clean the outside of the instrument using a soft, dry, lint-free dust cloth.

Cleaning
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2. Check and clean the fans regularly to ensure that they always operate properly.

3. Clean the touchscreen as follows:

a) Apply a small amount of standard screen cleaner to a soft cloth.
b) Wipe the screen gently with the moist, but not wet, cloth.
c) If necessary, remove any excess moisture with a dry, soft cloth.

12.2  Storing and Packing

The storage temperature range of the instrument is given in the data sheet. If the
instrument is to be stored for a longer period of time, it must be protected against dust.

Repack the instrument as it was originally packed when transporting or shipping. The
two protective foam plastic parts prevent the control elements and connectors from
being damaged. The antistatic packing foil avoids any undesired electrostatic charging
to occur.

If you do not use the original packaging, use a sturdy cardboard box of suitable size
and provide for sufficient padding to prevent the instrument from slipping inside the
package. Wrap antistatic packing foil around the instrument to protect it from electro-
static charging.

Storing and Packing
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13  Error Messages and Troubleshooting
This chapter describes the error messages of the R&S SGS. The error messages are
output in the "Info" line on the screen and entered in the error/event queue of the sta-
tus reporting system.

A great variety of different messages such as status messages, error messages, warn-
ings or information are displayed in the header field of the screen. Some error mes-
sages require that the error must be eliminated before correct instrument operation can
be ensured. The "Info" window with a list of current messages and a detailed descrip-
tion of each message can be opened with the "Info" button (see also Chapter 6.2.1,
"Info Dialog", on page 62).

13.1  Status Information

The status messages are displayed in the Info line of the R&S SGMA-GUI main panel.
The status information gives the user an overview of the main operating states and set-
tings of the instrument. The states are indicated for information only and do not neces-
sitate any action by the user.

Status Information displayed in the Info line

AttFixed
Attenuator fixed mode is active.

The uninterrupted level settings are made in a fixed range without attenuator switching.
The variation range is set automatically when this mode is activated. The range is dis-
played with the parameter "SGMA-GUI > Instrument Name > Level > Attenuator Fixed
Range".

13.2  Error Messages

Messages indicate errors in the instrument. They are displayed in the info line in differ-
ent colors depending on their importance and display duration. Errors (e.g. no calibra-
tion data) are displayed in red, information (e.g. file not found) and warnings in black.
Warnings indicate less significant errors (e.g. the instrument operates outside specified
data).

See also Chapter 6.2.1, "Info Dialog", on page 62 and Chapter 6.2.2, "Understanding
the Messages in the Info Bar", on page 63.

13.2.1  Volatile messages

Volatile messages report automatic settings in the instrument (e.g. switching off of
incompatible types of modulation) or on illegal entries that are not accepted by the

Error Messages
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instrument (e.g. range violations). They are displayed in the info line on a yellow back-
ground. They are displayed on top of status information or permanent messages.

Volatile messages do not normally demand user actions and disappear automatically
after a brief period of time. They are stored in the history, however.

SCPI command: :SYSTem:ERRor:ALL? and :SYSTem:ERRor[:NEXT]?.

13.2.2  Permanent messages

Permanent messages are displayed if an error occurs that impairs further instrument
operation, e.g. a hardware fault. The error signaled by a permanent message must be
eliminated before correct instrument operation can be ensured.

The message is displayed until the error is eliminated. It covers the status display in
the info line. After error elimination, the message automatically disappears and is also
recorded in the history.

SCPI command: :SYSTem:SERRor?

13.3  SCPI-Error Messages

The SCPI error messages are the same in all SCPI instruments. Detailed information
and an overview of all error messages as defined in SCPI standard can be found in the
corresponding documentation.

The errors are assigned negative numbers. The error text being entered into the error/
event queue or being displayed is printed in bold face on the left together with the error
code. Below the error text, there is an explanation as to the respective error.

13.4  Device-Specific Error Messages

The following table contains all error messages specific for the instrument in alphabeti-
cal order, as well as an explanation of the error situation. The positive error codes mark
the errors specific of the instrument.

The device-specific error messages set bit 3 in the ESR register.

The index provides a list of the error messages sorted according to their error codes.

Device-Specific Error Messages
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Error
Code

Error Description Remedy

180 Adjustment failed Adjustment could not be executed The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the device.

182 Adjustment data miss-
ing

Adjustment data are missing. The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the instrument.

183 Adjustment data inva-
lid

Adjustment data are invalid and must
be restored.

The adjustment data have to be
generated again by an internal or
external adjustment or to be loa-
ded into the instrument.

200 Cannot access hard-
ware

The data transmission to a module
was unsuccessful.

The module is not installed, not
properly installed or missing.

201 Hardware revision out
of date

A later version of certain parts of the
instrument is necessary to execute
the function selected.

The driver does not support the
installed version of a module.

202 Cannot access the
EEPROM

A error occurs when writing or reading
a EEPROM.

The EEPROM might be defect
and has to be replaced.

203 Invalid EEPROM data   

204 Driver initialization
failed

Initialization of a driver fails when
booting the instrument firmware.

The driver is not compatible with
the hardware or software config-
uration of the instrument.

241 No current list There is no list selected. To execute the required opera-
tion, a list has to be selected in
the related dialog. If no list is
available, a new list must be cre-
ated.

242 Unknown list type
specified

The list type selected is not valid for
the required operation.

For instance, the file extension for
mapping files is *.map. It is not possi-
ble to enter another file extension
when selecting a list.

Check the selected list type.

460 Cannot open file The selected file can not be opened. Check the path and file name.

461 Cannot write file The file can not be written. Check if the file is read-only.

462 Cannot read file The file can not be read. Check if the file contents are
compatible with the file type.

463 Filename missing The required operation cannot be
executed because the file name is not
specified.

A file name has to be entered
when creating a new list.

464 Invalid filename exten-
sion

The file extension is not valid for the
required operation.

Check the file extension.

For instance, the file extension
for the mapping files is *.map. It
is not possible to enter another
file extension when storing a list.

Device-Specific Error Messages
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Error
Code

Error Description Remedy

465 File contains invalid
data

The selected file contains data that is
not valid for the file type.

Check the file extension.

The file extension determines the
data that is valid for this file type.
If the file extension is changed
the lists are no longer recognized
and the data are therefore inva-
lid.

468 Cannot find directory Required folder cannot be found. Check drive and path.

469 No files found Folder is empty  

Device-Specific Error Messages
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Annex
A  Remote Control Basics

This chapter provides basic information on operating an instrument via remote control.

A.1  Messages

The messages transferred on the data lines are divided into the following categories:

● Interface messages
Interface messages are transmitted to the instrument on the data lines, with the
attention line being active (LOW). They are used to communicate between the con-
troller and the instrument. Interface messages can only be sent by instruments that
have GPIB bus functionality. For details see the sections for the required interface.

● Instrument messages
Instrument messages are employed in the same way for all interfaces, if not indica-
ted otherwise in the description. Structure and syntax of the instrument messages
are described in Chapter A.3, "SCPI Command Structure", on page 292. A
detailed description of all messages available for the instrument is provided in the
chapter "Remote Control Commands".
There are different types of instrument messages, depending on the direction they
are sent:
– Commands
– Instrument responses

Commands

Commands (program messages) are messages the controller sends to the instrument.
They operate the instrument functions and request information. The commands are
subdivided according to two criteria:
● According to the effect they have on the instrument:

– Setting commands cause instrument settings such as a reset of the instru-
ment or setting the frequency.

– Queries cause data to be provided for remote control, e.g. for identification of
the instrument or polling a parameter value. Queries are formed by directly
appending a question mark to the command header.

● According to their definition in standards:
– Common commands: their function and syntax are precisely defined in stan-

dard IEEE 488.2. They are employed identically on all instruments (if imple-
mented). They refer to functions such as management of the standardized sta-
tus registers, reset and self-test.

– Instrument control commands refer to functions depending on the features of
the instrument such as frequency settings. Many of these commands have also
been standardized by the SCPI committee. These commands are marked as

Messages
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"SCPI confirmed" in the command reference chapters. Commands without this
SCPI label are device-specific; however, their syntax follows SCPI rules as per-
mitted by the standard.

Instrument responses

Instrument responses (response messages and service requests) are messages the
instrument sends to the controller after a query. They can contain measurement
results, instrument settings and information on the instrument status.

A.2  LAN Interface Messages

In the LAN connection, the interface messages are called low–level control messages.
These messages can be used to emulate interface messages of the GPIB bus.

Command Long term Effect on the instrument

&ABO Abort Aborts processing of the commands just received.

&DCL Device Clear Aborts processing of the commands just received and
sets the command processing software to a defined initial
state. Does not change the instrument setting.

&GTL Go to Local Transition to the "local" state (manual control). (The
instrument automatically returns to remote state when a
remote command is sent UNLESS &NREN was sent
before.)

&GTR Go to Remote Enables automatic transition from local state to remote
state by a subsequent remote command (after &NREN
was sent).

&GET Group Execute Trigger Triggers a previously active instrument function (e.g. a
sweep). The effect of the command is the same as with
that of a pulse at the external trigger signal input.

&LLO Local Lockout Disables transition from remote control to manual control
by means of the front panel keys.

&NREN Not Remote Enable Disables automatic transition from local state to remote
state by a subsequent remote command. (To re-activate
automatic transition use &GTR.)

&POL Serial Poll Starts a serial poll.

A.3  SCPI Command Structure

SCPI commands consist of a header and, in most cases, one or more parameters. The
header and the parameters are separated by a "white space" (ASCII code 0 to 9, 11 to
32 decimal, e.g. blank). The headers may consist of several mnemonics (keywords).
Queries are formed by appending a question mark directly to the header.

SCPI Command Structure
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The commands can be either device-specific or device-independent (common com-
mands). Common and device-specific commands differ in their syntax.

A.3.1  Syntax for Common Commands

Common (= device-independent) commands consist of a header preceded by an aster-
isk (*), and possibly one or more parameters.

Table A-1: Examples of common commands

*RST RESET Resets the instrument.

*ESE EVENT STATUS ENABLE Sets the bits of the event status enable registers.

*ESR? EVENT STATUS QUERY Queries the contents of the event status register.

*IDN? IDENTIFICATION QUERY Queries the instrument identification string.

A.3.2  Syntax for Device-Specific Commands

Not all commands used in the following examples are necessarily implemented in the
instrument. For demonstration purposes only, assume the existence of the following
commands for this section:
● DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
● FORMat:READings:DATA <type>[,<length>]
● HCOPy:DEVice:COLor <Boolean>
● HCOPy:DEVice:CMAP:COLor:RGB <red>,<green>,<blue>
● HCOPy[:IMMediate]
● HCOPy:ITEM:ALL
● HCOPy:ITEM:LABel <string>
● HCOPy:PAGE:DIMensions:QUADrant[<N>]
● HCOPy:PAGE:ORIentation LANDscape | PORTrait
● HCOPy:PAGE:SCALe <numeric value>
● MMEMory:COPY <file_source>,<file_destination>
● SENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
● SENSe:FREQuency:STOP <numeric value>
● SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}

● Long and short form..............................................................................................294
● Numeric Suffixes...................................................................................................294
● Optional Mnemonics............................................................................................. 294

SCPI Command Structure
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A.3.2.1  Long and short form

The mnemonics feature a long form and a short form. The short form is marked by
upper case letters, the long form corresponds to the complete word. Either the short
form or the long form can be entered; other abbreviations are not permitted.

Example: 
HCOPy:DEVice:COLor ON is equivalent to HCOP:DEV:COL ON.

Case-insensitivity
Upper case and lower case notation only serves to distinguish the two forms in the
manual, the instrument itself is case-insensitive.

A.3.2.2  Numeric Suffixes

If a command can be applied to multiple instances of an object, e.g. specific channels
or sources, the required instances can be specified by a suffix added to the command.
Numeric suffixes are indicated by angular brackets (<1...4>, <n>, <i>) and are replaced
by a single value in the command. Entries without a suffix are interpreted as having the
suffix 1.

Example: 
Definition: HCOPy:PAGE:DIMensions:QUADrant[<N>]
Command: HCOP:PAGE:DIM:QUAD2
This command refers to the quadrant 2.

Different numbering in remote control
For remote control, the suffix may differ from the number of the corresponding selec-
tion used in manual operation. SCPI prescribes that suffix counting starts with 1. Suffix
1 is the default state and used when no specific suffix is specified.
Some standards define a fixed numbering, starting with 0. If the numbering differs in
manual operation and remote control, it is indicated for the corresponding command.

A.3.2.3  Optional Mnemonics

Some command systems permit certain mnemonics to be inserted into the header or
omitted. These mnemonics are marked by square brackets in the description. The
instrument must recognize the long command to comply with the SCPI standard. Some
commands are considerably shortened by these optional mnemonics.

Example: 
Definition: HCOPy[:IMMediate]
Command: HCOP:IMM is equivalent to HCOP

SCPI Command Structure
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Optional mnemonics with numeric suffixes
Do not omit an optional mnemonic if it includes a numeric suffix that is relevant for the
effect of the command.
Example:
Definition:DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
Command: DISP:MAX ON refers to window 1.

In order to refer to a window other than 1, you must include the optional WINDow
parameter with the suffix for the required window.
DISP:WIND2:MAX ON refers to window 2.

A.3.3  SCPI Parameters

Many commands are supplemented by a parameter or a list of parameters. The
parameters must be separated from the header by a "white space" (ASCII code 0 to 9,
11 to 32 decimal, e.g. blank).

The parameters required for each command and the allowed range of values are
specified in the command description.

Allowed parameters are:

● Numeric Values.....................................................................................................295
● Special Numeric Values........................................................................................ 296
● Boolean Parameters............................................................................................. 297
● Text Parameters....................................................................................................297
● Character Strings.................................................................................................. 297
● Block Data.............................................................................................................297

A.3.3.1  Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point and exponent.
Values exceeding the resolution of the instrument are rounded up or down. The man-
tissa may comprise up to 255 characters, the exponent must lie inside the value range
-32000 to 32000. The exponent is introduced by an "E" or "e". Entry of the exponent
alone is not allowed.

Example: 
SENS:FREQ:STOP 1500000 = SENS:FREQ:STOP 1.5E6

Units

For physical quantities, the unit can be entered. If the unit is missing, the basic unit is
used. Allowed unit prefixes are:
● G (giga)
● MA (mega), MOHM, MHZ
● K (kilo)

SCPI Command Structure
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● M (milli)
● U (micro)
● N (nano)

Example: 
SENSe:FREQ:STOP 1.5GHz = SENSe:FREQ:STOP 1.5E9

Some settings allow relative values to be stated in percent. According to SCPI, this unit
is represented by the PCT string.

Example: 
HCOP:PAGE:SCAL 90PCT

A.3.3.2  Special Numeric Values

The following mnemonics are special numeric values. In the response to a query, the
numeric value is provided.

● MIN and MAX: denote the minimum and maximum value.
● DEF: denotes a preset value which has been stored in the EPROM. This value

conforms to the default setting, as it is called by the *RST command.
● UP and DOWN: increases or reduces the numeric value by one step. The step

width can be specified via an allocated step command for each parameter which
can be set via UP and DOWN.

● INF and NINF: INFinity and negative INFinity (NINF) represent the numeric values
9.9E37 or -9.9E37, respectively. INF and NINF are only sent as instrument respon-
ses.

● NAN: Not A Number (NAN) represents the value 9.91E37. NAN is only sent as a
instrument response. This value is not defined. Possible causes are the division of
zero by zero, the subtraction of infinite from infinite and the representation of miss-
ing values.

Example: 
Setting command: SENSe:LIST:FREQ MAXimum
Query: SENS:LIST:FREQ?
Response: 3.5E9

Queries for special numeric values
The numeric values associated to MAXimum/MINimum/DEFault can be queried by
adding the corresponding mnemonic after the quotation mark.
Example: SENSe:LIST:FREQ? MAXimum
Returns the maximum numeric value as a result.

SCPI Command Structure
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A.3.3.3  Boolean Parameters

Boolean parameters represent two states. The "ON" state (logically true) is represen-
ted by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by
"OFF" or the numeric value 0. The numeric values are provided as the response for a
query.

Example: 
Setting command: HCOPy:DEV:COL ON
Query: HCOPy:DEV:COL?
Response: 1

A.3.3.4  Text Parameters

Text parameters observe the syntactic rules for mnemonics, i.e. they can be entered
using a short or long form. Like any parameter, they have to be separated from the
header by a white space. In the response to a query, the short form of the text is provi-
ded.

Example: 
Setting command: HCOPy:PAGE:ORIentation LANDscape
Query: HCOP:PAGE:ORI?
Response: LAND

A.3.3.5  Character Strings

Strings must always be entered in quotation marks (' or ").

Example: 
HCOP:ITEM:LABel "Test1"
HCOP:ITEM:LABel 'Test1'

A.3.3.6  Block Data

Block data is a format which is suitable for the transmission of large amounts of data.
For example, a command using a block data parameter has the following structure:

FORMat:READings:DATA #45168xxxxxxxx
The ASCII character # introduces the data block. The next number indicates how many
of the following digits describe the length of the data block. In the example the 4 follow-
ing digits indicate the length to be 5168 bytes. The data bytes follow. During the trans-
mission of these data bytes all end or other control signs are ignored until all bytes are
transmitted.

#0 specifies a data block of indefinite length. The use of the indefinite format requires a
NL^END message to terminate the data block. This format is useful when the length of
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the transmission is not known or if speed or other considerations prevent segmentation
of the data into blocks of definite length.

A.3.4  Overview of Syntax Elements

The following tables provide an overview of the syntax elements and special charac-
ters.

Table A-2: Syntax elements

: The colon separates the mnemonics of a command.

; The semicolon separates two commands of a command line. It does not alter the path.

, The comma separates several parameters of a command.

? The question mark forms a query.

* The asterisk marks a common command.

' '

"

Quotation marks introduce a string and terminate it (both single and double quotation marks are
possible).

# The hash symbol introduces binary, octal, hexadecimal and block data.
● Binary: #B10110
● Octal: #O7612
● Hexa: #HF3A7
● Block: #21312

A "white space" (ASCII-Code 0 to 9, 11 to 32 decimal, e.g. blank) separates the header from the
parameters.

SCPI Command Structure
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Table A-3: Special characters

| Parameters

A vertical stroke in parameter definitions indicates alternative possibilities in the sense of "or". The
effect of the command differs, depending on which parameter is used.

Example:

Definition:HCOPy:PAGE:ORIentation LANDscape | PORTrait
Command HCOP:PAGE:ORI LAND specifies landscape orientation

Command HCOP:PAGE:ORI PORT specifies portrait orientation

Mnemonics

A selection of mnemonics with an identical effect exists for several commands. These mnemonics are
indicated in the same line; they are separated by a vertical stroke. Only one of these mnemonics
needs to be included in the header of the command. The effect of the command is independent of
which of the mnemonics is used.

Example:

DefinitionSENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
The two following commands with identical meaning can be created:

SENS:BAND:RES 1
SENS:BWID:RES 1

[ ] Mnemonics in square brackets are optional and may be inserted into the header or omitted.

Example: HCOPy[:IMMediate]
HCOP:IMM is equivalent to HCOP

{ } Parameters in curly brackets are optional and can be inserted once or several times, or omitted.

Example: SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}
The following are valid commands:

SENS:LIST:FREQ 10
SENS:LIST:FREQ 10,20
SENS:LIST:FREQ 10,20,30,40

A.3.5  Structure of a Command Line

A command line may consist of one or several commands. It is terminated by one of
the following:
● <New Line>
● <New Line> with EOI
● EOI together with the last data byte

Several commands in a command line must be separated by a semicolon ";".

Example: 
MMEM:COPY "Test1","MeasurementXY";:HCOP:ITEM ALL

This command line contains two commands. The first command belongs to the MMEM
system, the second command belongs to the HCOP system. If the next command
belongs to a different command system, the semicolon is followed by a colon.

SCPI Command Structure
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Example: 
HCOP:ITEM ALL;:HCOP:IMM

This command line contains two commands. Both commands are part of the HCOP
command system, i.e. they have one level in common.
If the successive commands belong to the same system, having one or several levels
in common, the command line can be abbreviated. When abbreviating the command
line, the second command begins with the level below HCOP. The colon after the semi-
colon is omitted. The abbreviated form of the command line reads as follows:
HCOP:ITEM ALL;IMM

Example: 
HCOP:ITEM ALL
HCOP:IMM
A new command line always begins with the complete path.

A.3.6  Responses to Queries

A query is defined for each setting command unless explicitly specified otherwise. It is
formed by adding a question mark to the associated setting command. According to
SCPI, the responses to queries are partly subject to stricter rules than in standard
IEEE 488.2.

● The requested parameter is transmitted without a header.
Example: HCOP:PAGE:ORI?, Response: LAND

● Maximum values, minimum values and all other quantities that are requested via a
special text parameter are returned as numeric values.
Example: SENSe:FREQuency:STOP? MAX, Response: 3.5E9

● Numeric values are output without a unit. Physical quantities are referred to the
basic units or to the units set using the Unit command. The response 3.5E9 in
the previous example stands for 3.5 GHz.

● Truth values (Boolean values) are returned as 0 (for OFF) and 1 (for ON).
Example:
Setting command: HCOPy:DEV:COL ON
Query: HCOPy:DEV:COL?
Response: 1

● Text (character data) is returned in a short form.
Example:
Setting command: HCOPy:PAGE:ORIentation LANDscape
Query: HCOP:PAGE:ORI?
Response: LAND

● Invalid numerical results
In some cases, particularly when a result consists of multiple numeric values, inva-
lid values are returned as 9.91E37 (not a number).
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A.4  Command Sequence and Synchronization

IEEE 488.2 defines a distinction between overlapped and sequential commands:

● A sequential command is one which finishes executing before the next command
starts executing. Commands that are processed quickly are usually implemented
as sequential commands. Sequential commands are not implemented in the instru-
ment, however the execution time of most commands is so short that they act as
sequential commands when sent in different command lines.

● An overlapping command is one which does not automatically finish executing
before the next command starts executing. Usually, overlapping commands take
longer to process and allow the program to do other tasks while being executed. If
overlapping commands do have to be executed in a defined order, e.g. in order to
avoid wrong measurement results, they must be serviced sequentially. This is
called synchronization between the controller and the instrument.

Setting commands within one command line, even though they may be implemented
as sequential commands, are not necessarily serviced in the order in which they have
been received. In order to make sure that commands are actually carried out in a cer-
tain order, each command must be sent in a separate command line.

As a general rule, send commands and queries in different program messages.

A.4.1  Preventing Overlapping Execution

To prevent an overlapping execution of commands, one of the commands *OPC,
*OPC? or *WAI can be used. All three commands cause a certain action only to be
carried out after the hardware has been set. The controller can be forced to wait for the
corresponding action to occur.

Table A-4: Synchronization using *OPC, *OPC? and *WAI

Com-
mand

Action Programming the controller

*OPC Sets the Operation Complete bit in the ESR
after all previous commands have been exe-
cuted.

● Setting bit 0 in the ESE
● Setting bit 5 in the SRE
● Waiting for service request (SRQ)

*OPC? Stops command processing until 1 is
returned. This occurs when all pending opera-
tions are completed.

Send *OPC? directly after the command
whose processing must be terminated before
other commands can be executed.

*WAI Stops further command processing until all
commands sent before *WAI have been exe-
cuted.

Send *WAI directly after the command whose
processing must be terminated before other
commands are executed.

Command synchronization using *WAI or *OPC? is a good choice if the overlapped
command takes only little time to process. The two synchronization commands simply
block overlapped execution of the command. Append the synchronization command to
the overlapping command, for example:

Command Sequence and Synchronization
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SINGle; *OPC?
For time consuming overlapped commands, you can allow the controller or the instru-
ment to do other useful work while waiting for command execution. Use one of the fol-
lowing methods:

*OPC with a service request

1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

2. Set bit no. 5 in the SRE: *SRE 32 to enable ESB service request.

3. Send the overlapped command with *OPC .

4. Wait for a service request.

The service request indicates that the overlapped command has finished.

*OPC? with a service request

1. Set bit no. 4 in the SRE: *SRE 16 to enable MAV service request.

2. Send the overlapped command with *OPC?.

3. Wait for a service request.

The service request indicates that the overlapped command has finished.

Event status register (ESE)

1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

2. Send the overlapped command without *OPC, *OPC? or *WAI.

3. Poll the operation complete state periodically (with a timer) using the sequence:
*OPC; *ESR?
A return value (LSB) of 1 indicates that the overlapped command has finished.

A.5  Status Reporting System

The status reporting system stores all information on the current operating state of the
instrument, and on errors which have occurred. This information is stored in the status
registers and in the error queue.

You can query both with the commands of the STATus Subsystem.

A.5.1  Hierarchy of the Status Registers

The Figure A-1 shows the hierarchical structure of information in the status registers
(ascending from left to right).

Status Reporting System



Remote Control BasicsR&S®SGS100A

303User Manual 1173.9105.02 ─ 12

Figure A-1: Graphical overview of the status registers hierarchy

OPER = Operation Status Summary Bit
RQS/MSS = Service Request Generation
ESB = Standard Event Status Summary Bit
MAV = Message Available in Output Queue
QUES = Questionable Status Summary Bit
2 = Error- /Event-Queue
1, 0 = not used

Note: This legend explains the abbreviations to the Status Byte Register.

The R&S SGS uses the following status registers:
● Status Byte (STB) and Service Request Enable (SRE), see Chapter A.5.3, "Sta-

tus Byte (STB) and Service Request Enable Register (SRE)", on page 306.

Status Reporting System
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● Standard Event Status, i.e. the Event status Register (ESR) and the Event Status
Enable (ESE), see Chapter A.5.4, "Event Status Register (ESR) and Event Status
Enable Register (ESE)", on page 307.

● Questionable Status and Operation Status, the (SCPI status registers, see
Chapter A.5.2, "Structure of a SCPI Status Register", on page 304, Chapter A.5.5,
"Questionable Status Register (STATus:QUEStionable)", on page 307 and Chap-
ter A.5.6, "Operation Status Register (STATus:OPERation)", on page 308.

● Output-Queue
The output queue contains the messages the instrument returns to the controller. It
is not part of the status reporting system but determines the value of the MAV bit in
the STB and thus is represented in the overview.

● Error- /Event-Queue
The error-/event-queue contains all errors and events that have occurred in the
past. When reading the queue, the instrument starts with the first occurred error/
event.

All status registers have the same internal structure.

SRE, ESE
The service request enable register SRE can be used as ENABle part of the STB if the
STB is structured according to SCPI. By analogy, the ESE can be used as the ENABle
part of the ESR.

A.5.2  Structure of a SCPI Status Register

Each standard SCPI register consists of 5 parts. Each part has a width of 16 bits and
has different functions. The individual bits are independent of each other, i.e. each
hardware status is assigned a bit number which is valid for all five parts. Bit 15 (the
most significant bit) is set to zero for all parts. Thus the contents of the register parts
can be processed by the controller as positive integers.

Figure A-2: The status-register model

Status Reporting System
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Description of the five status register parts

The five parts of a SCPI register have different properties and functions:

● CONDition
The CONDition part is written into directly by the hardware or the sum bit of the
next lower register. Its contents reflect the current instrument status. This register
part can only be read, but not written into or cleared. Its contents are not affected
by reading.

● PTRansition / NTRansition
The two transition register parts define which state transition of the CONDition
part (none, 0 to 1, 1 to 0 or both) is stored in the EVENt part.
The Positive-TRansition part acts as a transition filter. When a bit of the
CONDition part is changed from 0 to 1, the associated PTR bit decides whether
the EVENt bit is set to 1.

– PTR bit =1: the EVENt bit is set.

– PTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.
The Negative-TRansition part also acts as a transition filter. When a bit of the
CONDition part is changed from 1 to 0, the associated NTR bit decides whether
the EVENt bit is set to 1.

– NTR bit =1: the EVENt bit is set.

– NTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.

● EVENt
The EVENt part indicates whether an event has occurred since the last reading, it
is the "memory" of the condition part. It only indicates events passed on by the
transition filters. It is permanently updated by the instrument. This part can only be
read by the user. Reading the register clears it. This part is often equated with the
entire register.

● ENABle
The ENABle part determines whether the associated EVENt bit contributes to the
sum bit (see below). Each bit of the EVENt part is "ANDed" with the associated
ENABle bit (symbol '&'). The results of all logical operations of this part are passed
on to the sum bit via an "OR" function (symbol '+').
ENABle bit = 0: the associated EVENt bit does not contribute to the sum bit
ENABle bit = 1: if the associated EVENt bit is "1", the sum bit is set to "1" as well.
This part can be written into and read by the user as required. Its contents are not
affected by reading.

Sum bit

The sum bit is obtained from the EVENt and ENABle part for each register. The result
is then entered into a bit of the CONDition part of the higher-order register.

Status Reporting System
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The instrument automatically generates the sum bit for each register. Thus an event
can lead to a service request throughout all levels of the hierarchy.

A.5.3  Status Byte (STB) and Service Request Enable Register (SRE)

The STatus Byte (STB) is already defined in IEEE 488.2. It provides a rough over-
view of the instrument status by collecting the pieces of information of the lower regis-
ters. A special feature is that bit 6 acts as the sum bit of the remaining bits of the status
byte.

The STB is read using the command *STB? or a serial poll.

The STatus Byte (STB) is linked to the Service Request Enable (SRE) register.
Each bit of the STB is assigned a bit in the SRE. Bit 6 of the SRE is ignored. If a bit is
set in the SRE and the associated bit in the STB changes from 0 to 1, a service
request (SRQ) is generated. The SRE can be set using the command *SRE and read
using the command *SRE?.

Table A-5: Meaning of the bits used in the status byte

Bit No. Meaning

0...1 Not used

2 Error Queue not empty

The bit is set when an entry is made in the error queue. If this bit is enabled by the SRE, each
entry of the error queue generates a service request. Thus an error can be recognized and
specified in greater detail by polling the error queue. The poll provides an informative error mes-
sage. This procedure is to be recommended since it considerably reduces the problems
involved with remote control.

3 QUEStionable status register summary bit

The bit is set if an EVENt bit is set in the QUEStionable status register and the associated
ENABle bit is set to 1. A set bit indicates a questionable instrument status, which can be speci-
fied in greater detail by querying the STATus:QUEStionable status register.

4 MAV bit (message available)

The bit is set if a message is available in the output queue which can be read. This bit can be
used to enable data to be automatically read from the instrument to the controller.

5 ESB bit

Sum bit of the event status register. It is set if one of the bits in the event status register is set
and enabled in the event status enable register. Setting of this bit indicates a serious error which
can be specified in greater detail by polling the event status register.

6 MSS bit (master status summary bit)

The bit is set if the instrument triggers a service request. This is the case if one of the other bits
of this registers is set together with its mask bit in the service request enable register SRE.

7 STATus:OPERation status register summary bit

The bit is set if an EVENt bit is set in the OPERation status register and the associated
ENABle bit is set to 1. A set bit indicates that the instrument is just performing an action. The
type of action can be determined by querying the STATus:OPERation status register.

Status Reporting System
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A.5.4  Event Status Register (ESR) and Event Status Enable Register
(ESE)

The ESR is defined in IEEE 488.2. It can be compared with the EVENt part of a SCPI
register. The event status register can be read out using command *ESR?.

The ESE corresponds to the ENABle part of a SCPI register. If a bit is set in the ESE
and the associated bit in the ESR changes from 0 to 1, the ESB bit in the STB is set.
The ESE register can be set using the command *ESE and read using the command
*ESE?.

Table A-6: Meaning of the bits used in the event status register

Bit No. Meaning

0 Operation Complete

This bit is set on receipt of the command *OPC exactly when all previous commands have been
executed.

1 Not used

2 Query Error

This bit is set if either the controller wants to read data from the instrument without having sent a
query, or if it does not fetch requested data and sends new instructions to the instrument
instead. The cause is often a query which is faulty and hence cannot be executed.

3 Device-dependent Error

This bit is set if a device-dependent error occurs. An error message with a number between
-300 and -399 or a positive error number, which denotes the error in greater detail, is entered
into the error queue.

4 Execution Error

This bit is set if a received command is syntactically correct but cannot be performed for other
reasons. An error message with a number between -200 and -300, which denotes the error in
greater detail, is entered into the error queue.

5 Command Error

This bit is set if a command is received, which is undefined or syntactically incorrect. An error
message with a number between -100 and -200, which denotes the error in greater detail, is
entered into the error queue.

6 User Request

This bit is set when the instrument is switched over to manual control.

7 Power On (supply voltage on)

This bit is set on switching on the instrument.

A.5.5  Questionable Status Register (STATus:QUEStionable)

This register contains information on questionable instrument states. Such states may
occur when the instrument is not operated in compliance with its specifications.

To read the register, use the query commands STAT:QUEST:COND? or
STAT:QUEST[:EVEN]?.

Status Reporting System
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Table A-7: Meaning of the bits used in the questionable status register

Bit No. Meaning

0–15 Not used

A.5.6  Operation Status Register (STATus:OPERation)

This condition part contains information on the actions currently being performed by
the instrument, while the event part contains information on the actions performed by
the instrument since the last readout of the register.

To read the register, use the query commands STAT:OPER:COND? or
STAT:OPER[:EVEN]?.

Table A-8: Meaning of the bits used in the operation status register

Bit No. Meaning

0 Calibrating

The bit is set during the calibration phase.

1–2 Not used

3 Sweeping

This bit is set during a sweep in automatic or single mode.

4–15 Not used

A.5.7  Application of the Status Reporting System

The purpose of the status reporting system is to monitor the status of one or several
devices in a measuring system. To do this and react appropriately, the controller must
receive and evaluate the information of all devices. The following standard methods
are used:

● Service request (SRQ) initiated by the instrument
● Serial poll of all devices in the bus system, initiated by the controller to find out

who sent an SRQ and why
● Query of a specific instrument status by commands
● Query of the error queue

A.5.7.1  Service Request

Under certain circumstances, the instrument can send a service request (SRQ) to the
controller. Usually this service request initiates an interrupt at the controller, to which
the control program can react appropriately. An SRQ is always initiated if one or sev-
eral of bits 2, 4 or 5 of the status byte are set and enabled in the SRE. Each of these
bits combines the information of the error queue or the output buffer. To use the possi-
bilities of the service request effectively, all bits should be set to "1" in the enable regis-
ters SRE and ESE.

Status Reporting System
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Example: 
Use command *OPC to generate an SRQ .

*ESE 1 - set bit 0 of ESE (Operation Complete)

*SRE 32 - set bit 5 of SRE (ESB).

After its settings have been completed, the instrument generates an SRQ.

The SRQ is the only possibility for the instrument to become active on its own. Each
controller program should set the instrument such that a service request is initiated in
the case of malfunction. The program should react appropriately to the service request.

A.5.7.2  Serial Poll

In a serial poll, just as with command *STB, the status byte of an instrument is queried.
However, the query is realized via interface messages and is thus clearly faster.

The serial poll method is defined in IEEE 488.1 and used to be the only standard pos-
sibility for different instruments to poll the status byte. The method also works for
instruments which do not adhere to SCPI or IEEE 488.2.

The serial poll is mainly used to obtain a fast overview of the state of several instru-
ments connected to the controller.

A.5.7.3  Query of an instrument status

Each part of any status register can be read using queries. There are two types of
commands:

● The common commands *ESR?, *IDN?, *IST?, *STB? query the higher-level
registers.

● The commands of the STATus system query the SCPI registers
(STATus:QUEStionable...)

The returned value is always a decimal number that represents the bit pattern of the
queried register. This number is evaluated by the controller program.

Queries are usually used after an SRQ in order to obtain more detailed information on
the cause of the SRQ.

A.5.7.4  Error Queue

Each error state in the instrument leads to an entry in the error queue. The entries of
the error queue are detailed plain text error messages that can be looked up in the
Error Log or queried via remote control using SYSTem:ERRor[:NEXT]?. Each call of
SYSTem:ERRor[:NEXT]? provides one entry from the error queue. If no error mes-
sages are stored there any more, the instrument responds with 0, "No error".

The error queue should be queried after every SRQ in the controller program as the
entries describe the cause of an error more precisely than the status registers. Espe-
cially in the test phase of a controller program the error queue should be queried regu-
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larly since faulty commands from the controller to the instrument are recorded there as
well.

A.5.8  Reset Values of the Status Reporting System

The following table contains the different commands and events causing the status
reporting system to be reset. None of the commands, except of *RST and
SYSTem:PRESet affect the functional instrument settings. In particular, DCL does not
change the instrument settings.

Table A-9: Resetting the status reporting system

Event Switching on supply
voltage

Power-On-Status-
Clear

DCL,
SDC
(Device
Clear,
Selected
Device
Clear)

*RST or
SYSTem:
PRESet

STATus:
PRESet

*CLS

Effect 0 1

Clear STB, ESR - Yes - - - Yes

Clear SRE, ESE - Yes - - - -

Clear PPE - Yes - - - -

Clear error queue Yes Yes - - - Yes

Clear output buffer Yes Yes Yes 1) 1) 1)

Clear command processing
and input buffer

Yes Yes Yes - - -

1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINA-
TOR> clears the output buffer.

A.6  General Programming Recommendations

Initial instrument status before changing settings

Manual operation is designed for maximum possible operating convenience. In con-
trast, the priority of remote control is the "predictability" of the instrument status. Thus,
when a command attempts to define incompatible settings, the command is ignored
and the instrument status remains unchanged, i.e. other settings are not automatically
adapted. Therefore, control programs should always define an initial instrument status
(e.g. using the *RST command) and then implement the required settings.

Command sequence

As a general rule, send commands and queries in different program messages. Other-
wise, the result of the query may vary depending on which operation is performed first
(see also Preventing Overlapping Execution).

General Programming Recommendations
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Reacting to malfunctions

The service request is the only possibility for the instrument to become active on its
own. Each controller program should instruct the instrument to initiate a service
request in case of malfunction. The program should react appropriately to the service
request.

Error queues

The error queue should be queried after every service request in the controller pro-
gram as the entries describe the cause of an error more precisely than the status regis-
ters. Especially in the test phase of a controller program the error queue should be
queried regularly since faulty commands from the controller to the instrument are
recorded there as well.

General Programming Recommendations
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B  Telnet program examples
The following program example shows a simple TcpClient class that is intended to
explain on how to get started with programming of sockets.

The example sets up a socket communication to R&S SGS and opens a simple user
interface, very similar to the telnet, which allows input of commands. To enable real
automation, further development of the program is required.

TcpClient.h

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

TcpClient.cpp

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
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    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

#include <netdb.h>
#include <netinet/in.h>
#include <unistd.h>
#include "TcpClient.h"
TcpClient::TcpClient()
: currentHostName( "" )
, currentPort( 0 )
, currentSocketDescr( 0 )
, serverAddress ( )
, currentHostInfo( NULL )
, clientIsConnected( false )
, receiveBufferSize( 1024 )
{
}
TcpClient::~TcpClient()
{
  currentHostInfo = NULL;
}

void TcpClient::connectToServer( string &hostname, int port )
{
  currentHostInfo = gethostbyname( hostname.c_str( ) );
  if( currentHostInfo == NULL )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("error connecting host\n" );
  }
  currentHostName = hostname;
  currentPort     = port;
  currentSocketDescr = socket(AF_INET, SOCK_STREAM, 0);
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  if( currentSocketDescr == 0 )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("can't create socket\n" );
  }
  serverAddress.sin_family = currentHostInfo->h_addrtype;
  serverAddress.sin_port   = htons( currentPort );
  memcpy( (char *) &serverAddress.sin_addr.s_addr, 
  currentHostInfo->h_addr_list[0], currentHostInfo->h_length );
  if( connect( currentSocketDescr, ( struct sockaddr *) &serverAddress, 
  sizeof( serverAddress ) ) < 0 )
  {
   throw string("can't connect server\n" );
  }
  clientIsConnected = true;
}
void TcpClient::disconnect( )
{
  if( clientIsConnected )
  {
    close( currentSocketDescr );
  }
  currentSocketDescr = 0;
  currentHostName    = "";
  currentPort        = 0;
  currentHostInfo    = NULL;
  clientIsConnected  = false;
}
void TcpClient::transmit( string &txString )
{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be sent\n");
  }
  char * transmitBuffer = new char[txString.length() +1];
  memcpy( transmitBuffer, txString.c_str(), txString.length() );
  transmitBuffer[txString.length()] = '\n'; //newline is needed!
  if( send( currentSocketDescr, transmitBuffer, txString.length() + 1, 0 ) < 0 )
  {
    throw string("can't transmit data\n");
  }
  delete [] transmitBuffer;
}
void TcpClient::receive( string &rxString )
{
  if( !clientIsConnected )
  {
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  throw string("connection must be established before any data can be received\n");
  }
  char * receiveBuffer = new char[receiveBufferSize];
  memset( receiveBuffer, 0, receiveBufferSize );
  bool receiving = true;
  while( receiving )
  {
    int receivedByteCount = recv( currentSocketDescr, 
    receiveBuffer, receiveBufferSize, 0 );
    if( receivedByteCount < 0 )
    {
      throw string("error while receiving data\n");
    }
    rxString += string( receiveBuffer );
    receiving = ( receivedByteCount == receiveBufferSize );
  }
  delete [] receiveBuffer;
}
string TcpClient::getCurrentHostName( ) const
{
  return currentHostName;
}
int TcpClient::getCurrentPort( ) const
{
  return currentPort;
}

TelnetClient.cpp

#include <iostream>
#include "TcpClient.h"
void printUsage()
{
  cout<<"usage: EthernetRawCommand <server-ip> [scpi-command]"<<endl;
}
int main( int argc, char *argv[] )
{
  int errorCode         = 0; //no error
  bool useSingleCommand = false;
  string singleCommand  = "";
  string hostname       = "";
  int    port           = 5025;
  string input          = "";
  TcpClient client;
  switch( argc )
  {
    case 3:
      useSingleCommand = true;
      singleCommand    = argv[2];
    case 2:
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      hostname         = argv[1];
      break;
    default:
        printUsage();
        return(-1);
  }
  try
  {
    client.connectToServer( hostname, port );
    bool terminate = false;
    while( !terminate )
    {
      char buffer[1024];
      if( useSingleCommand )
      {
        input =  singleCommand; //send string
      }
      else
      {
        cin.getline( buffer, 1024 );
        input = buffer;
        if( input == "end" )
        {
          terminate = true;
        }
      }
      if( !terminate)
      {
        client.transmit( input ); //send string
        int qPos = input.find( "?", 0 );
        //receive string only when needed
        if( qPos > 0 )
        {
          string rcStr = "";
          client.receive( rcStr );
          cout << rcStr << endl;
        }
      }
      if( useSingleCommand )
      {
        terminate = true;
      }
    }
  }catch( const string errorString )
  {
    cout<<errorString<<endl;
  }
  client.disconnect( );
  return errorCode;
}
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